aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2007-06-22 11:43:38 +0000
committerMathieu Arnold <mat@FreeBSD.org>2007-06-22 11:43:38 +0000
commitf865406682ca4f2c5a9deeeaf9c8a45823d79ccb (patch)
treee1438ae3a46fd63ad61167e9b33a297acfa4b309 /www
parent134df675a5562d53d8a4db692b3a5d99a4c74030 (diff)
downloadports-f865406682ca4f2c5a9deeeaf9c8a45823d79ccb.tar.gz
ports-f865406682ca4f2c5a9deeeaf9c8a45823d79ccb.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Template-Alloy/Makefile28
-rw-r--r--www/p5-Template-Alloy/distinfo3
-rw-r--r--www/p5-Template-Alloy/pkg-descr9
-rw-r--r--www/p5-Template-Alloy/pkg-plist20
5 files changed, 61 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 54acc420b03f..c13e8d64da34 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -845,6 +845,7 @@
SUBDIR += p5-Syntax-Highlight-HTML
SUBDIR += p5-Syntax-Highlight-Shell
SUBDIR += p5-Task-Catalyst
+ SUBDIR += p5-Template-Alloy
SUBDIR += p5-Template-GD
SUBDIR += p5-Template-Iterator-AlzaboWrapperCursor
SUBDIR += p5-Template-Multilingual
diff --git a/www/p5-Template-Alloy/Makefile b/www/p5-Template-Alloy/Makefile
new file mode 100644
index 000000000000..82bd9a8e9e60
--- /dev/null
+++ b/www/p5-Template-Alloy/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: www/p5-Template-Alloy
+# Date created: 22 June 2007
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Alloy
+PORTVERSION= 1.004
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Mixing of all of the major template systems
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Alloy.3 Template::Alloy::Compile.3 \
+ Template::Alloy::Context.3 Template::Alloy::Exception.3 \
+ Template::Alloy::HTE.3 Template::Alloy::Iterator.3 \
+ Template::Alloy::Operator.3 Template::Alloy::Parse.3 \
+ Template::Alloy::Play.3 Template::Alloy::TT.3 \
+ Template::Alloy::Tmpl.3 Template::Alloy::VMethod.3 \
+ Template::Alloy::Velocity.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Template-Alloy/distinfo b/www/p5-Template-Alloy/distinfo
new file mode 100644
index 000000000000..2cc95bcb72aa
--- /dev/null
+++ b/www/p5-Template-Alloy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Alloy-1.004.tar.gz) = 6220903d5b6c6901bce9692af97f726a
+SHA256 (Template-Alloy-1.004.tar.gz) = a8216325f9a75887aa466d9ef2c05e04350661036d08ffb11c5999a4cc406cf5
+SIZE (Template-Alloy-1.004.tar.gz) = 145352
diff --git a/www/p5-Template-Alloy/pkg-descr b/www/p5-Template-Alloy/pkg-descr
new file mode 100644
index 000000000000..06337d5f4079
--- /dev/null
+++ b/www/p5-Template-Alloy/pkg-descr
@@ -0,0 +1,9 @@
+Template::Alloy represents the mixing of features and capabilities from all of
+the major mini-language based template systems (support for non-mini-language
+based systems will happen eventually). With Template::Alloy you can use your
+favorite template interface and syntax and get features from each of the other
+major template systems. And Template::Alloy is fast - whether your using
+mod_perl, cgi, or running from the commandline. There is even
+Template::Alloy::XS for getting a little more speed when that is necessary.
+
+WWW: http://search.cpan.org/dist/Template-Alloy
diff --git a/www/p5-Template-Alloy/pkg-plist b/www/p5-Template-Alloy/pkg-plist
new file mode 100644
index 000000000000..a5ce4ff138a4
--- /dev/null
+++ b/www/p5-Template-Alloy/pkg-plist
@@ -0,0 +1,20 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Template/Alloy.pm
+%%SITE_PERL%%/Template/Alloy.pod
+%%SITE_PERL%%/Template/Alloy/Compile.pm
+%%SITE_PERL%%/Template/Alloy/Context.pm
+%%SITE_PERL%%/Template/Alloy/Exception.pm
+%%SITE_PERL%%/Template/Alloy/HTE.pm
+%%SITE_PERL%%/Template/Alloy/Iterator.pm
+%%SITE_PERL%%/Template/Alloy/Operator.pm
+%%SITE_PERL%%/Template/Alloy/Parse.pm
+%%SITE_PERL%%/Template/Alloy/Play.pm
+%%SITE_PERL%%/Template/Alloy/TT.pm
+%%SITE_PERL%%/Template/Alloy/Tmpl.pm
+%%SITE_PERL%%/Template/Alloy/VMethod.pm
+%%SITE_PERL%%/Template/Alloy/Velocity.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Alloy/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Alloy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template
+@dirrmtry %%SITE_PERL%%/Template/Alloy
+@dirrmtry %%SITE_PERL%%/Template