aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-17 08:27:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-17 08:27:46 +0000
commit11cb53bbfad7cc2ae34cecbe79e038295720dc31 (patch)
tree9402602cd2b42756ffffd9242f0a79a6d6552942 /www
parent3b69b89f5c3ca74cad6319c026b28a9b84458224 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/pear-Services_Amazon/Makefile6
-rw-r--r--www/pear-Services_Blogging/Makefile6
-rw-r--r--www/pear-Services_Delicious/Makefile10
-rw-r--r--www/pear-Services_Digg/Makefile48
-rw-r--r--www/pear-Services_Facebook/Makefile38
-rw-r--r--www/pear-Services_GeoNames/Makefile49
-rw-r--r--www/pear-Services_SharedBook/Makefile4
-rw-r--r--www/pear-Services_ShortURL/Makefile29
8 files changed, 18 insertions, 172 deletions
diff --git a/www/pear-Services_Amazon/Makefile b/www/pear-Services_Amazon/Makefile
index ce00393fcefe..a9a5d2cda73c 100644
--- a/www/pear-Services_Amazon/Makefile
+++ b/www/pear-Services_Amazon/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_Amazon
-# Date created: 11 May,2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Services_Amazon
PORTVERSION= 0.9.0
diff --git a/www/pear-Services_Blogging/Makefile b/www/pear-Services_Blogging/Makefile
index a0fe7d483cce..4d6aa95eea39 100644
--- a/www/pear-Services_Blogging/Makefile
+++ b/www/pear-Services_Blogging/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_Blogging
-# Date created: 23 June 2008
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Services_Blogging
PORTVERSION= 0.2.4
diff --git a/www/pear-Services_Delicious/Makefile b/www/pear-Services_Delicious/Makefile
index 5db1ceb2f9d0..713456187a73 100644
--- a/www/pear-Services_Delicious/Makefile
+++ b/www/pear-Services_Delicious/Makefile
@@ -15,15 +15,13 @@ COMMENT= PEAR Client for the del.icio.us web service
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
USE_DOS2UNIX= yes
USE_PHP= openssl
-
-FILES= Services/Delicious.php
-EXAMPLES= addPost.php config.php deletePost.php getDates.php getPosts.php \
- getTags.php renameTag.php
-DOCS= api.txt
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-Services_Digg/Makefile b/www/pear-Services_Digg/Makefile
index 7080ed698989..8c591f0900b5 100644
--- a/www/pear-Services_Digg/Makefile
+++ b/www/pear-Services_Digg/Makefile
@@ -1,59 +1,19 @@
-# Ports collection makefile for: pear-Services_Digg
-# Date created: 17 May 2007
-# Whom: Zhen REN <bg1tpt@gmail.com>
-#
+# Created by: Zhen REN <bg1tpt@gmail.com>
# $FreeBSD$
-#
PORTNAME= Services_Digg
PORTVERSION= 0.4.7
+PORTREVISION= 1
CATEGORIES= www pear
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to Digg's API
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
USE_PHP= curl
-CATEGORY= Services
-FILES= Digg.php Digg/Comments.php Digg/Comment.php Digg/Common.php \
- Digg/GalleryPhoto.php Digg/GalleryPhotos.php Digg/Request.php \
- Digg/Errors.php Digg/Exception.php Digg/Proxy.php Digg/Response.php \
- Digg/Stories.php Digg/Story.php Digg/Topics.php Digg/User.php \
- Digg/Users.php Digg/Response/Common.php Digg/Response/php.php \
- Digg/Response/xml.php Digg/Response/Exception.php
-
-TESTS= 000-services-digg-factory.phpt 001-errors-getAll.phpt \
- 003-errors-getErrorByCode.phpt 005-topics-getAll.phpt \
- 010-user-submissions.phpt 011-user-isFriend.phpt \
- 012-user-isFan.phpt 013-user-comments.phpt \
- 013-user-getFriendsDugg.phpt 013-user-getFriendsSubmissions.phpt \
- 013-user-getFriendsCommented.phpt \
- 013-user-getFriendsUpcoming.phpt 013-user-getFriendsPopular.phpt \
- 014-user-diggs.phpt 020-users-getUserByName.phpt \
- 030-stories-getStoryById.phpt 031-stories-getContainer.phpt \
- 031-stories-getContainerHot.phpt 031-stories-getContainerTop.phpt \
- 032-stories-getContainerPopular.phpt \
- 032-stories-getContainerUpcoming.phpt \
- 033-stories-getStoriesById.phpt 034-stories-comments.phpt \
- 034-stories-diggs.phpt 034-stories-popular.phpt \
- 035-stories-getAll.phpt 035-stories-getStoriesComments.phpt \
- 035-stories-getStoriesDiggs.phpt 036-stories-getStoryByTitle.phpt \
- 037-stories-hot.phpt 037-stories-top.phpt \
- 038-stories-getTopic.phpt 038-stories-getTopicHot.phpt \
- 038-stories-getTopicTop.phpt 040-story-comments.phpt \
- 041-story-getCommentById.phpt 050-comments.phpt \
- 060-comment-replies.phpt 070-proxy-get.phpt \
- 071-proxy-post.phpt 080-exception-toString.phpt \
- 150-request.phpt 200-diggapiuser-isFriend.phpt \
- 201-diggapistories-iteration.phpt tests-config.php
-
-post-extract:
- ${MV} ${WRKSRC}/Services/Digg.php ${WRKSRC}
- ${MV} ${WRKSRC}/Services/Digg ${WRKSRC}
-
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/www/pear-Services_Facebook/Makefile b/www/pear-Services_Facebook/Makefile
index 1d84db1286ea..53a6205d8f84 100644
--- a/www/pear-Services_Facebook/Makefile
+++ b/www/pear-Services_Facebook/Makefile
@@ -12,43 +12,7 @@ BUILD_DEPENDS= ${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
RUN_DEPENDS= ${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
USE_PHP= curl
-
-FILES= Services/Facebook.php \
- Services/Facebook/Users.php \
- Services/Facebook/Share.php \
- Services/Facebook/Profile.php \
- Services/Facebook/Photos.php \
- Services/Facebook/Pages.php \
- Services/Facebook/Notifications.php \
- Services/Facebook/MarketPlace.php \
- Services/Facebook/Groups.php \
- Services/Facebook/Friends.php \
- Services/Facebook/FQL.php \
- Services/Facebook/Feed.php \
- Services/Facebook/FBML.php \
- Services/Facebook/Exception.php \
- Services/Facebook/Events.php \
- Services/Facebook/Data.php \
- Services/Facebook/Common.php \
- Services/Facebook/Connect.php \
- Services/Facebook/Batch.php \
- Services/Facebook/Auth.php \
- Services/Facebook/Application.php \
- Services/Facebook/Admin.php \
- Services/Facebook/MarketPlace/Listing.php
-
-TESTS= AllTests.php Services/AllTests.php \
- Services/Facebook/AdminTest.php Services/Facebook/AllTests.php \
- Services/Facebook/ApplicationTest.php Services/Facebook/AuthTest.php \
- Services/Facebook/BatchTest.php Services/Facebook/CommonTest.php \
- Services/Facebook/ConnectTest.php Services/Facebook/EventsTest.php \
- Services/Facebook/FBMLTest.php Services/Facebook/FQLTest.php \
- Services/Facebook/FeedTest.php Services/Facebook/FriendsTest.php \
- Services/Facebook/GroupsTest.php Services/Facebook/MarketPlaceTest.php \
- Services/Facebook/NotificationsTest.php Services/Facebook/PagesTest.php \
- Services/Facebook/PhotosTest.php Services/Facebook/ProfileTest.php \
- Services/Facebook/ShareTest.php Services/Facebook/UnitTestCommon.php \
- Services/Facebook/UsersTest.php Services/Facebook/skel.php
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-Services_GeoNames/Makefile b/www/pear-Services_GeoNames/Makefile
index 688221175897..764ca986fd09 100644
--- a/www/pear-Services_GeoNames/Makefile
+++ b/www/pear-Services_GeoNames/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_GeoNames
-# Date created: 24 Jan 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Services_GeoNames
PORTVERSION= 1.0.1
@@ -14,47 +10,10 @@ COMMENT= A PHP5 Interface to the GeoNames Public API
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-FILES= Services/GeoNames.php Services/GeoNames/Exception.php
-EXAMPLES= examples1.php
-TESTS= AllTests.php \
- data/test_children.dat data/test_cities.dat \
- data/test_countrycode.dat data/test_countryinfo.dat \
- data/test_countrysubdivision.dat data/test_earthquakes.dat \
- data/test_findnearby.dat data/test_findnearbyplacename.dat \
- data/test_findnearbypostalcodes.dat data/test_findnearbystreets.dat \
- data/test_findnearbyweather.dat data/test_findnearbywikipedia.dat \
- data/test_findnearestaddress.dat data/test_findnearestintersection.dat \
- data/test_get.dat data/test_gtopo30.dat \
- data/test_hierarchy.dat data/test_neighbourhood.dat \
- data/test_neighbours.dat data/test_other_03.dat \
- data/test_other_06.dat data/test_postalcodecountryinfo.dat \
- data/test_postalcodelookup.dat data/test_postalcodesearch.dat \
- data/test_search.dat data/test_siblings.dat \
- data/test_srtm3.dat data/test_timezone.dat \
- data/test_weather.dat data/test_weathericao.dat \
- data/test_wikipediaboundingbox.dat data/test_wikipediasearch.dat \
- setup.php \
- test_children.phpt test_cities.phpt \
- test_countrycode.phpt test_countryinfo.phpt \
- test_countrysubdivision.phpt test_earthquakes.phpt \
- test_findnearby.phpt test_findnearbyplacename.phpt \
- test_findnearbypostalcodes.phpt test_findnearbystreets.phpt \
- test_findnearbyweather.phpt test_findnearbywikipedia.phpt \
- test_findnearestaddress.phpt test_findnearestintersection.phpt \
- test_get.phpt test_gtopo30.phpt \
- test_hierarchy.phpt test_neighbourhood.phpt \
- test_neighbours.phpt test_other_01.phpt \
- test_other_02.phpt test_other_03.phpt \
- test_other_04.phpt test_other_05.phpt \
- test_other_06.phpt test_other_07.phpt \
- test_postalcodecountryinfo.phpt test_postalcodelookup.phpt \
- test_postalcodesearch.phpt test_search.phpt \
- test_siblings.phpt test_srtm3.phpt \
- test_timezone.phpt test_weather.phpt \
- test_weathericao.phpt test_wikipediaboundingbox.phpt \
- test_wikipediasearch.phpt
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-Services_SharedBook/Makefile b/www/pear-Services_SharedBook/Makefile
index dc56ead85f57..fe81ef387dbd 100644
--- a/www/pear-Services_SharedBook/Makefile
+++ b/www/pear-Services_SharedBook/Makefile
@@ -15,9 +15,7 @@ COMMENT= PHP wrapper for SharedBook Open API
BUILD_DEPENDS= ${PEARDIR}/HTTP/Client.php:${PORTSDIR}/www/pear-HTTP_Client
RUN_DEPENDS= ${PEARDIR}/HTTP/Client.php:${PORTSDIR}/www/pear-HTTP_Client
-FILES= Services/SharedBook.php Services/SharedBook/Exception.php
-
-EXAMPLES= example.php photo1.jpg photo2.jpg photo3.jpg photo4.jpg
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-Services_ShortURL/Makefile b/www/pear-Services_ShortURL/Makefile
index f971cd4c8f9f..389f8ad929c7 100644
--- a/www/pear-Services_ShortURL/Makefile
+++ b/www/pear-Services_ShortURL/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_ShortURL
-# Date created: 06 April 2011
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Services_ShortURL
PORTVERSION= 0.3.1
@@ -17,28 +13,7 @@ RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
USE_PHP= simplexml pcre spl
-
-CATEGORY= Services
-PEAR_CATSRC= yes
-
-FILES= ShortURL/Bitly.php \
- ShortURL/Common.php \
- ShortURL/Digg.php \
- ShortURL/Exception/CouldNotExpand.php \
- ShortURL/Exception/CouldNotShorten.php \
- ShortURL/Exception/InvalidOptions.php \
- ShortURL/Exception/NotImplemented.php \
- ShortURL/Exception/UnknownService.php \
- ShortURL/Exception.php \
- ShortURL/Googl.php \
- ShortURL/Interface.php \
- ShortURL/Isgd.php \
- ShortURL/Shortie.php \
- ShortURL/TinyURL.php \
- ShortURL/Trim.php \
- ShortURL.php
-
-TESTS= AllTests.php Services/ShortURLTest.php
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"