aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2019-11-01 21:42:49 +0000
committerKoop Mast <kwm@FreeBSD.org>2019-11-01 21:42:49 +0000
commit487701a3d039489c119dbd3e14f742a6d9c8e24e (patch)
tree11f7a84215946b2ccee54bf648b978aba1a2fda1 /www
parent3d3c23a5d8d40aa5ec520ecd52491bd22ab1a4b1 (diff)
downloadports-487701a3d039489c119dbd3e14f742a6d9c8e24e.tar.gz
ports-487701a3d039489c119dbd3e14f742a6d9c8e24e.zip
MFH: r516196
Update webkit2-gtk3 to 2.26.1. * Drop the NPAPI option, which was removed. This option was used to support gtk+2 plugins (like flash). * Add a note when binutils can be dropped for linking. Security: 92243b6a-5775-4aea-8727-a938058df5ba Approved by: ports-secteam
Notes
Notes: svn path=/branches/2019Q4/; revision=516269
Diffstat (limited to 'www')
-rw-r--r--www/webkit2-gtk3/Makefile19
-rw-r--r--www/webkit2-gtk3/distinfo6
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WebCore_Modules_indexeddb_server_SQLiteIDBBackingStore.cpp19
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WebCore_contentextensions_DFACombiner.cpp13
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WebCore_contentextensions_NFAToDFA.cpp17
-rw-r--r--www/webkit2-gtk3/pkg-plist6
6 files changed, 14 insertions, 66 deletions
diff --git a/www/webkit2-gtk3/Makefile b/www/webkit2-gtk3/Makefile
index c1d887cd413b..f982dce379db 100644
--- a/www/webkit2-gtk3/Makefile
+++ b/www/webkit2-gtk3/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= webkit
-PORTVERSION= 2.24.4
+PORTVERSION= 2.26.1
CATEGORIES= www
MASTER_SITES= https://webkitgtk.org/releases/
PKGNAMESUFFIX= 2-gtk3
@@ -37,7 +37,7 @@ PORTSCOUT= limitw:1,even
USES= bison cmake compiler:c++14-lang gettext gl gnome gperf \
jpeg localbase:ldflags perl5 pkgconfig python:2.7,build \
- sqlite tar:xz
+ sqlite tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build libxml2 libxslt
USE_GL= gl egl glesv2
USE_GSTREAMER1= bad gl
@@ -65,17 +65,15 @@ INSTALL_TARGET= install
BROWSER_PLUGINS_DIR?= ${LOCALBASE}/lib/browser_plugins/symlinks/webkit-gtk3
-OPTIONS_DEFINE= DEBUG GEOIP NPAPI WAYLAND
+OPTIONS_DEFINE= DEBUG GEOIP WAYLAND
OPTIONS_DEFAULT= GEOIP WAYLAND
-OPTIONS_DEFAULT_i386= NPAPI
-OPTIONS_DEFAULT_amd64= NPAPI
OPTIONS_SUB= yes
-NPAPI_DESC= Support gtk2 (NPAPI) based plugins (like flash)
-
# Building WebKit with debugging symbols requires ar and ld with
# support for thin archives. Also see
# https://bugs.webkit.org/show_bug.cgi?id=140384
+# binutils can be removed when 12.0-R and 11.2 and 11.3 are EOL
+# https://svnweb.freebsd.org/base?view=revision&revision=346079
DEBUG_BUILD_DEPENDS= binutils>=0:devel/binutils
DEBUG_CMAKE_ON= -DCMAKE_AR=${LOCALBASE}/bin/ar \
-DCMAKE_RANLIB=${LOCALBASE}/bin/ranlib \
@@ -92,11 +90,10 @@ GEOIP_CMAKE_BOOL= ENABLE_GEOLOCATION
GEOIP_BUILD_DEPENDS= geoclue>=2.4.3:net/geoclue
GEOIP_RUN_DEPENDS= geoclue>=2.4.3:net/geoclue
-NPAPI_CMAKE_BOOL= ENABLE_PLUGIN_PROCESS_GTK2
-NPAPI_USE= GNOME=gtk20
-
WAYLAND_CMAKE_BOOL= ENABLE_WAYLAND_TARGET
-WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
+WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
+ libwpe-1.0.so:www/libwpe \
+ libWPEBackend-fdo-1.0.so:www/wpebackend-fdo
post-patch:
@${REINPLACE_CMD} -e 's|/usr/lib/browser/plugins|${BROWSER_PLUGINS_DIR}|' \
diff --git a/www/webkit2-gtk3/distinfo b/www/webkit2-gtk3/distinfo
index 6e7e4cae72dd..52de168bcdd2 100644
--- a/www/webkit2-gtk3/distinfo
+++ b/www/webkit2-gtk3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1567099248
-SHA256 (gnome/webkitgtk-2.24.4.tar.xz) = 8668b129c026624ec226a4cccf4995f9d26f3e88fc28ab75b0e965f3c32b7dd8
-SIZE (gnome/webkitgtk-2.24.4.tar.xz) = 17575784
+TIMESTAMP = 1569330516
+SHA256 (gnome/webkitgtk-2.26.1.tar.xz) = 6b4b21801d2b1008422a1075dbd6fb4ae8b5127503faf657cf9671289d9cd155
+SIZE (gnome/webkitgtk-2.26.1.tar.xz) = 19327444
diff --git a/www/webkit2-gtk3/files/patch-Source_WebCore_Modules_indexeddb_server_SQLiteIDBBackingStore.cpp b/www/webkit2-gtk3/files/patch-Source_WebCore_Modules_indexeddb_server_SQLiteIDBBackingStore.cpp
deleted file mode 100644
index 98073d81d40f..000000000000
--- a/www/webkit2-gtk3/files/patch-Source_WebCore_Modules_indexeddb_server_SQLiteIDBBackingStore.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
-.build/lib/libwebkit2gtk-4.0.so: undefined reference to `JSC::JSObject::didBecomePrototype()'
-
-https://trac.webkit.org/changeset/246922/webkit
-
---- Source/WebCore/Modules/indexeddb/server/SQLiteIDBBackingStore.cpp.orig 2019-08-26 14:55:44 UTC
-+++ Source/WebCore/Modules/indexeddb/server/SQLiteIDBBackingStore.cpp
-@@ -48,11 +48,8 @@
- #include "SQLiteTransaction.h"
- #include "ThreadSafeDataBuffer.h"
- #include <JavaScriptCore/AuxiliaryBarrierInlines.h>
--#include <JavaScriptCore/HeapInlines.h>
--#include <JavaScriptCore/JSCJSValueInlines.h>
--#include <JavaScriptCore/JSGlobalObject.h>
-+#include <JavaScriptCore/JSCInlines.h>
- #include <JavaScriptCore/StrongInlines.h>
--#include <JavaScriptCore/StructureInlines.h>
- #include <wtf/FileSystem.h>
- #include <wtf/NeverDestroyed.h>
- #include <wtf/text/StringConcatenateNumbers.h>
diff --git a/www/webkit2-gtk3/files/patch-Source_WebCore_contentextensions_DFACombiner.cpp b/www/webkit2-gtk3/files/patch-Source_WebCore_contentextensions_DFACombiner.cpp
deleted file mode 100644
index 6dbd88961f63..000000000000
--- a/www/webkit2-gtk3/files/patch-Source_WebCore_contentextensions_DFACombiner.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-https://trac.webkit.org/changeset/244591
-
---- Source/WebCore/contentextensions/DFACombiner.cpp.orig 2019-02-12 11:21:18 UTC
-+++ Source/WebCore/contentextensions/DFACombiner.cpp
-@@ -37,7 +37,7 @@ namespace WebCore {
- namespace ContentExtensions {
-
- class DFAMerger {
-- typedef MutableRangeList<char, uint64_t, 128> CombinedTransitionsMutableRangeList;
-+ typedef MutableRangeList<signed char, uint64_t, 128> CombinedTransitionsMutableRangeList;
-
- enum class WhichDFA {
- A,
diff --git a/www/webkit2-gtk3/files/patch-Source_WebCore_contentextensions_NFAToDFA.cpp b/www/webkit2-gtk3/files/patch-Source_WebCore_contentextensions_NFAToDFA.cpp
deleted file mode 100644
index 7460f54c8dea..000000000000
--- a/www/webkit2-gtk3/files/patch-Source_WebCore_contentextensions_NFAToDFA.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
-https://trac.webkit.org/changeset/244591
-
---- Source/WebCore/contentextensions/NFAToDFA.cpp.orig 2019-02-12 11:21:18 UTC
-+++ Source/WebCore/contentextensions/NFAToDFA.cpp
-@@ -41,9 +41,9 @@ namespace WebCore {
-
- namespace ContentExtensions {
-
--typedef MutableRange<char, NFANodeIndexSet> NFANodeRange;
--typedef MutableRangeList<char, NFANodeIndexSet> NFANodeRangeList;
--typedef MutableRangeList<char, NFANodeIndexSet, 128> PreallocatedNFANodeRangeList;
-+typedef MutableRange<signed char, NFANodeIndexSet> NFANodeRange;
-+typedef MutableRangeList<signed char, NFANodeIndexSet> NFANodeRangeList;
-+typedef MutableRangeList<signed char, NFANodeIndexSet, 128> PreallocatedNFANodeRangeList;
- typedef Vector<uint32_t, 0, ContentExtensionsOverflowHandler> UniqueNodeList;
- typedef Vector<UniqueNodeList, 0, ContentExtensionsOverflowHandler> NFANodeClosures;
-
diff --git a/www/webkit2-gtk3/pkg-plist b/www/webkit2-gtk3/pkg-plist
index 42af317e9c39..e8137a3212c7 100644
--- a/www/webkit2-gtk3/pkg-plist
+++ b/www/webkit2-gtk3/pkg-plist
@@ -46,6 +46,7 @@ include/webkitgtk-4.0/webkit2/WebKitFindController.h
include/webkitgtk-4.0/webkit2/WebKitFormSubmissionRequest.h
include/webkitgtk-4.0/webkit2/WebKitForwardDeclarations.h
include/webkitgtk-4.0/webkit2/WebKitFrame.h
+include/webkitgtk-4.0/webkit2/WebKitGeolocationManager.h
include/webkitgtk-4.0/webkit2/WebKitGeolocationPermissionRequest.h
include/webkitgtk-4.0/webkit2/WebKitHitTestResult.h
include/webkitgtk-4.0/webkit2/WebKitInstallMissingMediaPluginsPermissionRequest.h
@@ -213,10 +214,10 @@ lib/girepository-1.0/WebKit2-4.0.typelib
lib/girepository-1.0/WebKit2WebExtension-4.0.typelib
lib/libjavascriptcoregtk-4.0.so
lib/libjavascriptcoregtk-4.0.so.18
-lib/libjavascriptcoregtk-4.0.so.18.13.7
+lib/libjavascriptcoregtk-4.0.so.18.14.6
lib/libwebkit2gtk-4.0.so
lib/libwebkit2gtk-4.0.so.37
-lib/libwebkit2gtk-4.0.so.37.37.6
+lib/libwebkit2gtk-4.0.so.37.39.2
lib/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
libdata/pkgconfig/javascriptcoregtk-4.0.pc
libdata/pkgconfig/webkit2gtk-4.0.pc
@@ -224,7 +225,6 @@ libdata/pkgconfig/webkit2gtk-web-extension-4.0.pc
libexec/webkit2gtk-4.0/MiniBrowser
libexec/webkit2gtk-4.0/WebKitNetworkProcess
libexec/webkit2gtk-4.0/WebKitPluginProcess
-%%NPAPI%%libexec/webkit2gtk-4.0/WebKitPluginProcess2
libexec/webkit2gtk-4.0/WebKitWebProcess
libexec/webkit2gtk-4.0/jsc
share/gir-1.0/JavaScriptCore-4.0.gir