aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-05-23 03:50:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-05-23 03:50:10 +0000
commit7b72eeb5ddf6577c36be2ca1efb9e56fade13857 (patch)
treec2e7e4181eb5fa8fdab12a1086f8a2828a70815e /www
parent58c84f0a299d248dcf6aa9d12d9d1b03dc72e974 (diff)
downloadports-7b72eeb5ddf6577c36be2ca1efb9e56fade13857.tar.gz
ports-7b72eeb5ddf6577c36be2ca1efb9e56fade13857.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/npm2/Makefile2
-rw-r--r--www/npm2/distinfo5
-rw-r--r--www/npm2/pkg-plist136
3 files changed, 73 insertions, 70 deletions
diff --git a/www/npm2/Makefile b/www/npm2/Makefile
index 43e749c4d813..99f6ca4c4bea 100644
--- a/www/npm2/Makefile
+++ b/www/npm2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= npm
-PORTVERSION= 2.15.3
+PORTVERSION= 2.15.6
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
PKGNAMESUFFIX= 2
diff --git a/www/npm2/distinfo b/www/npm2/distinfo
index 575c69c51719..1958a7ad9cfa 100644
--- a/www/npm2/distinfo
+++ b/www/npm2/distinfo
@@ -1,2 +1,3 @@
-SHA256 (npm-2.15.3.tar.xz) = bd42f72e64ef0b83d3b02b66f6009cca0259be06ad9fecade10bc03e6ce27ea9
-SIZE (npm-2.15.3.tar.xz) = 2612884
+TIMESTAMP = 1463938978
+SHA256 (npm-2.15.6.tar.xz) = 804a442eac591e9912899d377c6534c97d336959baec07b3c3ab34989c3dfe5d
+SIZE (npm-2.15.6.tar.xz) = 2662216
diff --git a/www/npm2/pkg-plist b/www/npm2/pkg-plist
index 5671884531f2..1e316e9c5005 100644
--- a/www/npm2/pkg-plist
+++ b/www/npm2/pkg-plist
@@ -503,18 +503,8 @@ lib/node_modules/npm/node_modules/async-some/test/simple.js
lib/node_modules/npm/node_modules/block-stream/LICENCE
lib/node_modules/npm/node_modules/block-stream/LICENSE
lib/node_modules/npm/node_modules/block-stream/README.md
-lib/node_modules/npm/node_modules/block-stream/bench/block-stream-pause.js
-lib/node_modules/npm/node_modules/block-stream/bench/block-stream.js
-lib/node_modules/npm/node_modules/block-stream/bench/dropper-pause.js
-lib/node_modules/npm/node_modules/block-stream/bench/dropper.js
lib/node_modules/npm/node_modules/block-stream/block-stream.js
lib/node_modules/npm/node_modules/block-stream/package.json
-lib/node_modules/npm/node_modules/block-stream/test/basic.js
-lib/node_modules/npm/node_modules/block-stream/test/nopad-thorough.js
-lib/node_modules/npm/node_modules/block-stream/test/nopad.js
-lib/node_modules/npm/node_modules/block-stream/test/pause-resume.js
-lib/node_modules/npm/node_modules/block-stream/test/thorough.js
-lib/node_modules/npm/node_modules/block-stream/test/two-stream.js
lib/node_modules/npm/node_modules/char-spinner/LICENSE
lib/node_modules/npm/node_modules/char-spinner/README.md
lib/node_modules/npm/node_modules/char-spinner/package.json
@@ -609,6 +599,7 @@ lib/node_modules/npm/node_modules/editor/index.js
lib/node_modules/npm/node_modules/editor/package.json
lib/node_modules/npm/node_modules/fs-vacuum/.eslintrc
lib/node_modules/npm/node_modules/fs-vacuum/.npmignore
+lib/node_modules/npm/node_modules/fs-vacuum/.travis.yml
lib/node_modules/npm/node_modules/fs-vacuum/LICENSE
lib/node_modules/npm/node_modules/fs-vacuum/README.md
lib/node_modules/npm/node_modules/fs-vacuum/package.json
@@ -620,6 +611,9 @@ lib/node_modules/npm/node_modules/fs-vacuum/test/no-entries-no-purge.js
lib/node_modules/npm/node_modules/fs-vacuum/test/no-entries-with-link-purge.js
lib/node_modules/npm/node_modules/fs-vacuum/test/no-entries-with-purge.js
lib/node_modules/npm/node_modules/fs-vacuum/test/other-directories-no-purge.js
+lib/node_modules/npm/node_modules/fs-vacuum/test/racy-entries-eexist.js
+lib/node_modules/npm/node_modules/fs-vacuum/test/racy-entries-enotempty.js
+lib/node_modules/npm/node_modules/fs-vacuum/test/racy-entries.js
lib/node_modules/npm/node_modules/fs-vacuum/vacuum.js
lib/node_modules/npm/node_modules/fs-write-stream-atomic/.npmignore
lib/node_modules/npm/node_modules/fs-write-stream-atomic/.travis.yml
@@ -824,9 +818,6 @@ lib/node_modules/npm/node_modules/lockfile/test/fixtures/bad-child.js
lib/node_modules/npm/node_modules/lockfile/test/fixtures/child.js
lib/node_modules/npm/node_modules/lockfile/test/retry-time.js
lib/node_modules/npm/node_modules/lockfile/test/stale-contention.js
-lib/node_modules/npm/node_modules/lru-cache/.npmignore
-lib/node_modules/npm/node_modules/lru-cache/.travis.yml
-lib/node_modules/npm/node_modules/lru-cache/CONTRIBUTORS
lib/node_modules/npm/node_modules/lru-cache/LICENSE
lib/node_modules/npm/node_modules/lru-cache/README.md
lib/node_modules/npm/node_modules/lru-cache/lib/lru-cache.js
@@ -834,13 +825,17 @@ lib/node_modules/npm/node_modules/lru-cache/node_modules/pseudomap/LICENSE
lib/node_modules/npm/node_modules/lru-cache/node_modules/pseudomap/README.md
lib/node_modules/npm/node_modules/lru-cache/node_modules/pseudomap/map.js
lib/node_modules/npm/node_modules/lru-cache/node_modules/pseudomap/package.json
+lib/node_modules/npm/node_modules/lru-cache/node_modules/pseudomap/pseudomap.js
lib/node_modules/npm/node_modules/lru-cache/node_modules/pseudomap/test/basic.js
+lib/node_modules/npm/node_modules/lru-cache/node_modules/yallist/.npmignore
+lib/node_modules/npm/node_modules/lru-cache/node_modules/yallist/.travis.yml
+lib/node_modules/npm/node_modules/lru-cache/node_modules/yallist/CONTRIBUTING.md
+lib/node_modules/npm/node_modules/lru-cache/node_modules/yallist/LICENSE
+lib/node_modules/npm/node_modules/lru-cache/node_modules/yallist/README.md
+lib/node_modules/npm/node_modules/lru-cache/node_modules/yallist/package.json
+lib/node_modules/npm/node_modules/lru-cache/node_modules/yallist/test/basic.js
+lib/node_modules/npm/node_modules/lru-cache/node_modules/yallist/yallist.js
lib/node_modules/npm/node_modules/lru-cache/package.json
-lib/node_modules/npm/node_modules/lru-cache/test/basic.js
-lib/node_modules/npm/node_modules/lru-cache/test/foreach.js
-lib/node_modules/npm/node_modules/lru-cache/test/memory-leak.js
-lib/node_modules/npm/node_modules/lru-cache/test/overflow.js
-lib/node_modules/npm/node_modules/lru-cache/test/serialize.js
lib/node_modules/npm/node_modules/minimatch/LICENSE
lib/node_modules/npm/node_modules/minimatch/README.md
lib/node_modules/npm/node_modules/minimatch/minimatch.js
@@ -1928,6 +1923,7 @@ lib/node_modules/npm/node_modules/nopt/lib/nopt.js
lib/node_modules/npm/node_modules/nopt/package.json
lib/node_modules/npm/node_modules/nopt/test/basic.js
lib/node_modules/npm/node_modules/normalize-git-url/.npmignore
+lib/node_modules/npm/node_modules/normalize-git-url/.travis.yml
lib/node_modules/npm/node_modules/normalize-git-url/CHANGELOG.md
lib/node_modules/npm/node_modules/normalize-git-url/LICENSE
lib/node_modules/npm/node_modules/normalize-git-url/README.md
@@ -2202,39 +2198,23 @@ lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/has-uni
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/LICENSE
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/README.md
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.repeat/LICENSE
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.repeat/README.md
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.repeat/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.repeat/package.json
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.tostring/LICENSE
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.tostring/README.md
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.tostring/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.tostring/package.json
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/package.json
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/LICENSE
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/README.md
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.repeat/LICENSE
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.repeat/README.md
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.repeat/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.repeat/package.json
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.tostring/LICENSE
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.tostring/README.md
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.tostring/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.tostring/package.json
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/package.json
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/LICENSE
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/README.md
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.repeat/LICENSE
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.repeat/README.md
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.repeat/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.repeat/package.json
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.tostring/LICENSE
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.tostring/README.md
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.tostring/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.tostring/package.json
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/package.json
+lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.repeat/LICENSE
+lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.repeat/README.md
+lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.repeat/index.js
+lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.repeat/package.json
+lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.tostring/LICENSE
+lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.tostring/README.md
+lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.tostring/index.js
+lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/lodash.tostring/package.json
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/package.json
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/progress-bar.js
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/test/progress-bar.js
@@ -2337,6 +2317,7 @@ lib/node_modules/npm/node_modules/read-package-json/node_modules/json-parse-help
lib/node_modules/npm/node_modules/read-package-json/node_modules/json-parse-helpfulerror/README.md
lib/node_modules/npm/node_modules/read-package-json/node_modules/json-parse-helpfulerror/index.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/json-parse-helpfulerror/node_modules/jju/.npmignore
+lib/node_modules/npm/node_modules/read-package-json/node_modules/json-parse-helpfulerror/node_modules/jju/LICENSE
lib/node_modules/npm/node_modules/read-package-json/node_modules/json-parse-helpfulerror/node_modules/jju/README.md
lib/node_modules/npm/node_modules/read-package-json/node_modules/json-parse-helpfulerror/node_modules/jju/index.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/json-parse-helpfulerror/node_modules/jju/lib/analyze.js
@@ -2369,7 +2350,6 @@ lib/node_modules/npm/node_modules/read-package-json/test/fixtures/readmes/readme
lib/node_modules/npm/node_modules/read-package-json/test/helpful.js
lib/node_modules/npm/node_modules/read-package-json/test/non-json.js
lib/node_modules/npm/node_modules/read-package-json/test/readmes.js
-lib/node_modules/npm/node_modules/read-package-json/zunda
lib/node_modules/npm/node_modules/read/LICENSE
lib/node_modules/npm/node_modules/read/README.md
lib/node_modules/npm/node_modules/read/lib/read.js
@@ -2380,30 +2360,48 @@ lib/node_modules/npm/node_modules/read/node_modules/mute-stream/package.json
lib/node_modules/npm/node_modules/read/node_modules/mute-stream/test/basic.js
lib/node_modules/npm/node_modules/read/package.json
lib/node_modules/npm/node_modules/readable-stream/.npmignore
+lib/node_modules/npm/node_modules/readable-stream/.travis.yml
lib/node_modules/npm/node_modules/readable-stream/LICENSE
lib/node_modules/npm/node_modules/readable-stream/README.md
+lib/node_modules/npm/node_modules/readable-stream/doc/stream.markdown
+lib/node_modules/npm/node_modules/readable-stream/doc/wg-meetings/2015-01-30.md
lib/node_modules/npm/node_modules/readable-stream/duplex.js
-lib/node_modules/npm/node_modules/readable-stream/float.patch
lib/node_modules/npm/node_modules/readable-stream/lib/_stream_duplex.js
lib/node_modules/npm/node_modules/readable-stream/lib/_stream_passthrough.js
lib/node_modules/npm/node_modules/readable-stream/lib/_stream_readable.js
lib/node_modules/npm/node_modules/readable-stream/lib/_stream_transform.js
lib/node_modules/npm/node_modules/readable-stream/lib/_stream_writable.js
+lib/node_modules/npm/node_modules/readable-stream/node_modules/core-util-is/LICENSE
lib/node_modules/npm/node_modules/readable-stream/node_modules/core-util-is/README.md
lib/node_modules/npm/node_modules/readable-stream/node_modules/core-util-is/float.patch
lib/node_modules/npm/node_modules/readable-stream/node_modules/core-util-is/lib/util.js
lib/node_modules/npm/node_modules/readable-stream/node_modules/core-util-is/package.json
-lib/node_modules/npm/node_modules/readable-stream/node_modules/core-util-is/util.js
+lib/node_modules/npm/node_modules/readable-stream/node_modules/core-util-is/test.js
+lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/.npmignore
+lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/.travis.yml
+lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/Makefile
lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/README.md
-lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/build/build.js
lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/component.json
lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/index.js
lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/package.json
+lib/node_modules/npm/node_modules/readable-stream/node_modules/isarray/test.js
+lib/node_modules/npm/node_modules/readable-stream/node_modules/process-nextick-args/.travis.yml
+lib/node_modules/npm/node_modules/readable-stream/node_modules/process-nextick-args/index.js
+lib/node_modules/npm/node_modules/readable-stream/node_modules/process-nextick-args/license.md
+lib/node_modules/npm/node_modules/readable-stream/node_modules/process-nextick-args/package.json
+lib/node_modules/npm/node_modules/readable-stream/node_modules/process-nextick-args/readme.md
+lib/node_modules/npm/node_modules/readable-stream/node_modules/process-nextick-args/test.js
lib/node_modules/npm/node_modules/readable-stream/node_modules/string_decoder/.npmignore
lib/node_modules/npm/node_modules/readable-stream/node_modules/string_decoder/LICENSE
lib/node_modules/npm/node_modules/readable-stream/node_modules/string_decoder/README.md
lib/node_modules/npm/node_modules/readable-stream/node_modules/string_decoder/index.js
lib/node_modules/npm/node_modules/readable-stream/node_modules/string_decoder/package.json
+lib/node_modules/npm/node_modules/readable-stream/node_modules/util-deprecate/History.md
+lib/node_modules/npm/node_modules/readable-stream/node_modules/util-deprecate/LICENSE
+lib/node_modules/npm/node_modules/readable-stream/node_modules/util-deprecate/README.md
+lib/node_modules/npm/node_modules/readable-stream/node_modules/util-deprecate/browser.js
+lib/node_modules/npm/node_modules/readable-stream/node_modules/util-deprecate/node.js
+lib/node_modules/npm/node_modules/readable-stream/node_modules/util-deprecate/package.json
lib/node_modules/npm/node_modules/readable-stream/package.json
lib/node_modules/npm/node_modules/readable-stream/passthrough.js
lib/node_modules/npm/node_modules/readable-stream/readable.js
@@ -2442,22 +2440,11 @@ lib/node_modules/npm/node_modules/request/node_modules/aws-sign2/README.md
lib/node_modules/npm/node_modules/request/node_modules/aws-sign2/index.js
lib/node_modules/npm/node_modules/request/node_modules/aws-sign2/package.json
lib/node_modules/npm/node_modules/request/node_modules/aws4/.npmignore
+lib/node_modules/npm/node_modules/request/node_modules/aws4/.tern-port
lib/node_modules/npm/node_modules/request/node_modules/aws4/.travis.yml
lib/node_modules/npm/node_modules/request/node_modules/aws4/LICENSE
lib/node_modules/npm/node_modules/request/node_modules/aws4/README.md
lib/node_modules/npm/node_modules/request/node_modules/aws4/aws4.js
-lib/node_modules/npm/node_modules/request/node_modules/aws4/example.js
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/.npmignore
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/.travis.yml
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/CONTRIBUTORS
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/LICENSE
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/README.md
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/lib/lru-cache.js
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/package.json
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/test/basic.js
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/test/foreach.js
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/test/memory-leak.js
-lib/node_modules/npm/node_modules/request/node_modules/aws4/node_modules/lru-cache/test/serialize.js
lib/node_modules/npm/node_modules/request/node_modules/aws4/package.json
lib/node_modules/npm/node_modules/request/node_modules/bl/.npmignore
lib/node_modules/npm/node_modules/request/node_modules/bl/.travis.yml
@@ -2483,11 +2470,14 @@ lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/core-util-is/lib/util.js
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/core-util-is/package.json
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/core-util-is/test.js
+lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/.npmignore
+lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/.travis.yml
+lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/Makefile
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/README.md
-lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/build/build.js
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/component.json
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/index.js
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/package.json
+lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/isarray/test.js
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/process-nextick-args/.travis.yml
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/process-nextick-args/index.js
lib/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/node_modules/process-nextick-args/license.md
@@ -2540,10 +2530,14 @@ lib/node_modules/npm/node_modules/request/node_modules/forever-agent/LICENSE
lib/node_modules/npm/node_modules/request/node_modules/forever-agent/README.md
lib/node_modules/npm/node_modules/request/node_modules/forever-agent/index.js
lib/node_modules/npm/node_modules/request/node_modules/forever-agent/package.json
+lib/node_modules/npm/node_modules/request/node_modules/form-data/.dockerignore
+lib/node_modules/npm/node_modules/request/node_modules/form-data/.editorconfig
+lib/node_modules/npm/node_modules/request/node_modules/form-data/.eslintignore
lib/node_modules/npm/node_modules/request/node_modules/form-data/License
lib/node_modules/npm/node_modules/request/node_modules/form-data/Readme.md
lib/node_modules/npm/node_modules/request/node_modules/form-data/lib/browser.js
lib/node_modules/npm/node_modules/request/node_modules/form-data/lib/form_data.js
+lib/node_modules/npm/node_modules/request/node_modules/form-data/lib/populate.js
lib/node_modules/npm/node_modules/request/node_modules/form-data/node_modules/async/CHANGELOG.md
lib/node_modules/npm/node_modules/request/node_modules/form-data/node_modules/async/LICENSE
lib/node_modules/npm/node_modules/request/node_modules/form-data/node_modules/async/README.md
@@ -2552,6 +2546,7 @@ lib/node_modules/npm/node_modules/request/node_modules/form-data/node_modules/as
lib/node_modules/npm/node_modules/request/node_modules/form-data/node_modules/async/lib/async.js
lib/node_modules/npm/node_modules/request/node_modules/form-data/node_modules/async/package.json
lib/node_modules/npm/node_modules/request/node_modules/form-data/package.json
+lib/node_modules/npm/node_modules/request/node_modules/form-data/wercker.yml
lib/node_modules/npm/node_modules/request/node_modules/har-validator/LICENSE
lib/node_modules/npm/node_modules/request/node_modules/har-validator/README.md
lib/node_modules/npm/node_modules/request/node_modules/har-validator/bin/har-validator
@@ -2878,6 +2873,11 @@ lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modul
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/asn1/package.json
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/asn1/tst/ber/reader.test.js
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/asn1/tst/ber/writer.test.js
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/assert-plus/AUTHORS
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/assert-plus/CHANGES.md
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/assert-plus/README.md
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/assert-plus/assert.js
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/assert-plus/package.json
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/dashdash/README.md
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/dashdash/etc/dashdash.bash_completion.in
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/dashdash/lib/dashdash.js
@@ -2891,6 +2891,12 @@ lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modul
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/ecc-jsbn/lib/sec.js
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/ecc-jsbn/package.json
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/ecc-jsbn/test.js
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/getpass/.npmignore
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/getpass/.travis.yml
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/getpass/LICENSE
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/getpass/README.md
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/getpass/lib/index.js
+lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/getpass/package.json
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/jodid25519/.npmignore
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/jodid25519/.travis.yml
lib/node_modules/npm/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/jodid25519/AUTHORS.md
@@ -2975,7 +2981,6 @@ lib/node_modules/npm/node_modules/request/node_modules/oauth-sign/LICENSE
lib/node_modules/npm/node_modules/request/node_modules/oauth-sign/README.md
lib/node_modules/npm/node_modules/request/node_modules/oauth-sign/index.js
lib/node_modules/npm/node_modules/request/node_modules/oauth-sign/package.json
-lib/node_modules/npm/node_modules/request/node_modules/oauth-sign/test.js
lib/node_modules/npm/node_modules/request/node_modules/qs/.eslintignore
lib/node_modules/npm/node_modules/request/node_modules/qs/.npmignore
lib/node_modules/npm/node_modules/request/node_modules/qs/.travis.yml
@@ -3220,11 +3225,11 @@ lib/node_modules/npm/node_modules/validate-npm-package-name/node_modules/builtin
lib/node_modules/npm/node_modules/validate-npm-package-name/node_modules/builtins/package.json
lib/node_modules/npm/node_modules/validate-npm-package-name/package.json
lib/node_modules/npm/node_modules/validate-npm-package-name/test/index.js
-lib/node_modules/npm/node_modules/which/.npmignore
-lib/node_modules/npm/node_modules/which/.travis.yml
+lib/node_modules/npm/node_modules/which/CHANGELOG.md
lib/node_modules/npm/node_modules/which/LICENSE
lib/node_modules/npm/node_modules/which/README.md
lib/node_modules/npm/node_modules/which/bin/which
+lib/node_modules/npm/node_modules/which/changelog.sh
lib/node_modules/npm/node_modules/which/node_modules/is-absolute/LICENSE
lib/node_modules/npm/node_modules/which/node_modules/is-absolute/README.md
lib/node_modules/npm/node_modules/which/node_modules/is-absolute/index.js
@@ -3234,6 +3239,7 @@ lib/node_modules/npm/node_modules/which/node_modules/is-absolute/node_modules/is
lib/node_modules/npm/node_modules/which/node_modules/is-absolute/node_modules/is-relative/package.json
lib/node_modules/npm/node_modules/which/node_modules/is-absolute/package.json
lib/node_modules/npm/node_modules/which/node_modules/isexe/.npmignore
+lib/node_modules/npm/node_modules/which/node_modules/isexe/LICENSE
lib/node_modules/npm/node_modules/which/node_modules/isexe/README.md
lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js
lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js
@@ -3242,9 +3248,6 @@ lib/node_modules/npm/node_modules/which/node_modules/isexe/package.json
lib/node_modules/npm/node_modules/which/node_modules/isexe/test/basic.js
lib/node_modules/npm/node_modules/which/node_modules/isexe/windows.js
lib/node_modules/npm/node_modules/which/package.json
-lib/node_modules/npm/node_modules/which/test/basic.js
-lib/node_modules/npm/node_modules/which/test/bin.js
-lib/node_modules/npm/node_modules/which/test/windows.js
lib/node_modules/npm/node_modules/which/which.js
lib/node_modules/npm/node_modules/wrappy/LICENSE
lib/node_modules/npm/node_modules/wrappy/README.md
@@ -3271,7 +3274,6 @@ lib/node_modules/npm/scripts/release.sh
lib/node_modules/npm/scripts/relocate.sh
lib/node_modules/npm/scripts/update-authors.sh
lib/node_modules/npm/test/common-tap.js
-lib/node_modules/npm/test/common.js
lib/node_modules/npm/test/fixtures/config/builtin
lib/node_modules/npm/test/fixtures/config/globalconfig
lib/node_modules/npm/test/fixtures/config/malformed
@@ -3300,7 +3302,6 @@ lib/node_modules/npm/test/packages/npm-test-ignore-nested-nm/test.js
lib/node_modules/npm/test/packages/npm-test-missing-bindir/test.js
lib/node_modules/npm/test/packages/npm-test-optional-deps/test.js
lib/node_modules/npm/test/packages/npm-test-shrinkwrap/npm-shrinkwrap.json
-lib/node_modules/npm/test/packages/npm-test-shrinkwrap/test.js
lib/node_modules/npm/test/run.js
lib/node_modules/npm/test/tap/00-check-mock-dep.js
lib/node_modules/npm/test/tap/00-config-setup.js
@@ -3388,6 +3389,7 @@ lib/node_modules/npm/test/tap/install-save-prefix.js
lib/node_modules/npm/test/tap/install-scoped-already-installed.js
lib/node_modules/npm/test/tap/install-scoped-link.js
lib/node_modules/npm/test/tap/install-scoped-with-peer-dependency.js
+lib/node_modules/npm/test/tap/install-shrinkwrap-equals-ls.js
lib/node_modules/npm/test/tap/install-with-dev-dep-duplicate.js
lib/node_modules/npm/test/tap/invalid-cmd-exit-code.js
lib/node_modules/npm/test/tap/legacy-array-bin.js