aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-05-08 18:44:44 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-05-08 18:44:44 +0000
commitb0249c7e2d8e1093f0ebf8570533de6fed5f4ebd (patch)
tree5d21c8b693a4465d285057a1113820fac199cb12 /www
parent68ab9f3914ecabd54b16782998e13287bdf3eb4c (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/hs-webkit/Makefile25
-rw-r--r--www/hs-webkit/distinfo2
-rw-r--r--www/hs-webkit/pkg-descr7
3 files changed, 34 insertions, 0 deletions
diff --git a/www/hs-webkit/Makefile b/www/hs-webkit/Makefile
new file mode 100644
index 000000000000..5e474377d06f
--- /dev/null
+++ b/www/hs-webkit/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: hs-webkit
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= webkit
+PORTVERSION= 0.12.1
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Binding to the Webkit library
+
+LICENSE= LGPL21
+FILE_LICENSE= COPYING
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= cairo>=0.12 glib>=0.12 gtk>=0.12 mtl pango>=0.12
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/webkit-1.0.pc:${PORTSDIR}/www/webkit-gtk2
+
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-webkit/distinfo b/www/hs-webkit/distinfo
new file mode 100644
index 000000000000..2f179c66ab38
--- /dev/null
+++ b/www/hs-webkit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/webkit-0.12.1.tar.gz) = 9849ccf8c077a8c2c24103597a0183ba51e76fe4792d610dd148628062c5d232
+SIZE (cabal/webkit-0.12.1.tar.gz) = 58139
diff --git a/www/hs-webkit/pkg-descr b/www/hs-webkit/pkg-descr
new file mode 100644
index 000000000000..fa30db413f27
--- /dev/null
+++ b/www/hs-webkit/pkg-descr
@@ -0,0 +1,7 @@
+WebKit is a web content engine, derived from KHTML and KJS from KDE, and
+used primarily in Apple's Safari browser. It is made to be embedded in
+other applications, such as mail readers, or web browsers.
+It is able to display content such as HTML, SVG, XML, and others. It also
+supports DOM, XMLHttpRequest, XSLT, CSS, Javascript/ECMAscript and more.
+
+WWW: http://www.haskell.org/gtk2hs/