aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2009-09-14 15:33:23 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2009-09-14 15:33:23 +0000
commitc0180be414e7592bbda06381f8e5dffb49806773 (patch)
tree8af8d7fb013d6dc65baf9aa5ed63b4eadce519d0 /www
parent8449b0ccbebb3624f24dece817462e74bcd997ac (diff)
downloadports-c0180be414e7592bbda06381f8e5dffb49806773.tar.gz
ports-c0180be414e7592bbda06381f8e5dffb49806773.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/p5-WWW-Plurk/Makefile22
-rw-r--r--www/p5-WWW-Plurk/files/patch-lib__WWW__Plurk.pm21
-rw-r--r--www/p5-WWW-Plurk/pkg-descr4
3 files changed, 35 insertions, 12 deletions
diff --git a/www/p5-WWW-Plurk/Makefile b/www/p5-WWW-Plurk/Makefile
index 3f06e207bbaf..6c157c84e4e2 100644
--- a/www/p5-WWW-Plurk/Makefile
+++ b/www/p5-WWW-Plurk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WWW-Plurk
PORTVERSION= 0.02
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,17 +15,22 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mhsin@mhsin.org
COMMENT= Unofficial plurk.com API
-BUILD_DEPENDS= p5-Time-Piece>=0:${PORTSDIR}/devel/p5-Time-Piece \
- p5-DateTime-Format-Mail>=0:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
- ${SITE_PERL}/HTTP/Cookies.pm:${PORTSDIR}/www/p5-libwww \
- p5-JSON>=2.00:${PORTSDIR}/converters/p5-JSON \
- p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+RUN_DEPENDS= p5-DateTime-Format-Mail>=0:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
p5-HTML-Tiny>=0:${PORTSDIR}/textproc/p5-HTML-Tiny \
- p5-Math-Base36>=0:${PORTSDIR}/math/p5-Math-Base36
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ p5-JSON>=2.00:${PORTSDIR}/converters/p5-JSON1 \
+ p5-Math-Base36>=0:${PORTSDIR}/math/p5-Math-Base36 \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
PERL_CONFIGURE= yes
MAN3= WWW::Plurk.3 WWW::Plurk::Friend.3 WWW::Plurk::Message.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500905
+RUN_DEPENDS+= p5-Time-Piece>=0:${PORTSDIR}/devel/p5-Time-Piece
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Plurk/files/patch-lib__WWW__Plurk.pm b/www/p5-WWW-Plurk/files/patch-lib__WWW__Plurk.pm
new file mode 100644
index 000000000000..ff1f4f4c6686
--- /dev/null
+++ b/www/p5-WWW-Plurk/files/patch-lib__WWW__Plurk.pm
@@ -0,0 +1,21 @@
+--- lib/WWW/Plurk.pm.orig 2009-08-02 17:46:42.000000000 -0700
++++ lib/WWW/Plurk.pm 2009-08-02 17:47:52.000000000 -0700
+@@ -247,7 +247,7 @@
+ );
+
+ my $ok = 0;
+- $self->_cookies->scan( sub { $ok++ if $_[1] eq 'plurkcookie' } );
++ $self->_cookies->scan( sub { $ok++ if $_[1] eq 'plurkcookiea' } );
+ croak "Login for $name failed, no cookie returned"
+ unless $ok;
+
+@@ -705,7 +705,8 @@
+
+ sub _uri_for {
+ my ( $self, $service ) = ( shift, shift );
+- my $uri = $self->_base_uri . $self->_path_for( $service );
++ my $uri = $self->_path_for( $service );
++ $uri = $self->_base_uri . $uri if $uri !~ m{^http};
+ return $uri unless @_;
+ my $params = shift;
+ return join '?', $uri, HTML::Tiny->new->query_encode( $params );
diff --git a/www/p5-WWW-Plurk/pkg-descr b/www/p5-WWW-Plurk/pkg-descr
index 734f50ade293..dec8d538c26e 100644
--- a/www/p5-WWW-Plurk/pkg-descr
+++ b/www/p5-WWW-Plurk/pkg-descr
@@ -6,9 +6,5 @@ advantage of it. In the mean time use with caution.
Ryan Lim did the heavy lifting of reverse engineering the API. His PHP
implementation can be found at http://code.google.com/p/rlplurkapi/.
-If you'd like to lend a hand supporting the bits of Plurk that this API
-doesn't yet reach please feel free to send me a patch. The Plurk API Wiki at
-http://plurkwiki.badchemicals.net/ is a good source of information.
-
Author: Andy Armstrong <andy.armstrong@messagesystems.com>
WWW: http://search.cpan.org/dist/WWW-Plurk/