aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-10-01 04:13:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-10-01 04:13:31 +0000
commitc45de9579f6ec97574056dd335df02031ccd00ad (patch)
treebf42b7c476faa7a6183d0feaa4c65bb90053847d /www
parent4c6b47d49f526e4aa085f3d82bef3b2910453e64 (diff)
downloadports-c45de9579f6ec97574056dd335df02031ccd00ad.tar.gz
ports-c45de9579f6ec97574056dd335df02031ccd00ad.zip
Qt5 update to 5.13.0
For new features, check: https://wiki.qt.io/New_Features_in_Qt_5.13 Thanks to adridg who helped to fix a lot of packages. Exp-run by: antoine PR: 238782
Notes
Notes: svn path=/head/; revision=513447
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/qt5-webglplugin/Makefile21
-rw-r--r--www/qt5-webglplugin/pkg-plist3
3 files changed, 25 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 172f3299f09d..259d47d7b9e8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1925,6 +1925,7 @@
SUBDIR += qooxdoo
SUBDIR += qt5-webchannel
SUBDIR += qt5-webengine
+ SUBDIR += qt5-webglplugin
SUBDIR += qt5-webkit
SUBDIR += qt5-websockets
SUBDIR += qt5-websockets-qml
diff --git a/www/qt5-webglplugin/Makefile b/www/qt5-webglplugin/Makefile
new file mode 100644
index 000000000000..f8f0b416c139
--- /dev/null
+++ b/www/qt5-webglplugin/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= webglplugin
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= www
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt QPA plugin for running an application via a browser using streamed WebGL commands
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= compiler:c++11-lang gl gnome qmake:norecursive qt-dist:5
+USE_GL= gl
+USE_GNOME= glib20
+USE_QT= core dbus declarative gui network webchannel websockets \
+ buildtools_build
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+.include <bsd.port.mk>
diff --git a/www/qt5-webglplugin/pkg-plist b/www/qt5-webglplugin/pkg-plist
new file mode 100644
index 000000000000..01ba017ba4eb
--- /dev/null
+++ b/www/qt5-webglplugin/pkg-plist
@@ -0,0 +1,3 @@
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QWebGLIntegrationPlugin.cmake
+%%QT_PLUGINDIR%%/platforms/libqwebgl.so
+%%DEBUG%%%%QT_PLUGINDIR%%/platforms/libqwebgl.so.debug