aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-10 22:41:40 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-10 22:41:40 +0000
commit3857791e2b547c2be0e82c50ca72d58596cecff1 (patch)
treeb8177e7bdc5a9fcf559596343f9a47f7ce395e43 /www
parentcc555442337c7591ab5c3fd19ad8e3e185a256b0 (diff)
downloadports-3857791e2b547c2be0e82c50ca72d58596cecff1.tar.gz
ports-3857791e2b547c2be0e82c50ca72d58596cecff1.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer-Plugin-Lexicon/Makefile26
-rw-r--r--www/p5-Dancer-Plugin-Lexicon/distinfo2
-rw-r--r--www/p5-Dancer-Plugin-Lexicon/pkg-descr14
-rw-r--r--www/p5-Dancer-Plugin-Lexicon/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 323f767f9932..a9a2269c1e8f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -841,6 +841,7 @@
SUBDIR += p5-Dancer-Logger-Log4perl
SUBDIR += p5-Dancer-Plugin-ExtDirect
SUBDIR += p5-Dancer-Plugin-Feed
+ SUBDIR += p5-Dancer-Plugin-Lexicon
SUBDIR += p5-Dancer-Plugin-SiteMap
SUBDIR += p5-Dancer-Plugin-ValidationClass
SUBDIR += p5-Dancer-Session-Cookie
diff --git a/www/p5-Dancer-Plugin-Lexicon/Makefile b/www/p5-Dancer-Plugin-Lexicon/Makefile
new file mode 100644
index 000000000000..1a58086652d0
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Lexicon/Makefile
@@ -0,0 +1,26 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-Lexicon
+PORTVERSION= 0.06
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DRTECH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Flexible I18N using Locale::Maketext::Lexicon for Dancer apps
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Dancer>=1.3118:${PORTSDIR}/www/p5-Dancer \
+ p5-Locale-Maketext-Lexicon>0:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
+ p5-Package-Stash>0:${PORTSDIR}/devel/p5-Package-Stash \
+ p5-PathTools>0:${PORTSDIR}/devel/p5-PathTools
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Plugin-Lexicon/distinfo b/www/p5-Dancer-Plugin-Lexicon/distinfo
new file mode 100644
index 000000000000..830361546dd5
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Lexicon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-Lexicon-0.06.tar.gz) = 4494b7057f66e6443d0df186b44db1ea3d30704b938b0998c9825631a1d8a645
+SIZE (Dancer-Plugin-Lexicon-0.06.tar.gz) = 14594
diff --git a/www/p5-Dancer-Plugin-Lexicon/pkg-descr b/www/p5-Dancer-Plugin-Lexicon/pkg-descr
new file mode 100644
index 000000000000..8b69d0811873
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Lexicon/pkg-descr
@@ -0,0 +1,14 @@
+Dancer::Plugin::Lexicon uses Locale::Maketext::Lexicon to provide I18N
+functionality to your Dancer application.
+
+Translations are stored in PO or MO (compiled PO) gettext files in the
+"languages/" dir. You can generate or update your PO files by
+automatically extracting translatable strings from your code and
+templates with xgettext.pl.
+
+The user's preferred language can be auto-detected from their browser
+settings, and the current language is automatically stored in the user's
+session. Including "lang=$lang_tag" in the query string change the
+user's language.
+
+WWW: https://metacpan.org/source/DRTECH/Dancer-Plugin-Lexicon-0.06
diff --git a/www/p5-Dancer-Plugin-Lexicon/pkg-plist b/www/p5-Dancer-Plugin-Lexicon/pkg-plist
new file mode 100644
index 000000000000..425e4e97b395
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Lexicon/pkg-plist
@@ -0,0 +1,5 @@
+%%PERL5_MAN3%%/Dancer::Plugin::Lexicon.3.gz
+%%SITE_PERL%%/Dancer/Plugin/Lexicon.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Lexicon/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Lexicon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin