aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-01-23 23:27:08 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-01-23 23:27:08 +0000
commit434db3c661d39c4fa7a5fa734f0300d9151b0f79 (patch)
tree1bde6a160073d799240f5525260f08b113c88dc4 /www
parentff7c902ed28761f924e324b440bb141d69603255 (diff)
downloadports-434db3c661d39c4fa7a5fa734f0300d9151b0f79.tar.gz
ports-434db3c661d39c4fa7a5fa734f0300d9151b0f79.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-mercurial/Makefile35
-rw-r--r--www/trac-mercurial/distinfo3
-rw-r--r--www/trac-mercurial/pkg-descr4
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c33c89248835..46aeebe7fc61 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1437,6 +1437,7 @@
SUBDIR += trac-ldap
SUBDIR += trac-macropost
SUBDIR += trac-mastertickets
+ SUBDIR += trac-mercurial
SUBDIR += trac-nav
SUBDIR += trac-navadd
SUBDIR += trac-pagelist
diff --git a/www/trac-mercurial/Makefile b/www/trac-mercurial/Makefile
new file mode 100644
index 000000000000..136ecfbec04a
--- /dev/null
+++ b/www/trac-mercurial/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: trac-mercurial
+# Date created: January 23, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;:L}
+PORTVERSION= 0.11.0.7
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= A plugin to use Mercurial instead of Subversion in Trac
+
+RUN_DEPENDS+= hg:${PORTSDIR}/devel/mercurial \
+ tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= 2.3+
+NO_BUILD= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= TracMercurial
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+do-build:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/www/trac-mercurial/distinfo b/www/trac-mercurial/distinfo
new file mode 100644
index 000000000000..748e26aecd87
--- /dev/null
+++ b/www/trac-mercurial/distinfo
@@ -0,0 +1,3 @@
+MD5 (mercurialplugin-0.11.0.7.tar.gz) = 0e9966e495b8d712927041409c110bd7
+SHA256 (mercurialplugin-0.11.0.7.tar.gz) = c24e43b1c7080c8f30972e1baf8664b0b7807e5dcf4b6d276c3612b48e004914
+SIZE (mercurialplugin-0.11.0.7.tar.gz) = 20064
diff --git a/www/trac-mercurial/pkg-descr b/www/trac-mercurial/pkg-descr
new file mode 100644
index 000000000000..00fdabf14e4e
--- /dev/null
+++ b/www/trac-mercurial/pkg-descr
@@ -0,0 +1,4 @@
+This a plugin for Trac which enables Mercurial to be used instead of Subversion
+as the VersioningSystemBackend for Trac.
+
+WWW: http://trac.edgewall.org/wiki/TracMercurial