aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-22 00:43:15 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-22 00:43:15 +0000
commit5eb6e8e832d4b4d1cb9456f0e1a914c7dc0f5140 (patch)
treec2d8e1c40ffd4c8ddf1570486f6e5dd4c8ef7413 /www
parent4345ad92400f5c38fdf04d19d8237911dd608148 (diff)
downloadports-5eb6e8e832d4b4d1cb9456f0e1a914c7dc0f5140.tar.gz
ports-5eb6e8e832d4b4d1cb9456f0e1a914c7dc0f5140.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mozplugger/Makefile19
-rw-r--r--www/mozplugger/distinfo6
-rw-r--r--www/mozplugger/files/patch-Makefile26
-rw-r--r--www/mozplugger/files/patch-mozplugger.c12
-rw-r--r--www/mozplugger/files/pkg-message.in (renamed from www/mozplugger/pkg-message)0
5 files changed, 21 insertions, 42 deletions
diff --git a/www/mozplugger/Makefile b/www/mozplugger/Makefile
index a8cae345a756..4662b82276cf 100644
--- a/www/mozplugger/Makefile
+++ b/www/mozplugger/Makefile
@@ -1,32 +1,23 @@
# New ports collection makefile for: mozplugger
# Date created: 2 June 2005
-# Whom: Loren M. Lang
+# Whom: Loren M. Lang <loren@north-winds.org>
#
# $FreeBSD$
#
PORTNAME= mozplugger
-PORTVERSION= 1.7.3
-PORTREVISION= 3
+PORTVERSION= 1.10.2
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_MOZDEV}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://mozplugger.mozdev.org/files/
-MAINTAINER= lorenl@north-winds.org
+MAINTAINER= rnejdl@ringofsaturn.com
COMMENT= Framework for loading web content in external viewers
-EXTRACT_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
-
USE_XORG= x11 xt
MAN7= mozplugger.7
-
-FETCH_CMD= /usr/bin/fetch -Rr
-
+SUB_FILES= pkg-message
ALL_TARGET= freebsd
-post-extract:
- ${BZIP2_CMD} -d ${WRKSRC}/mozplugger.7.bz2
-
post-install:
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
diff --git a/www/mozplugger/distinfo b/www/mozplugger/distinfo
index 5fa6b760e85b..065807feeffe 100644
--- a/www/mozplugger/distinfo
+++ b/www/mozplugger/distinfo
@@ -1,3 +1,3 @@
-MD5 (mozplugger-1.7.3.tar.gz) = 5b56c7c598e9609d9dca3d7c3a88e124
-SHA256 (mozplugger-1.7.3.tar.gz) = 5dcac24b34db58d17dbf2f9dac720f4172fdec7d72aa56e6f3a38a97fb30c524
-SIZE (mozplugger-1.7.3.tar.gz) = 54718
+MD5 (mozplugger-1.10.2.tar.gz) = 2c1ce1f3f4f7cd4acb41e01209c7b20a
+SHA256 (mozplugger-1.10.2.tar.gz) = b5609e864f78f1c70772db62b281542d9b3e61b95e49573b25f4a3b262e7bbf4
+SIZE (mozplugger-1.10.2.tar.gz) = 68982
diff --git a/www/mozplugger/files/patch-Makefile b/www/mozplugger/files/patch-Makefile
index 7798df7ccdfa..98147f7d1a54 100644
--- a/www/mozplugger/files/patch-Makefile
+++ b/www/mozplugger/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Aug 29 14:09:55 2005
-+++ Makefile Fri Jan 27 16:37:23 2006
+--- Makefile.orig 2008-03-22 16:47:51.000000000 -0500
++++ Makefile 2008-07-05 15:24:56.000000000 -0500
@@ -1,5 +1,5 @@
# Where is your Xwindows located?
-X11=/usr/X11R6
@@ -24,7 +24,7 @@
LD=gcc
BINFORMAT=bin
-@@ -60,7 +60,7 @@
+@@ -66,7 +66,7 @@
${MAKE} all CC=gcc XCFLAGS='-fPIC -aout' LD=gcc XLDFLAGS='-shared -aout'
freebsd:
@@ -33,16 +33,16 @@
openbsd:
${MAKE} all CC=gcc XCFLAGS=-fPIC LD=gcc XLDFLAGS=-shared X11=/usr/X11R6/
-@@ -91,7 +91,7 @@
- mozplugger-common.c mozplugger.h README.in
- BIN_FILES=mozplugger.so mozplugger-helper
+@@ -109,7 +109,7 @@
+ mozplugger-helper \
+ mozplugger-controller
--DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" #-Wall -DDEBUG #-D__amd64__
-+DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(prefix)\" #-Wall -DDEBUG #-D__amd64__
+-DEFINES= -DXP_UNIX -DVERSION=\"$(VERSION)\" -D$(BUILD) #-D__amd64__
++DEFINES= -DXP_UNIX -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(prefix)\" -D$(BUILD) #-D__amd64__
+ INCLUDES= -Inpapi/include -I$(X11)/include
RPM_OPT_FLAGS=-O2
- COMMON_CFLAGS=$(RPM_OPT_FLAGS) -Inpapi/include -I$(X11)/include -DXP_UNIX $(DEFINES)
- COMMON_LDFLAGS=
-@@ -156,14 +156,14 @@
+ COMMON_CFLAGS=$(RPM_OPT_FLAGS) $(INCLUDES) $(DEFINES)
+@@ -175,14 +175,14 @@
install:
-@mkdir -p $(root)$(prefix)/bin
@@ -50,13 +50,13 @@
- -@mkdir -p $(root)$(prefix)/share/man/man7
- -@mkdir -p $(root)/etc
+ -@mkdir -p $(root)$(prefix)/lib/browser_plugins
-+ -@mkdir -p $(root)$(prefix)/etc
+ -@mkdir -p $(root)$(prefix)/man/man7
++ -@mkdir -p $(root)$(prefix)/etc
cp mozplugger-helper $(root)$(prefix)/bin/
cp mozplugger-controller $(root)$(prefix)/bin/
- cp mozplugger.so $(root)$(prefix)/lib/mozilla/plugins/
- cp mozpluggerrc $(root)/etc/
-- cp mozplugger.7.bz2 $(root)$(prefix)/share/man/man7/
+- cp mozplugger.7 $(root)$(prefix)/share/man/man7/
+ cp mozplugger.so $(root)$(prefix)/lib/browser_plugins/
+ cp mozpluggerrc $(root)$(prefix)/etc/
+ cp mozplugger.7 $(root)$(prefix)/man/man7/
diff --git a/www/mozplugger/files/patch-mozplugger.c b/www/mozplugger/files/patch-mozplugger.c
deleted file mode 100644
index 26db7994dd1a..000000000000
--- a/www/mozplugger/files/patch-mozplugger.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- mozplugger.c.orig Mon Aug 29 14:08:04 2005
-+++ mozplugger.c Fri Jan 27 17:04:36 2006
-@@ -572,6 +572,9 @@
- if (cb(fname, data)) return 1;
- }
-
-+ snprintf(fname, sizeof(fname), PREFIX "/etc/%s", basename);
-+ if (cb(fname, data)) return 1;
-+
- snprintf(fname, sizeof(fname), "/etc/%s", basename);
- if (cb(fname, data)) return 1;
-
diff --git a/www/mozplugger/pkg-message b/www/mozplugger/files/pkg-message.in
index 797fd5dff844..797fd5dff844 100644
--- a/www/mozplugger/pkg-message
+++ b/www/mozplugger/files/pkg-message.in