aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2006-09-14 14:37:45 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2006-09-14 14:37:45 +0000
commit6c79376f0b521c5bc820715481428f51c658cb6d (patch)
treef1fcae2e016a7ed94f3b18ca71ef8ef96aafb923 /www
parenta9af5d69b002f21826ad87a74e461c649f10e7f9 (diff)
downloadports-6c79376f0b521c5bc820715481428f51c658cb6d.tar.gz
ports-6c79376f0b521c5bc820715481428f51c658cb6d.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile28
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx/Makefile28
-rw-r--r--www/nginx/distinfo6
4 files changed, 60 insertions, 8 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index b95f754da5a1..425fc3afd753 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.1
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -21,6 +21,10 @@ NGINX_RUNDIR?= ${NGINX_VARDIR}/run
NGINX_TMPDIR?= ${NGINX_VARDIR}/tmp/nginx
HTTP_PORT?= 80
+.if defined(WITH_PERL_MODULE)
+USE_PERL5= yes
+.endif
+
USE_RC_SUBR= nginx.sh
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${PREFIX}/etc/nginx \
@@ -65,6 +69,10 @@ CONFIGURE_ARGS+=--without-http_rewrite_module \
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
.endif
+.if defined(WITH_PERL_MODULE)
+CONFIGURE_ARGS+=--with-http_perl_module
+.endif
+
.if defined(WITHOUT_WWW)
PLIST_SUB+= WWWDATA="@comment "
.else
@@ -103,4 +111,22 @@ do-install:
${LN} -sf ${PREFIX}/www/nginx-dist ${PREFIX}/www/nginx
.endif
+.if defined(WITH_PERL_MODULE)
+ ${MKDIR} ${SITE_PERL}/${PERL_ARCH}/auto/nginx
+ ${INSTALL_PROGRAM} ${WRKSRC}/objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so \
+ ${SITE_PERL}/${PERL_ARCH}/auto/nginx
+ ${INSTALL_DATA} ${WRKSRC}/objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs \
+ ${SITE_PERL}/${PERL_ARCH}/auto/nginx
+ ${INSTALL_DATA} ${WRKSRC}/objs/src/http/modules/perl/blib/lib/nginx.pm \
+ ${SITE_PERL}/${PERL_ARCH}/
+.endif
+
+post-install:
+.if defined(WITH_PERL_MODULE)
+ ${ECHO_CMD} ${SITE_PERL_REL}/${PERL_ARCH}/auto/nginx/nginx.so >> ${TMPPLIST}
+ ${ECHO_CMD} ${SITE_PERL_REL}/${PERL_ARCH}/auto/nginx/nginx.bs >> ${TMPPLIST}
+ ${ECHO_CMD} ${SITE_PERL_REL}/${PERL_ARCH}/nginx.pm >> ${TMPPLIST}
+ ${ECHO_CMD} @dirrm ${SITE_PERL_REL}/${PERL_ARCH}/auto/nginx >> ${TMPPLIST}
+.endif
+
.include <bsd.port.mk>
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index dfe78cade2ba..4493baa717c7 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (nginx-0.4.0.tar.gz) = 59db2b315f65cbe9f9452bc882d77999
-SHA256 (nginx-0.4.0.tar.gz) = 4bd30b1ae75f64553d03ce5f2657cb4f8685a272d02c1390e47a92c9d11d9b62
-SIZE (nginx-0.4.0.tar.gz) = 421031
+MD5 (nginx-0.4.1.tar.gz) = ddc338af7697094d42dcb712be99c953
+SHA256 (nginx-0.4.1.tar.gz) = c032e9743e882b18a0e496de3206e6697648ddbe251b89e3ebe586b0195606aa
+SIZE (nginx-0.4.1.tar.gz) = 419532
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index b95f754da5a1..425fc3afd753 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.1
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -21,6 +21,10 @@ NGINX_RUNDIR?= ${NGINX_VARDIR}/run
NGINX_TMPDIR?= ${NGINX_VARDIR}/tmp/nginx
HTTP_PORT?= 80
+.if defined(WITH_PERL_MODULE)
+USE_PERL5= yes
+.endif
+
USE_RC_SUBR= nginx.sh
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${PREFIX}/etc/nginx \
@@ -65,6 +69,10 @@ CONFIGURE_ARGS+=--without-http_rewrite_module \
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
.endif
+.if defined(WITH_PERL_MODULE)
+CONFIGURE_ARGS+=--with-http_perl_module
+.endif
+
.if defined(WITHOUT_WWW)
PLIST_SUB+= WWWDATA="@comment "
.else
@@ -103,4 +111,22 @@ do-install:
${LN} -sf ${PREFIX}/www/nginx-dist ${PREFIX}/www/nginx
.endif
+.if defined(WITH_PERL_MODULE)
+ ${MKDIR} ${SITE_PERL}/${PERL_ARCH}/auto/nginx
+ ${INSTALL_PROGRAM} ${WRKSRC}/objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so \
+ ${SITE_PERL}/${PERL_ARCH}/auto/nginx
+ ${INSTALL_DATA} ${WRKSRC}/objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs \
+ ${SITE_PERL}/${PERL_ARCH}/auto/nginx
+ ${INSTALL_DATA} ${WRKSRC}/objs/src/http/modules/perl/blib/lib/nginx.pm \
+ ${SITE_PERL}/${PERL_ARCH}/
+.endif
+
+post-install:
+.if defined(WITH_PERL_MODULE)
+ ${ECHO_CMD} ${SITE_PERL_REL}/${PERL_ARCH}/auto/nginx/nginx.so >> ${TMPPLIST}
+ ${ECHO_CMD} ${SITE_PERL_REL}/${PERL_ARCH}/auto/nginx/nginx.bs >> ${TMPPLIST}
+ ${ECHO_CMD} ${SITE_PERL_REL}/${PERL_ARCH}/nginx.pm >> ${TMPPLIST}
+ ${ECHO_CMD} @dirrm ${SITE_PERL_REL}/${PERL_ARCH}/auto/nginx >> ${TMPPLIST}
+.endif
+
.include <bsd.port.mk>
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index dfe78cade2ba..4493baa717c7 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,3 +1,3 @@
-MD5 (nginx-0.4.0.tar.gz) = 59db2b315f65cbe9f9452bc882d77999
-SHA256 (nginx-0.4.0.tar.gz) = 4bd30b1ae75f64553d03ce5f2657cb4f8685a272d02c1390e47a92c9d11d9b62
-SIZE (nginx-0.4.0.tar.gz) = 421031
+MD5 (nginx-0.4.1.tar.gz) = ddc338af7697094d42dcb712be99c953
+SHA256 (nginx-0.4.1.tar.gz) = c032e9743e882b18a0e496de3206e6697648ddbe251b89e3ebe586b0195606aa
+SIZE (nginx-0.4.1.tar.gz) = 419532