aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-20 08:24:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-20 08:24:22 +0000
commit785537c20950961b1fdb8d03a86633d75af1279a (patch)
treebdfc368cda05eb1a67087a830f9fcc69780123d2 /www
parent43bf816902aff79debeba715cc9b917e8ed6ed18 (diff)
downloadports-785537c20950961b1fdb8d03a86633d75af1279a.tar.gz
ports-785537c20950961b1fdb8d03a86633d75af1279a.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-FCGI/Makefile35
-rw-r--r--www/p5-FCGI/distinfo2
-rw-r--r--www/p5-FCGI/pkg-descr11
-rw-r--r--www/p5-FCGI/pkg-plist5
5 files changed, 54 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 42fa6cccc09e..0fa1bd246003 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -918,6 +918,7 @@
SUBDIR += p5-Data-Validate-URI
SUBDIR += p5-Emplacken
SUBDIR += p5-FAQ-OMatic
+ SUBDIR += p5-FCGI
SUBDIR += p5-FCGI-Async
SUBDIR += p5-FCGI-Client
SUBDIR += p5-FCGI-Engine
diff --git a/www/p5-FCGI/Makefile b/www/p5-FCGI/Makefile
new file mode 100644
index 000000000000..313a948a8692
--- /dev/null
+++ b/www/p5-FCGI/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-FCGI
+# Date created: 2011-08-20
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FCGI
+PORTVERSION= 0.73
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast CGI module
+
+OPTIONS= PURE_PERL "Build pure Perl version (experimental)" off
+
+PERL_CONFIGURE= yes
+
+MAN3= FCGI.3
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PURE_PERL)
+CONFIGURE_ARGS= --pure-perl
+PLIST_SUB= PURE_PERL="@comment "
+.else
+PLIST_SUB= PURE_PERL=""
+.endif
+
+regression-test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/www/p5-FCGI/distinfo b/www/p5-FCGI/distinfo
new file mode 100644
index 000000000000..afdda384f979
--- /dev/null
+++ b/www/p5-FCGI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (FCGI-0.73.tar.gz) = 08fee08b2d0766a6e87ead24db6b207829fdb29f4008b2d550e4a42e530384ed
+SIZE (FCGI-0.73.tar.gz) = 96250
diff --git a/www/p5-FCGI/pkg-descr b/www/p5-FCGI/pkg-descr
new file mode 100644
index 000000000000..4f70ba718a5b
--- /dev/null
+++ b/www/p5-FCGI/pkg-descr
@@ -0,0 +1,11 @@
+FCGI is a Fast CGI module for Perl. It's based on the FCGI module that comes
+with Open Market's FastCGI Developer's Kit.
+
+FCGI.pm isn't Unicode aware, only characters within the range 0x00-0xFF are
+supported. Attempts to output strings containing characters above 0xFF results
+in a exception: (F) Wide character in %s.
+
+Users who wants the previous (FCGI.pm <= 0.68) incorrect behavior can disable
+the exception by using the bytes pragma.
+
+WWW: http://search.cpan.org/dist/FCGI/
diff --git a/www/p5-FCGI/pkg-plist b/www/p5-FCGI/pkg-plist
new file mode 100644
index 000000000000..411015494368
--- /dev/null
+++ b/www/p5-FCGI/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/FCGI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/.packlist
+%%PURE_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/FCGI.bs
+%%PURE_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/FCGI.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI