aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-04-07 14:05:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-04-07 14:05:49 +0000
commit94d74e79590391265aa5df97e1e7ae0b4372e102 (patch)
tree19d72bb4659c130179f9d6b03e59b0131fdfd0ea /www
parent81575644bb807df3bba5cb4ad548d1b7195ff7b5 (diff)
downloadports-94d74e79590391265aa5df97e1e7ae0b4372e102.tar.gz
ports-94d74e79590391265aa5df97e1e7ae0b4372e102.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/thundercache/Makefile50
-rw-r--r--www/thundercache/distinfo12
-rw-r--r--www/thundercache/files/log.sh.in2
-rw-r--r--www/thundercache/files/pkg-message.in7
-rw-r--r--www/thundercache/pkg-plist82
5 files changed, 94 insertions, 59 deletions
diff --git a/www/thundercache/Makefile b/www/thundercache/Makefile
index b8a6c602659a..2fa0e6e2888e 100644
--- a/www/thundercache/Makefile
+++ b/www/thundercache/Makefile
@@ -12,14 +12,15 @@ CATEGORIES= www
MASTER_SITES= http://www.bmsoftware.org/freebsd/ \
http://www6.freebsdbrasil.com.br/~eksffa/l/dev/thunder/ \
${MASTER_SITE_LOCAL}/jmelo
-DISTNAME= thunder32bits_17032010
+DISTNAME= thunder32bits_29032010
MAINTAINER= eksffa@freebsdbrasil.com.br
COMMENT= High-performance and high-eficiency caching proxy system
-BROKEN= calls false in default configuration
-
-OPTIONS= DEPENDACK "I have read and understood the depends needs" off
+OPTIONS= DEPENDACK "I have read and understood the depends needs" on \
+ APACHE "Install apache for reporting viewing" on \
+ PHP "Install PHP for reporting generating" on \
+ PGSQL "Install PostgreSQL (report data storing)" on
USE_OPENSSL= yes
USE_BZIP2= yes
@@ -39,25 +40,35 @@ BROKEN= Won't run on systems version < FreeBSD 8.0-RELEASE
.endif
.if ${ARCH} == "amd64"
-DISTNAME= thunder64bits_17032010
+DISTNAME= thunder64bits_29032010
.endif
WRKSRC= ${WRKDIR}/thunder
-USE_PHP+= curl pcre bcmath pdo mcrypt mhash session pgsql
+.if defined (WITH_APACHE)
+USE_APACHE= 2.0+
+.endif
+
+.if defined (WITH_PGSQL)
USE_PGSQL= yes
WANT_PGSQL_VER= 84
-USE_APACHE= 2.0+
+RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+.endif
+
+.if defined(WITH_PHP)
+USE_PHP+= curl pcre bcmath pdo mcrypt mhash session pgsql
+.endif
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl:install
-RUN_DEPENDS+= sudo:${PORTSDIR}/security/sudo \
- postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server \
- ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
-SUB_FILES= pkg-message log.sh
+.if defined(APACHE+PHP) && defined(WITH_PGSQL)
+LIB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
+.endif
+
+SUB_FILES= pkg-message log.sh test-deps.sh
+SUB_LIST= "GREP=${GREP}"
pre-everything::
-.if !defined(WITH_DEPENDACK)
@${ECHO_MSG} ""
@${ECHO_MSG} "ATTENTION:"
@${ECHO_MSG} ""
@@ -73,12 +84,27 @@ pre-everything::
@${ECHO_MSG} " After you understood it correctly, select DEPENDACK on"
@${ECHO_MSG} " the OPTIONS screen. Run ''make config'' to acknowledge"
@${ECHO_MSG} ""
+.if !defined(WITH_DEPENDACK)
@${FALSE}
.endif
+pre-install:
+ @(${CHMOD} +x ${WRKDIR}/test-deps.sh ; \
+ if ! ${WRKDIR}/test-deps.sh > /dev/null 2>&1 ; then \
+ ${ECHO_MSG} "FATAL: " ; \
+ ${ECHO_MSG} "Some depends are not built with required features." ; \
+ ${ECHO_MSG} "You must always honor at least the following options" ; \
+ ${ECHO_MSG} "depends as listed:" ; \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "ftp/curl LIBSSH2=yes OPENSSL=yes PROXY=yes" ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi)
+
do-install:
@${CP} -r ${WRKSRC} ${PREFIX}/
${INSTALL_SCRIPT} ${WRKDIR}/log.sh ${PREFIX}/thunder/sbin/
+ @${MKDIR} -m 755 /var/run/thunder
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/thundercache/distinfo b/www/thundercache/distinfo
index 0b3179034607..a32750cd31b2 100644
--- a/www/thundercache/distinfo
+++ b/www/thundercache/distinfo
@@ -1,6 +1,6 @@
-MD5 (thunder32bits_17032010.tar.bz2) = 83a1c3319f50b30e9c126efe446218f6
-SHA256 (thunder32bits_17032010.tar.bz2) = 49a310295360feba0fda20ef043d861a4769b30c57f2fe14c046ea4d40d3f7e0
-SIZE (thunder32bits_17032010.tar.bz2) = 2729811
-MD5 (thunder64bits_17032010.tar.bz2) = ef1af778432abe887033b503a2ba6bdc
-SHA256 (thunder64bits_17032010.tar.bz2) = 4ab6b36159ac1b25855feb70a933a96fb750ea6a81306c026dceae0cc8081535
-SIZE (thunder64bits_17032010.tar.bz2) = 3870257
+MD5 (thunder32bits_29032010.tar.bz2) = 51a940e7255abcaa278619efb6bf67fa
+SHA256 (thunder32bits_29032010.tar.bz2) = f3ede1ffe3d77c11f349f839c473368c73acee85c5e6db8e677f4d8aa177abf9
+SIZE (thunder32bits_29032010.tar.bz2) = 1396108
+MD5 (thunder64bits_29032010.tar.bz2) = 5ab1831934092519b820e3377884267a
+SHA256 (thunder64bits_29032010.tar.bz2) = 9fd65a917e211c939be9d864a250583d5e20d9740ab2562d5eabc82f11f7ac3e
+SIZE (thunder64bits_29032010.tar.bz2) = 1456262
diff --git a/www/thundercache/files/log.sh.in b/www/thundercache/files/log.sh.in
index d50f058e608a..74975c4df19c 100644
--- a/www/thundercache/files/log.sh.in
+++ b/www/thundercache/files/log.sh.in
@@ -23,5 +23,5 @@ cp -f ${LOG}/access.log ${LOGTEMP}/access.log
:> ${LOG}/access.log
-$PHP $THUNDERLOG $HOST $DB $USER $PASS $LOGTEMP/access.log >>$ {SCRIPTLOG} 2>&1 && rm -f $LOGTEMP/access.log
+$PHP $THUNDERLOG $HOST $DB $USER $PASS $LOGTEMP/access.log >>${SCRIPTLOG} 2>&1 && rm -f $LOGTEMP/access.log
diff --git a/www/thundercache/files/pkg-message.in b/www/thundercache/files/pkg-message.in
index 200de3f40492..1779d1fa0df2 100644
--- a/www/thundercache/files/pkg-message.in
+++ b/www/thundercache/files/pkg-message.in
@@ -35,5 +35,10 @@ Add %%PREFIX%%/thunder/sbin/log.sh to /etc/crontab according to your needs:
@hourly root %%PREFIX%%/thunder/sbin/log.sh
-Configure %%PREFIX%%/thunder/etc/thunder.conf accordingly.
+Configure %%PREFIX%%/thunder/etc/thunder.conf accordingly and finally, add
+the following line to rc.conf:
+
+ thundercache_enable="YES"
+
+And start it from %%PREFIX%%/etc/rc.d/thundercache
diff --git a/www/thundercache/pkg-plist b/www/thundercache/pkg-plist
index 7ace64171949..1c1bcddd5828 100644
--- a/www/thundercache/pkg-plist
+++ b/www/thundercache/pkg-plist
@@ -1,65 +1,69 @@
+thunder/etc/thunder_postgre.sql
thunder/etc/thunder.conf
thunder/etc/log.sh
thunder/etc/thunder.php
-thunder/etc/thunder_postgre.sql
thunder/logs/error.log
thunder/logs/access.log
-thunder/plugins/4shared.com.so
-thunder/plugins/avast.com.so
+thunder/plugins/youtube.com.so
+thunder/plugins/xvideos.com.so
+thunder/plugins/vimeo.com.so
+thunder/plugins/rapidshare.com.so
+thunder/plugins/grisoft.com.so
thunder/plugins/avg.com.so
+thunder/plugins/dailymotion.com.so
+thunder/plugins/viddler.com.so
+thunder/plugins/globo.com.so
+thunder/plugins/windowsupdate.com.so
+thunder/plugins/terra.com.so
+thunder/plugins/ziddu.com.so
+thunder/plugins/photobucket.com.so
+thunder/plugins/video.msn.com.so
thunder/plugins/avgate.com.so
+thunder/plugins/etrustdownloads.ca.com.so
+thunder/plugins/update.nai.com.so
+thunder/plugins/metacafe.com.so
thunder/plugins/avgate.net.so
+thunder/plugins/kaspersky-labs.com.so
+thunder/plugins/pornhub.com.so
+thunder/plugins/nai.com.so
+thunder/plugins/mediafire.com.so
thunder/plugins/bitgravity.com.so
-thunder/plugins/dailymotion.com.so
+thunder/plugins/grandchase.com.br.so
thunder/plugins/doubleclick.net.so
-thunder/plugins/edgecastcdn.net.so
-thunder/plugins/eset.com.so
-thunder/plugins/etrustdownloads.ca.com.so
+thunder/plugins/pop6.com.so
thunder/plugins/freeav.com.so
+thunder/plugins/googlevideo.com.so
+thunder/plugins/edgecastcdn.net.so
thunder/plugins/freeav.net.so
-thunder/plugins/globo.com.so
+thunder/plugins/tube8.com.so
+thunder/plugins/microsoft.com.so
thunder/plugins/sambatech.com.br.so
-thunder/plugins/googlevideo.com.so
-thunder/plugins/grandchase.com.br.so
-thunder/plugins/grisoft.com.so
-thunder/plugins/nai.com.so
thunder/plugins/grisoft.cz.so
-thunder/plugins/kaspersky-labs.com.so
-thunder/plugins/kaspersky.com.so
-thunder/plugins/mccont.com.so
-thunder/plugins/mediafire.com.so
-thunder/plugins/megaupload.com.so
+thunder/plugins/symantecliveupdate.com.so
+thunder/plugins/rad.msn.com.so
thunder/plugins/megavideo.com.so
-thunder/plugins/metacafe.com.so
-thunder/plugins/microsoft.com.so
-thunder/plugins/orkut.com.br.so
+thunder/plugins/kaspersky.com.so
thunder/plugins/orkut.com.so
-thunder/plugins/photobucket.com.so
-thunder/plugins/pop6.com.so
-thunder/plugins/pornhub.com.so
-thunder/plugins/pornotube.com.so
-thunder/plugins/rad.msn.com.so
-thunder/plugins/rapidshare.com.so
-thunder/plugins/redtube.com.so
-thunder/plugins/symantecliveupdate.com.so
-thunder/plugins/terra.com.so
-thunder/plugins/tube8.com.so
thunder/plugins/uol.com.br.so
-thunder/plugins/update.nai.com.so
-thunder/plugins/viddler.com.so
-thunder/plugins/video.msn.com.so
-thunder/plugins/vimeo.com.so
-thunder/plugins/windowsupdate.com.so
+thunder/plugins/avast.com.so
+thunder/plugins/eset.com.so
thunder/plugins/xtube.com.so
-thunder/plugins/xvideos.com.so
-thunder/plugins/youtube.com.so
-thunder/plugins/ziddu.com.so
-thunder/sbin/thunder
+thunder/plugins/redtube.com.so
+thunder/plugins/4shared.com.so
+thunder/plugins/pornotube.com.so
+thunder/plugins/orkut.com.br.so
+thunder/plugins/megaupload.com.so
+thunder/plugins/mccont.com.so
thunder/sbin/thunderlog.php
+thunder/sbin/diskinfo
+thunder/sbin/thunder
thunder/sbin/log.sh
@dirrm thunder/etc
@dirrm thunder/logs/tmp
@dirrm thunder/logs
@dirrm thunder/plugins
@dirrm thunder/sbin
+@dirrm thunder/cache
@dirrm thunder
+@unexec /bin/rm /var/run/thunder/thunder.pid 2>/dev/null || true
+@unexec /bin/rmdir /var/run/thunder 2>/dev/null || true