aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2011-04-27 08:56:07 +0000
committerNicola Vitale <nivit@FreeBSD.org>2011-04-27 08:56:07 +0000
commit9e6cc07ae91cc052dddf02aed53334300c0bac93 (patch)
treebbb5164ac394eb543d23e36fed1824b462c58c1d /www
parent798b2424f1e8f574aa996bbea0996443072b3d59 (diff)
downloadports-9e6cc07ae91cc052dddf02aed53334300c0bac93.tar.gz
ports-9e6cc07ae91cc052dddf02aed53334300c0bac93.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/cutycapt/Makefile32
-rw-r--r--www/cutycapt/distinfo2
-rw-r--r--www/cutycapt/pkg-descr5
4 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e4522c960aa3..dcde03531963 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -122,6 +122,7 @@
SUBDIR += cssed
SUBDIR += csstidy
SUBDIR += ctemplate
+ SUBDIR += cutycapt
SUBDIR += dalbum
SUBDIR += dansguardian
SUBDIR += davical
diff --git a/www/cutycapt/Makefile b/www/cutycapt/Makefile
new file mode 100644
index 000000000000..aab40dcea7eb
--- /dev/null
+++ b/www/cutycapt/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: CutyCapt
+# Date created: 2010-09-29
+# Whom: Axel Gonzalez <loox@e-shell.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cutycapt
+PORTVERSION= 20100608
+CATEGORIES= www
+MASTER_SITES= http://bsd.e-shell.net/local/
+
+MAINTAINER= loox@e-shell.net
+COMMENT= A command-line utility to capture WebKit's rendering of a web page
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/CutyCapt
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build imageformats webkit
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/CutyCapt
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE}
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/CutyCapt ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/www/cutycapt/distinfo b/www/cutycapt/distinfo
new file mode 100644
index 000000000000..0347bc935006
--- /dev/null
+++ b/www/cutycapt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cutycapt-20100608.tar.gz) = 0267dcf292f0a1e1dc5838e83f3807c7fcff4c188fda8d4630ffe6f86ee97e0c
+SIZE (cutycapt-20100608.tar.gz) = 6968
diff --git a/www/cutycapt/pkg-descr b/www/cutycapt/pkg-descr
new file mode 100644
index 000000000000..6e157c13b582
--- /dev/null
+++ b/www/cutycapt/pkg-descr
@@ -0,0 +1,5 @@
+CutyCapt is a small cross-platform command-line utility to capture
+WebKit's rendering of a web page into a variety of vector and bitmap
+formats, including SVG, PDF, PS, PNG, JPEG, TIFF, GIF, and BMP.
+
+WWW: http://cutycapt.sourceforge.net