aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-12-03 20:56:24 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-12-03 20:56:24 +0000
commitb2dda62aed91dc5f8f14ec2ddbb86d8504814388 (patch)
tree257f1da238ce8fc23439936ddea02d264e6a178b /www
parent88aba0f55d9a6ff008a406bd8317deb2be948009 (diff)
downloadports-b2dda62aed91dc5f8f14ec2ddbb86d8504814388.tar.gz
ports-b2dda62aed91dc5f8f14ec2ddbb86d8504814388.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/hiawatha/Makefile47
-rw-r--r--www/hiawatha/distinfo3
-rw-r--r--www/hiawatha/files/hiawatha.in22
-rw-r--r--www/hiawatha/files/pkg-message.in10
-rw-r--r--www/hiawatha/pkg-descr5
-rw-r--r--www/hiawatha/pkg-plist15
7 files changed, 103 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3ad092416919..6fa4397dc88e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -191,6 +191,7 @@
SUBDIR += harvest
SUBDIR += hastymail
SUBDIR += havp
+ SUBDIR += hiawatha
SUBDIR += hinventory-client
SUBDIR += horde
SUBDIR += horde-passwd
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
new file mode 100644
index 000000000000..c5a7f2ab36b1
--- /dev/null
+++ b/www/hiawatha/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: hiawatha
+# Date created: 24 november 2006
+# Whom: Hugo Leisink <hugo@leisink.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hiawatha
+PORTVERSION= 5.2
+CATEGORIES= www
+MASTER_SITES= http://hiawatha.leisink.org/files/
+
+MAINTAINER= hugo@leisink.net
+COMMENT= An advanced and secure webserver for Unix
+
+MAN1= hiawatha.1 cgi_wrapper.1
+MANCOMPRESSED= no
+
+USE_RC_SUBR= hiawatha
+SUB_FILES= pkg-message
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var --enable-cache webrootdir=${PREFIX}/www/hiawatha
+
+OPTIONS= SSL "Compile with SSL support?" On \
+ PHP "Include the CGI version of PHP?" On
+
+CONFIG_FILES= httpd.conf mimetype.conf throttle.conf cgi_wrapper.conf
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SSL)
+CONFIGURE_ARGS+=--enable-ssl
+.endif
+
+.if !defined(WITHOUT_PHP)
+WANT_PHP_CGI= yes
+.endif
+
+post-install:
+ @for _file in ${CONFIG_FILES} ; do \
+ ${CP} -f ${WRKSRC}/etc/hiawatha/$${_file} ${PREFIX}/etc/hiawatha/$${_file}.sample ; \
+ done
+ ${CP} -f ${WRKSRC}/doc/index.html ${PREFIX}/www/hiawatha/index.html.sample
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/hiawatha/distinfo b/www/hiawatha/distinfo
new file mode 100644
index 000000000000..7b67d351551c
--- /dev/null
+++ b/www/hiawatha/distinfo
@@ -0,0 +1,3 @@
+MD5 (hiawatha-5.2.tar.gz) = 48dc41d30c0c8fa04385705cc18422c5
+SHA256 (hiawatha-5.2.tar.gz) = 3a2620b3c6a0a106a8a39f91d055f98d24e2c6c21037052947ecd8b80194d8a9
+SIZE (hiawatha-5.2.tar.gz) = 182128
diff --git a/www/hiawatha/files/hiawatha.in b/www/hiawatha/files/hiawatha.in
new file mode 100644
index 000000000000..eeb2ce7304cb
--- /dev/null
+++ b/www/hiawatha/files/hiawatha.in
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: httpd
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+
+# Add the following line(s) to /etc/rc.conf:
+# hiawatha_enable (bool): Set to "NO" by default, set it to "YES" to enable hiawatha
+
+. %%RC_SUBR%%
+
+name="hiawatha"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/sbin/${name}"
+pidfile="/var/run/${name}.pid"
+
+load_rc_config $name
+: ${hiawatha_enable="NO"}
+run_rc_command "$1"
diff --git a/www/hiawatha/files/pkg-message.in b/www/hiawatha/files/pkg-message.in
new file mode 100644
index 000000000000..11dd02e7e29e
--- /dev/null
+++ b/www/hiawatha/files/pkg-message.in
@@ -0,0 +1,10 @@
+===============================================================================
+
+The Hiawatha webserver is now installed.
+
+Edit the configuration files in %%PREFIX%%/etc/hiawatha to suit your needs.
+
+Add hiawatha_enable="YES" to rc.conf and start Hiawatha by running:
+%%PREFIX%%/etc/rc.d/hiawatha.sh start
+
+===============================================================================
diff --git a/www/hiawatha/pkg-descr b/www/hiawatha/pkg-descr
new file mode 100644
index 000000000000..9feed96f09c0
--- /dev/null
+++ b/www/hiawatha/pkg-descr
@@ -0,0 +1,5 @@
+Hiawatha is an advanced and secure webserver for Unix. It has been written with
+'being secure' as its main goal. Hiawatha has many security features that no
+other webserver has. Besides being very secure, it's also a very fast
+webserver. It's twice as fast as Apache for static content. It supports
+load-balanced FastCGI, which makes it fast and scalable for serving CGI.
diff --git a/www/hiawatha/pkg-plist b/www/hiawatha/pkg-plist
new file mode 100644
index 000000000000..f6fb1b1e0934
--- /dev/null
+++ b/www/hiawatha/pkg-plist
@@ -0,0 +1,15 @@
+sbin/hiawatha
+sbin/cgi_wrapper
+sbin/wigwam
+@unexec if cmp -s %D/etc/hiawatha/httpd.conf %D/etc/hiawatha/httpd.conf.sample; then rm -f %D/etc/hiawatha/httpd.conf; fi
+@unexec if cmp -s %D/etc/hiawatha/mimetype.conf %D/etc/hiawatha/mimetype.conf.sample; then rm -f %D/etc/hiawatha/mimetype.conf; fi
+@unexec if cmp -s %D/etc/hiawatha/throttle.conf %D/etc/hiawatha/throttle.conf.sample; then rm -f %D/etc/hiawatha/throttle.conf; fi
+@unexec if cmp -s %D/etc/hiawatha/cgi_wrapper.conf %D/etc/hiawatha/cgi_wrapper.conf.sample; then rm -f %D/etc/hiawatha/cgi_wrapper.conf; fi
+etc/hiawatha/httpd.conf.sample
+etc/hiawatha/mimetype.conf.sample
+etc/hiawatha/throttle.conf.sample
+etc/hiawatha/cgi_wrapper.conf.sample
+@dirrm etc/hiawatha
+@unexec if cmp -s %D/www/hiawatha/index.html %D/www/hiawatha/index.html.sample; then rm -f %D/www/hiawatha/index.html; fi
+www/hiawatha/index.html.sample
+@dirrm www/hiawatha