aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2018-06-20 08:53:10 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2018-06-20 08:53:10 +0000
commit0a3b61ae9e7f9402954c9f72b8834441532c1860 (patch)
tree139ec692c017d37e98f4e704c685b19d514bf1dd /www
parentb46d30b60197193f4313cdc90bf17076819b6a8f (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/iridium/Makefile20
-rw-r--r--www/iridium/files/extra-patch-llvm-base53
-rw-r--r--www/iridium/files/extra-patch-llvm-port (renamed from www/iridium/files/patch-build_toolchain_gcc__toolchain.gni)0
3 files changed, 64 insertions, 9 deletions
diff --git a/www/iridium/Makefile b/www/iridium/Makefile
index ccd3d2127d94..272a3e87602c 100644
--- a/www/iridium/Makefile
+++ b/www/iridium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iridium
PORTVERSION= 58.0
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= www
MASTER_SITES= https://downloads.iridiumbrowser.de/source/
PKGNAMESUFFIX= -browser
@@ -16,7 +16,6 @@ LICENSE= BSD3CLAUSE LGPL21 MPL11
LICENSE_COMB= multi
BUILD_DEPENDS= gperf:devel/gperf \
- clang60:devel/llvm60 \
yasm:devel/yasm \
ffmpeg>=3.2.2,1:multimedia/ffmpeg \
bash:shells/bash \
@@ -71,8 +70,6 @@ ALL_TARGET= chrome
INSTALLS_ICONS= yes
BINARY_ALIAS= python=${PYTHON_CMD}
-CC= clang60
-CXX= clang++60
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang
# Run "./out/${BUILDTYPE}/gn args out/${BUILDTYPE} --list" for all variables.
@@ -158,16 +155,21 @@ SNDIO_VARS_OFF= GN_ARGS+=use_sndio=false
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1101513
+BUILD_DEPENDS+= clang60:devel/llvm60
+CC= clang60
+CXX= clang++60
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-llvm-port
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/bin/ar:devel/binutils
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-llvm-base
+.endif
+
# TODO: -isystem, would be just as ugly as this approach, but more reliably
# build would fail without C_INCLUDE_PATH/CPLUS_INCLUDE_PATH env var set.
MAKE_ENV+= C_INCLUDE_PATH=${LOCALBASE}/include \
CPLUS_INCLUDE_PATH=${LOCALBASE}/include
-# Work around base r261801
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100508
-GN_ARGS+= extra_cxxflags="-D_LIBCPP_TRIVIAL_PAIR_COPY_CTOR=1"
-.endif
-
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "To build Iridium, you should have around 2GB of memory"
diff --git a/www/iridium/files/extra-patch-llvm-base b/www/iridium/files/extra-patch-llvm-base
new file mode 100644
index 000000000000..3e117b37257d
--- /dev/null
+++ b/www/iridium/files/extra-patch-llvm-base
@@ -0,0 +1,53 @@
+--- build/toolchain/gcc_toolchain.gni.orig 2017-04-19 21:06:28.000000000 +0200
++++ build/toolchain/gcc_toolchain.gni 2018-06-19 17:35:48.967441000 +0200
+@@ -12,6 +12,11 @@
+ import("//build/toolchain/goma.gni")
+ import("//build/toolchain/toolchain.gni")
+
++declare_args() {
++ extra_cxxflags = ""
++ extra_ldflags = ""
++}
++
+ # This template defines a toolchain for something that works like gcc
+ # (including clang).
+ #
+@@ -483,10 +488,23 @@
+ }
+
+ gcc_toolchain(target_name) {
+- prefix = rebase_path("$clang_base_path/bin", root_build_dir)
+- cc = "$prefix/clang"
+- cxx = "$prefix/clang++"
+- ld = cxx
++ if (is_bsd) {
++ prefix = "/usr/local/bin"
++ cc = "cc"
++ cxx = "c++"
++ ld = cxx
++ readelf = "readelf"
++ ar = "${prefix}/ar"
++ nm = "${toolprefix}nm"
++ } else {
++ prefix = rebase_path("$clang_base_path/bin", root_build_dir)
++ cc = "$prefix/clang"
++ cxx = "$prefix/clang++"
++ ld = cxx
++ readelf = "${toolprefix}readelf"
++ ar = "${toolprefix}ar"
++ nm = "${toolprefix}nm"
++ }
+
+ if (use_clang_static_analyzer) {
+ # Static analysis isn't supported under GOMA. See crbug.com/687245
+@@ -506,10 +524,6 @@
+ rebase_path("//third_party/scan-build/src/libexec/c++-analyzer",
+ root_build_dir)
+ }
+-
+- readelf = "${toolprefix}readelf"
+- ar = "${toolprefix}ar"
+- nm = "${toolprefix}nm"
+
+ forward_variables_from(invoker, [ "strip" ])
+
diff --git a/www/iridium/files/patch-build_toolchain_gcc__toolchain.gni b/www/iridium/files/extra-patch-llvm-port
index 7130a5a5fa8f..7130a5a5fa8f 100644
--- a/www/iridium/files/patch-build_toolchain_gcc__toolchain.gni
+++ b/www/iridium/files/extra-patch-llvm-port