aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-09 11:43:38 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-09 11:43:38 +0000
commit35a3256787b35a3ac84c57a93e64ee49f066dfc8 (patch)
treefe8d6d1bb77f066ad3509b241e4a189b13ae62bc /www
parentd13a3290d368e78f26cc9630804c1e953ee53388 (diff)
downloadports-35a3256787b35a3ac84c57a93e64ee49f066dfc8.tar.gz
ports-35a3256787b35a3ac84c57a93e64ee49f066dfc8.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/abcache/Makefile6
-rw-r--r--www/eaccelerator/Makefile6
-rw-r--r--www/gallery/Makefile6
-rw-r--r--www/gallery2/Makefile6
-rw-r--r--www/gallery3/Makefile6
-rw-r--r--www/pear-APC/Makefile2
-rw-r--r--www/pecl-APC-devel/Makefile2
-rw-r--r--www/pecl-APC/Makefile2
-rw-r--r--www/php-dyn/Makefile6
-rw-r--r--www/php-screw/Makefile6
-rw-r--r--www/php-templates/Makefile6
-rw-r--r--www/phpSysInfo/Makefile6
-rw-r--r--www/phpsysinfo-dev/Makefile6
-rw-r--r--www/phpsysinfo/Makefile6
-rw-r--r--www/smarty/Makefile5
-rw-r--r--www/turck-mmcache/Makefile6
16 files changed, 29 insertions, 54 deletions
diff --git a/www/abcache/Makefile b/www/abcache/Makefile
index a3eac9c45d32..427280b9229d 100644
--- a/www/abcache/Makefile
+++ b/www/abcache/Makefile
@@ -16,6 +16,7 @@ COMMENT= A tool to cache applications written in PHP
WRKSRC= ${WRKDIR}/bware_cache-${PORTVERSION}
+USE_PHP= yes
USE_PHPIZE= yes
WITH_PHP_MOD= yes
@@ -23,9 +24,6 @@ CONFIGURE_ARGS+=--enable-bware_cache=shared
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-build:
@${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
@@ -38,4 +36,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/eaccelerator/Makefile b/www/eaccelerator/Makefile
index daa9cd11c383..7c4317bb19a8 100644
--- a/www/eaccelerator/Makefile
+++ b/www/eaccelerator/Makefile
@@ -16,15 +16,13 @@ COMMENT= An opcode cache for PHP with encoder and loader
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-mmcache=shared
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-patch:
@${REINPLACE_CMD} 's|ALIGN|MMALIGN|g' ${WRKSRC}/mm.c ${WRKSRC}/mmcache.c
@@ -49,4 +47,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/gallery/Makefile b/www/gallery/Makefile
index 2c3076184887..1b1e3b68cc5d 100644
--- a/www/gallery/Makefile
+++ b/www/gallery/Makefile
@@ -54,6 +54,7 @@ LANGPACKS= af_ZA-pack-${LANGVERSION}-u1${EXTRACT_SUFX} \
zh_TW-pack-${LANGVERSION}-u1${EXTRACT_SUFX} \
zh_TW.utf8-pack-${LANGVERSION}${EXTRACT_SUFX}
+USE_PHP= yes
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -64,9 +65,6 @@ EXCEPTFILES= ${DOCFILES} LICENSE.txt
CPIOARGS= --quiet -pdum -R
PLIST_SUB= GALLERYDIR=${GALLERYDIR}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
pre-fetch:
.if !defined(GALLERYDIR)
@${ECHO_MSG} ""
@@ -106,4 +104,4 @@ post-install:
@ ${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/gallery2/Makefile b/www/gallery2/Makefile
index 2c3076184887..1b1e3b68cc5d 100644
--- a/www/gallery2/Makefile
+++ b/www/gallery2/Makefile
@@ -54,6 +54,7 @@ LANGPACKS= af_ZA-pack-${LANGVERSION}-u1${EXTRACT_SUFX} \
zh_TW-pack-${LANGVERSION}-u1${EXTRACT_SUFX} \
zh_TW.utf8-pack-${LANGVERSION}${EXTRACT_SUFX}
+USE_PHP= yes
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -64,9 +65,6 @@ EXCEPTFILES= ${DOCFILES} LICENSE.txt
CPIOARGS= --quiet -pdum -R
PLIST_SUB= GALLERYDIR=${GALLERYDIR}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
pre-fetch:
.if !defined(GALLERYDIR)
@${ECHO_MSG} ""
@@ -106,4 +104,4 @@ post-install:
@ ${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/gallery3/Makefile b/www/gallery3/Makefile
index 2c3076184887..1b1e3b68cc5d 100644
--- a/www/gallery3/Makefile
+++ b/www/gallery3/Makefile
@@ -54,6 +54,7 @@ LANGPACKS= af_ZA-pack-${LANGVERSION}-u1${EXTRACT_SUFX} \
zh_TW-pack-${LANGVERSION}-u1${EXTRACT_SUFX} \
zh_TW.utf8-pack-${LANGVERSION}${EXTRACT_SUFX}
+USE_PHP= yes
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -64,9 +65,6 @@ EXCEPTFILES= ${DOCFILES} LICENSE.txt
CPIOARGS= --quiet -pdum -R
PLIST_SUB= GALLERYDIR=${GALLERYDIR}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
pre-fetch:
.if !defined(GALLERYDIR)
@${ECHO_MSG} ""
@@ -106,4 +104,4 @@ post-install:
@ ${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-APC/Makefile b/www/pear-APC/Makefile
index 7396299260d7..ebad4289b675 100644
--- a/www/pear-APC/Makefile
+++ b/www/pear-APC/Makefile
@@ -15,12 +15,12 @@ COMMENT= Alternative PHP Cache
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
diff --git a/www/pecl-APC-devel/Makefile b/www/pecl-APC-devel/Makefile
index 7396299260d7..ebad4289b675 100644
--- a/www/pecl-APC-devel/Makefile
+++ b/www/pecl-APC-devel/Makefile
@@ -15,12 +15,12 @@ COMMENT= Alternative PHP Cache
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index 7396299260d7..ebad4289b675 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -15,12 +15,12 @@ COMMENT= Alternative PHP Cache
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
diff --git a/www/php-dyn/Makefile b/www/php-dyn/Makefile
index 5f9a1284a3aa..f9031cc7e038 100644
--- a/www/php-dyn/Makefile
+++ b/www/php-dyn/Makefile
@@ -16,6 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ale@FreeBSD.org
COMMENT= A PHP Extension to help debugging a PHP script
+USE_PHP= yes
USE_PHPIZE= yes
WITH_PHP_MOD= yes
@@ -23,9 +24,6 @@ CONFIGURE_ARGS= --enable-php_dyn=shared
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-build:
@${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|g" \
${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@@ -42,4 +40,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/php-screw/Makefile b/www/php-screw/Makefile
index e5086520bba4..7ef04de03dec 100644
--- a/www/php-screw/Makefile
+++ b/www/php-screw/Makefile
@@ -20,13 +20,11 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CRYPTKEY?= 11152, 368, 192, 1281, 62
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS+=--enable-php_screw=shared
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
-
pre-everything::
@${ECHO} ""
@${ECHO} "To achieve real security, define your own encryption"
@@ -57,4 +55,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
index 14b2d14b6677..fb5e186ddba1 100644
--- a/www/php-templates/Makefile
+++ b/www/php-templates/Makefile
@@ -21,15 +21,13 @@ COMMENT= A template framework for PHP
WRKSRC= ${WRKDIR}/templates
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-templates=shared
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-build:
@${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
@@ -46,4 +44,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/phpSysInfo/Makefile b/www/phpSysInfo/Makefile
index 229a1d671cfc..e98baf97a568 100644
--- a/www/phpSysInfo/Makefile
+++ b/www/phpSysInfo/Makefile
@@ -13,6 +13,7 @@ MASTER_SITE_SUBDIR= phpsysinfo
MAINTAINER= so14k@so14k.com
COMMENT= A php script that displays info about the host being accessed
+USE_PHP= yes
WANT_PHP_WEB= yes
PREFIX= ${LOCALBASE}
@@ -25,9 +26,6 @@ PLIST= ${WRKDIR}/plist
PLIST_SUB+= INSTALLDIR=${INSTALLDIR:S,^${PREFIX}/,,}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-patch:
rm -f ${PLIST}
cd ${WRKSRC};\
@@ -43,4 +41,4 @@ do-install:
${CHMOD} -R ${BINMODE} ${INSTALLDIR}
${FIND} ${INSTALLDIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/phpsysinfo-dev/Makefile b/www/phpsysinfo-dev/Makefile
index 229a1d671cfc..e98baf97a568 100644
--- a/www/phpsysinfo-dev/Makefile
+++ b/www/phpsysinfo-dev/Makefile
@@ -13,6 +13,7 @@ MASTER_SITE_SUBDIR= phpsysinfo
MAINTAINER= so14k@so14k.com
COMMENT= A php script that displays info about the host being accessed
+USE_PHP= yes
WANT_PHP_WEB= yes
PREFIX= ${LOCALBASE}
@@ -25,9 +26,6 @@ PLIST= ${WRKDIR}/plist
PLIST_SUB+= INSTALLDIR=${INSTALLDIR:S,^${PREFIX}/,,}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-patch:
rm -f ${PLIST}
cd ${WRKSRC};\
@@ -43,4 +41,4 @@ do-install:
${CHMOD} -R ${BINMODE} ${INSTALLDIR}
${FIND} ${INSTALLDIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/phpsysinfo/Makefile b/www/phpsysinfo/Makefile
index 229a1d671cfc..e98baf97a568 100644
--- a/www/phpsysinfo/Makefile
+++ b/www/phpsysinfo/Makefile
@@ -13,6 +13,7 @@ MASTER_SITE_SUBDIR= phpsysinfo
MAINTAINER= so14k@so14k.com
COMMENT= A php script that displays info about the host being accessed
+USE_PHP= yes
WANT_PHP_WEB= yes
PREFIX= ${LOCALBASE}
@@ -25,9 +26,6 @@ PLIST= ${WRKDIR}/plist
PLIST_SUB+= INSTALLDIR=${INSTALLDIR:S,^${PREFIX}/,,}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-patch:
rm -f ${PLIST}
cd ${WRKSRC};\
@@ -43,4 +41,4 @@ do-install:
${CHMOD} -R ${BINMODE} ${INSTALLDIR}
${FIND} ${INSTALLDIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
index 1e8f440fc09a..28422df0f85d 100644
--- a/www/smarty/Makefile
+++ b/www/smarty/Makefile
@@ -21,6 +21,7 @@ COMMENT= The PHP compiling template engine
WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION}
NO_BUILD= yes
+USE_PHP= yes
WANT_PHP_WEB= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -28,8 +29,6 @@ MSG_SRC= ${FILESDIR}/pkg-message
MSG_SUB= DATADIR=${DATADIR} LOCALBASE=${LOCALBASE}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
do-install:
@${MKDIR} ${DATADIR}
.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php debug.tpl
@@ -59,4 +58,4 @@ post-install:
${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/turck-mmcache/Makefile b/www/turck-mmcache/Makefile
index daa9cd11c383..7c4317bb19a8 100644
--- a/www/turck-mmcache/Makefile
+++ b/www/turck-mmcache/Makefile
@@ -16,15 +16,13 @@ COMMENT= An opcode cache for PHP with encoder and loader
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-mmcache=shared
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-patch:
@${REINPLACE_CMD} 's|ALIGN|MMALIGN|g' ${WRKSRC}/mm.c ${WRKSRC}/mmcache.c
@@ -49,4 +47,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>