aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-12-06 12:49:51 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-12-06 12:49:51 +0000
commit4d49bc10fc8ee8e0e663949db98d8ade7ec1c7c1 (patch)
tree3b1b354559423ab03159a3b68aabc7be6f518447 /www
parentb6be012a4685c57d5fd44da6e9a5126a70263f6f (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/nextcloud-tasks/Makefile35
-rw-r--r--www/nextcloud-tasks/distinfo3
-rw-r--r--www/nextcloud-tasks/pkg-descr4
-rw-r--r--www/nextcloud-tasks/pkg-plist162
5 files changed, 205 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6d0c8f3edc3d..1972de3a2ef9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -541,6 +541,7 @@
SUBDIR += nextcloud-calendar
SUBDIR += nextcloud-contacts
SUBDIR += nextcloud-notes
+ SUBDIR += nextcloud-tasks
SUBDIR += nghttp2
SUBDIR += nginx
SUBDIR += nginx-devel
diff --git a/www/nextcloud-tasks/Makefile b/www/nextcloud-tasks/Makefile
new file mode 100644
index 000000000000..6ade57162f96
--- /dev/null
+++ b/www/nextcloud-tasks/Makefile
@@ -0,0 +1,35 @@
+# Created by: Bernard Spil <brnrd@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= tasks
+PORTVERSION= 0.9.5
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+MASTER_SITES= https://github.com/${PKGNAMEPREFIX:S/-//}/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
+PKGNAMEPREFIX= nextcloud-
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}/${DISTNAME}-${DISTVERSIONPREFIX}${PORTVERSION}
+
+MAINTAINER= brnrd@freebsd.org
+COMMENT= Tasks app for Nextcloud
+
+LICENSE= AGPLv3
+
+RUN_DEPENDS= nextcloud>=12:www/nextcloud
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+NEXTCLOUD_USERNAME?= ${WWWOWN}
+NEXTCLOUD_GROUPNAME?= ${WWWGRP}
+
+PLIST_SUB= NEXTCLOUD_USERNAME=${NEXTCLOUD_USERNAME} \
+ NEXTCLOUD_GROUPNAME=${NEXTCLOUD_GROUPNAME}
+
+WWWDIR= ${PREFIX}/www/nextcloud/apps/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>
diff --git a/www/nextcloud-tasks/distinfo b/www/nextcloud-tasks/distinfo
new file mode 100644
index 000000000000..80aeb363594a
--- /dev/null
+++ b/www/nextcloud-tasks/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512563326
+SHA256 (nextcloud/tasks-v0.9.5/tasks.tar.gz) = a76ab499668510d0364262f787520e8f030974facbbe5f0b9ec8ea11915579c9
+SIZE (nextcloud/tasks-v0.9.5/tasks.tar.gz) = 478397
diff --git a/www/nextcloud-tasks/pkg-descr b/www/nextcloud-tasks/pkg-descr
new file mode 100644
index 000000000000..0d9a6dd0b0f7
--- /dev/null
+++ b/www/nextcloud-tasks/pkg-descr
@@ -0,0 +1,4 @@
+Tasks app for Nextcloud adds a Tasks menu to your Nextcloud.
+Add the task lists as remote calendar.
+
+WWW: https://apps.nextcloud.com/apps/tasks
diff --git a/www/nextcloud-tasks/pkg-plist b/www/nextcloud-tasks/pkg-plist
new file mode 100644
index 000000000000..867413d578e4
--- /dev/null
+++ b/www/nextcloud-tasks/pkg-plist
@@ -0,0 +1,162 @@
+@owner %%NEXTCLOUD_USERNAME%%
+@group %%NEXTCLOUD_GROUPNAME%%
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/appinfo/app.php
+%%WWWDIR%%/appinfo/application.php
+%%WWWDIR%%/appinfo/info.xml
+%%WWWDIR%%/appinfo/routes.php
+%%WWWDIR%%/appinfo/signature.json
+%%WWWDIR%%/controller/collectionscontroller.php
+%%WWWDIR%%/controller/pagecontroller.php
+%%WWWDIR%%/controller/response.php
+%%WWWDIR%%/controller/searchprovider.php
+%%WWWDIR%%/controller/settingscontroller.php
+%%WWWDIR%%/css/style.css
+%%WWWDIR%%/css/vendor/angularui/ui-select/select2.css
+%%WWWDIR%%/css/vendor/timepicker/jquery.ui.timepicker.css
+%%WWWDIR%%/img/divider.svg
+%%WWWDIR%%/img/favicon-touch.png
+%%WWWDIR%%/img/favicon-touch.svg
+%%WWWDIR%%/img/favicon.ico
+%%WWWDIR%%/img/favicon.png
+%%WWWDIR%%/img/favicon.svg
+%%WWWDIR%%/img/loading.gif
+%%WWWDIR%%/img/random.svg
+%%WWWDIR%%/img/sprites.png
+%%WWWDIR%%/img/sprites.svg
+%%WWWDIR%%/img/tasks.png
+%%WWWDIR%%/img/tasks.svg
+%%WWWDIR%%/js/public/app.js
+%%WWWDIR%%/js/vendor/angular-animate/angular-animate.min.js
+%%WWWDIR%%/js/vendor/angular-animate/index.js
+%%WWWDIR%%/js/vendor/angular-draganddrop/LICENSE
+%%WWWDIR%%/js/vendor/angular-draganddrop/angular-drag-and-drop-lists.min.js
+%%WWWDIR%%/js/vendor/angular-route/angular-route.min.js
+%%WWWDIR%%/js/vendor/angular-route/index.js
+%%WWWDIR%%/js/vendor/angular-sanitize/angular-sanitize.min.js
+%%WWWDIR%%/js/vendor/angular-sanitize/index.js
+%%WWWDIR%%/js/vendor/angular-ui-select/LICENSE
+%%WWWDIR%%/js/vendor/angular-ui-select/dist/select.min.css
+%%WWWDIR%%/js/vendor/angular-ui-select/dist/select.min.js
+%%WWWDIR%%/js/vendor/angular-ui-select/index.js
+%%WWWDIR%%/js/vendor/angular-ui-select/npm-debug.log
+%%WWWDIR%%/js/vendor/angular/angular-csp.css
+%%WWWDIR%%/js/vendor/angular/angular.min.js
+%%WWWDIR%%/js/vendor/angular/angular.min.js.gzip
+%%WWWDIR%%/js/vendor/angular/index.js
+%%WWWDIR%%/js/vendor/davclient.js/LICENSE
+%%WWWDIR%%/js/vendor/davclient.js/lib/client.js
+%%WWWDIR%%/js/vendor/ical.js/build/ical.js
+%%WWWDIR%%/js/vendor/ical.js/build/ical.min.js
+%%WWWDIR%%/js/vendor/jquery-timepicker/GPL-LICENSE.txt
+%%WWWDIR%%/js/vendor/jquery-timepicker/MIT-LICENSE.txt
+%%WWWDIR%%/js/vendor/jquery-timepicker/jquery.ui.timepicker.css
+%%WWWDIR%%/js/vendor/jquery-timepicker/jquery.ui.timepicker.js
+%%WWWDIR%%/js/vendor/jquery-timepicker/timepicker.png
+%%WWWDIR%%/js/vendor/jstzdetect/LICENCE.txt
+%%WWWDIR%%/js/vendor/jstzdetect/jstz.min.js
+%%WWWDIR%%/l10n/.tx/config
+%%WWWDIR%%/l10n/ast.js
+%%WWWDIR%%/l10n/ast.json
+%%WWWDIR%%/l10n/az.js
+%%WWWDIR%%/l10n/az.json
+%%WWWDIR%%/l10n/bg_BG.js
+%%WWWDIR%%/l10n/bg_BG.json
+%%WWWDIR%%/l10n/bn_BD.js
+%%WWWDIR%%/l10n/bn_BD.json
+%%WWWDIR%%/l10n/ca.js
+%%WWWDIR%%/l10n/ca.json
+%%WWWDIR%%/l10n/cs_CZ.js
+%%WWWDIR%%/l10n/cs_CZ.json
+%%WWWDIR%%/l10n/da.js
+%%WWWDIR%%/l10n/da.json
+%%WWWDIR%%/l10n/de.js
+%%WWWDIR%%/l10n/de.json
+%%WWWDIR%%/l10n/de_DE.js
+%%WWWDIR%%/l10n/de_DE.json
+%%WWWDIR%%/l10n/el.js
+%%WWWDIR%%/l10n/el.json
+%%WWWDIR%%/l10n/en_GB.js
+%%WWWDIR%%/l10n/en_GB.json
+%%WWWDIR%%/l10n/es.js
+%%WWWDIR%%/l10n/es.json
+%%WWWDIR%%/l10n/es_MX.js
+%%WWWDIR%%/l10n/es_MX.json
+%%WWWDIR%%/l10n/et_EE.js
+%%WWWDIR%%/l10n/et_EE.json
+%%WWWDIR%%/l10n/eu.js
+%%WWWDIR%%/l10n/eu.json
+%%WWWDIR%%/l10n/fi_FI.js
+%%WWWDIR%%/l10n/fi_FI.json
+%%WWWDIR%%/l10n/fr.js
+%%WWWDIR%%/l10n/fr.json
+%%WWWDIR%%/l10n/gl.js
+%%WWWDIR%%/l10n/gl.json
+%%WWWDIR%%/l10n/he.js
+%%WWWDIR%%/l10n/he.json
+%%WWWDIR%%/l10n/hu_HU.js
+%%WWWDIR%%/l10n/hu_HU.json
+%%WWWDIR%%/l10n/ia.js
+%%WWWDIR%%/l10n/ia.json
+%%WWWDIR%%/l10n/id.js
+%%WWWDIR%%/l10n/id.json
+%%WWWDIR%%/l10n/is.js
+%%WWWDIR%%/l10n/is.json
+%%WWWDIR%%/l10n/it.js
+%%WWWDIR%%/l10n/it.json
+%%WWWDIR%%/l10n/ja.js
+%%WWWDIR%%/l10n/ja.json
+%%WWWDIR%%/l10n/ko.js
+%%WWWDIR%%/l10n/ko.json
+%%WWWDIR%%/l10n/lb.js
+%%WWWDIR%%/l10n/lb.json
+%%WWWDIR%%/l10n/lt_LT.js
+%%WWWDIR%%/l10n/lt_LT.json
+%%WWWDIR%%/l10n/lv.js
+%%WWWDIR%%/l10n/lv.json
+%%WWWDIR%%/l10n/nb_NO.js
+%%WWWDIR%%/l10n/nb_NO.json
+%%WWWDIR%%/l10n/nl.js
+%%WWWDIR%%/l10n/nl.json
+%%WWWDIR%%/l10n/oc.js
+%%WWWDIR%%/l10n/oc.json
+%%WWWDIR%%/l10n/pl.js
+%%WWWDIR%%/l10n/pl.json
+%%WWWDIR%%/l10n/pt_BR.js
+%%WWWDIR%%/l10n/pt_BR.json
+%%WWWDIR%%/l10n/pt_PT.js
+%%WWWDIR%%/l10n/pt_PT.json
+%%WWWDIR%%/l10n/ro.js
+%%WWWDIR%%/l10n/ro.json
+%%WWWDIR%%/l10n/ru.js
+%%WWWDIR%%/l10n/ru.json
+%%WWWDIR%%/l10n/sk_SK.js
+%%WWWDIR%%/l10n/sk_SK.json
+%%WWWDIR%%/l10n/sl.js
+%%WWWDIR%%/l10n/sl.json
+%%WWWDIR%%/l10n/sq.js
+%%WWWDIR%%/l10n/sq.json
+%%WWWDIR%%/l10n/sr.js
+%%WWWDIR%%/l10n/sr.json
+%%WWWDIR%%/l10n/sv.js
+%%WWWDIR%%/l10n/sv.json
+%%WWWDIR%%/l10n/th_TH.js
+%%WWWDIR%%/l10n/th_TH.json
+%%WWWDIR%%/l10n/tr.js
+%%WWWDIR%%/l10n/tr.json
+%%WWWDIR%%/l10n/uk.js
+%%WWWDIR%%/l10n/uk.json
+%%WWWDIR%%/l10n/zh_CN.js
+%%WWWDIR%%/l10n/zh_CN.json
+%%WWWDIR%%/l10n/zh_TW.js
+%%WWWDIR%%/l10n/zh_TW.json
+%%WWWDIR%%/service/collectionsservice.php
+%%WWWDIR%%/service/settingsservice.php
+%%WWWDIR%%/templates/colorpicker.html
+%%WWWDIR%%/templates/confirmation.php
+%%WWWDIR%%/templates/main.php
+%%WWWDIR%%/templates/part.collectionall.php
+%%WWWDIR%%/templates/part.collectionweek.php
+%%WWWDIR%%/templates/part.details.php
+%%WWWDIR%%/templates/part.taskbody.php
+%%WWWDIR%%/templates/part.tasklist.php