aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-05-06 07:29:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-05-06 07:29:54 +0000
commit4ef71b535150deac3c6d5b00bfa2f40bdbec34b0 (patch)
tree232e3494b0371db7e48b036a9526caf9dfce37f2 /www
parent4c14de48a591aa4f3d47fadc8d8962e07410beb9 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-star-ratings/Makefile21
-rw-r--r--www/py-django-star-ratings/distinfo3
-rw-r--r--www/py-django-star-ratings/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 52ef266db1d0..edb56bcafd2b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1591,6 +1591,7 @@
SUBDIR += py-django-simple-history
SUBDIR += py-django-social-auth
SUBDIR += py-django-sortedm2m
+ SUBDIR += py-django-star-ratings
SUBDIR += py-django-statici18n
SUBDIR += py-django-storages
SUBDIR += py-django-subdomains
diff --git a/www/py-django-star-ratings/Makefile b/www/py-django-star-ratings/Makefile
new file mode 100644
index 000000000000..aea887720135
--- /dev/null
+++ b/www/py-django-star-ratings/Makefile
@@ -0,0 +1,21 @@
+# Created by: Kevin Golding <ports@caomhin.org>
+# $FreeBSD$
+
+PORTNAME= django-star-ratings
+PORTVERSION= 0.5.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= Django app to add star ratings to models
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:www/py-django18
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/www/py-django-star-ratings/distinfo b/www/py-django-star-ratings/distinfo
new file mode 100644
index 000000000000..f7c08fb0f3e7
--- /dev/null
+++ b/www/py-django-star-ratings/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465811270
+SHA256 (django-star-ratings-0.5.1.tar.gz) = 3062306578ac3a649e205f1643ac5d26a9b027ac456db17cf2dd26ad71603240
+SIZE (django-star-ratings-0.5.1.tar.gz) = 26180
diff --git a/www/py-django-star-ratings/pkg-descr b/www/py-django-star-ratings/pkg-descr
new file mode 100644
index 000000000000..790e09d93309
--- /dev/null
+++ b/www/py-django-star-ratings/pkg-descr
@@ -0,0 +1,3 @@
+Python 3 compatible star ratings for Django models.
+
+WWW: https://github.com/wildfish/django-star-ratings