aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-11-20 04:31:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-11-20 04:31:30 +0000
commit4f886304af13ab0d26f89e0afc857f6206e75801 (patch)
tree7af9097dee95f0a564d828464f487ee32c0822de /www
parent76a74f2a33f28574e5c45ea59d856bf04a168250 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/npm-node8/Makefile13
2 files changed, 14 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 852bcded74b6..fa8ab67d49c7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -561,6 +561,7 @@
SUBDIR += npm-less-plugin-clean-css
SUBDIR += npm-node4
SUBDIR += npm-node6
+ SUBDIR += npm-node8
SUBDIR += npm2
SUBDIR += npm3
SUBDIR += npm4
diff --git a/www/npm-node8/Makefile b/www/npm-node8/Makefile
new file mode 100644
index 000000000000..cdce488bb205
--- /dev/null
+++ b/www/npm-node8/Makefile
@@ -0,0 +1,13 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -node8
+
+CONFLICTS_INSTALL= npm npm-node4 npm-node6 npm2 npm3 npm4
+
+OPTIONS_EXCLUDE=NODE NODE4 NODE6
+OPTIONS_SLAVE= NODE8
+
+MASTERDIR= ${.CURDIR}/../npm
+
+.include "${MASTERDIR}/Makefile"