aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-19 22:16:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-19 22:16:18 +0000
commit91511104dd292fd41c0302159b2267543a17c6e8 (patch)
tree5e0ef4668dd271cb2c37f0954a376aae8844c11d /www
parent2af736c19515e0923207cbc84d61407dd9c231c8 (diff)
downloadports-91511104dd292fd41c0302159b2267543a17c6e8.tar.gz
ports-91511104dd292fd41c0302159b2267543a17c6e8.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/p5-RT-Extension-LDAPImport/Makefile11
-rw-r--r--www/p5-RT-Extension-SLA/Makefile8
-rw-r--r--www/p5-RTx-Calendar/Makefile8
-rw-r--r--www/p5-RTx-RightsMatrix/Makefile8
-rw-r--r--www/p5-RTx-Shredder/Makefile8
5 files changed, 30 insertions, 13 deletions
diff --git a/www/p5-RT-Extension-LDAPImport/Makefile b/www/p5-RT-Extension-LDAPImport/Makefile
index e4c85bdae379..028de5b7495c 100644
--- a/www/p5-RT-Extension-LDAPImport/Makefile
+++ b/www/p5-RT-Extension-LDAPImport/Makefile
@@ -27,9 +27,16 @@ CONFIGURE_ENV+= RTHOME=${PREFIX}/${RTHOME}
MAN3= RT::Extension::LDAPImport.3
-# Don't use normal CONFIGURE_ARGS
+post-patch:
+ @${REINPLACE_CMD} -e 's,/opt/rt3/lib,${PREFIX}/${RTHOME}/lib,' \
+ ${WRKSRC}/bin/rtldapimport
+
+# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
+# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
+# rather undesirably.
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT}
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT} && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
.include <bsd.port.mk>
diff --git a/www/p5-RT-Extension-SLA/Makefile b/www/p5-RT-Extension-SLA/Makefile
index 56ad92866698..2dd9bc73b88a 100644
--- a/www/p5-RT-Extension-SLA/Makefile
+++ b/www/p5-RT-Extension-SLA/Makefile
@@ -31,9 +31,13 @@ MAN3= RT::Action::SLA_SetDefault.3 \
RT::Condition::SLA_RequireStartsSet.3 RT::Queue_SLA.3 \
RT::Action::SLA_SetStarts.3 RT::Action::SLA.3
-# Don't use normal CONFIGURE_ARGS
+# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
+# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
+# rather undesirably.
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT}
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT} && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+
.include <bsd.port.mk>
diff --git a/www/p5-RTx-Calendar/Makefile b/www/p5-RTx-Calendar/Makefile
index 04b8db354e28..42699811e6e9 100644
--- a/www/p5-RTx-Calendar/Makefile
+++ b/www/p5-RTx-Calendar/Makefile
@@ -29,10 +29,12 @@ CONFIGURE_ENV+= RTHOME=${PREFIX}/${RTHOME}
MAN3PREFIX= ${PREFIX}/${RTHOME}/local
MAN3= RTx::Calendar.3
-# Don't use normal CONFIGURE_ARGS
+# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
+# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
+# rather undesirably.
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} \
- ${PERL5} ./${CONFIGURE_SCRIPT}
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT} && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
.include <bsd.port.mk>
diff --git a/www/p5-RTx-RightsMatrix/Makefile b/www/p5-RTx-RightsMatrix/Makefile
index 8d593cfe2481..8843e85d2389 100644
--- a/www/p5-RTx-RightsMatrix/Makefile
+++ b/www/p5-RTx-RightsMatrix/Makefile
@@ -28,10 +28,12 @@ MAN3= RTx::RightsMatrix::RolePrincipal.3 \
RTx::RightsMatrix::Util.3 \
RTx::RightsMatrix.3
-# Don't use normal CONFIGURE_ARGS
+# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
+# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
+# rather undesirably.
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} \
- ${PERL5} ./${CONFIGURE_SCRIPT}
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT} && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
.include <bsd.port.mk>
diff --git a/www/p5-RTx-Shredder/Makefile b/www/p5-RTx-Shredder/Makefile
index eeb20d7f101a..297162366e4d 100644
--- a/www/p5-RTx-Shredder/Makefile
+++ b/www/p5-RTx-Shredder/Makefile
@@ -37,10 +37,12 @@ MAN3= RTx::Shredder::Plugin::Base.3 \
RTx::Shredder::Plugin::Users.3 \
RTx::Shredder::Plugin::Objects.3
-# Don't use normal CONFIGURE_ARGS
+# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
+# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
+# rather undesirably.
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} \
- ${PERL5} ./${CONFIGURE_SCRIPT}
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT} && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
.include <bsd.port.mk>