aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-01 07:23:22 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-01 07:23:22 +0000
commit9b67cf1de81be8e819071628711514408de917bf (patch)
tree97e16dce47567090e32416a995147d60c4ebd94f /www
parent469eb887d2ac5ddfe413dc7eced574ffaabd2de3 (diff)
downloadports-9b67cf1de81be8e819071628711514408de917bf.tar.gz
ports-9b67cf1de81be8e819071628711514408de917bf.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/gurlchecker/Makefile44
-rw-r--r--www/mod_musicindex/Makefile6
2 files changed, 24 insertions, 26 deletions
diff --git a/www/gurlchecker/Makefile b/www/gurlchecker/Makefile
index f6770ada7276..75a8dc54dff0 100644
--- a/www/gurlchecker/Makefile
+++ b/www/gurlchecker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gURLChecker
-# Date created: 06 Jun 2003
-# Whom: Koop Mast <einekoai@chello.nl>
-#
+# Created by: Koop Mast <einekoai@chello.nl>
# $FreeBSD$
-#
PORTNAME= gurlchecker
PORTVERSION= 0.10.1
@@ -13,52 +9,56 @@ MASTER_SITES= http://labs.libre-entreprise.org/frs/download.php/%SUBDIR%/
MASTER_SITE_SUBDIR= 547
MAINTAINER= clsung@FreeBSD.org
-COMMENT= A Gnome program to check a page/website for broken links
+COMMENT= Gnome program to check a page/website for broken links
LIB_DEPENDS= gnet-2.0.0:${PORTSDIR}/net/gnet2
-OPTIONS= CROCO "Use CROCO library for CSS2 validation" off \
- TIDY "Use TIDY library for HTML w3c validation" off \
- CLAMAV "Use CLAMAV library for virii scan" on \
- GNUTLS "Use GNU TLS library for HTTPS check" on
+OPTIONS_DEFINE= CROCO TIDY CLAMAV GNUTLS
+CROCO_DESC=Library for CSS2 validation
+TIDY_DESC=Library for HTML w3c validation
+CLAMAV_DESC=Library for virii scan
+GNUTLS_DESC=Library for HTTPS check
-USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
+OPTIONS_DEFAULT= CLAMAV GNUTLS
+
+USE_GNOME= gnomeprefix intlhack libgnomeui
+USES= pathfix
USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_CROCO)
+.if ${PORT_OPTIONS:MCROCO}
LIB_DEPENDS+= croco-0.6.3:${PORTSDIR}/textproc/libcroco
.else
CONFIGURE_ARGS+= --disable-croco
.endif
-.if defined(WITH_TIDY)
+.if ${PORT_OPTIONS:MTIDY}
LIB_DEPENDS+= tidy-0.99.0:${PORTSDIR}/www/tidy-lib
.else
CONFIGURE_ARGS+= --disable-tidy
.endif
-.if defined(WITH_CLAMAV)
+.if ${PORT_OPTIONS:MCLAMAV}
LIB_DEPENDS+= clamav.7:${PORTSDIR}/security/clamav
.else
CONFIGURE_ARGS+= --disable-clamav
.endif
-.if defined(WITHOUT_GNUTLS)
-CONFIGURE_ARGS+= --disable-gnutls
-.else
+.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
+.else
+CONFIGURE_ARGS+= --disable-gnutls
.endif
post-patch:
@@ -68,9 +68,9 @@ post-patch:
'/^SUBDIRS/s|doc ui man|ui|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|-lresolv||g' ${WRKSRC}/src/Makefile.in
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e \
'/^SUBDIRS/s|po ui|ui|g' ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 7080feb7b78e..43bf1b2be14c 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -14,8 +14,6 @@ LICENSE= LGPL21
USE_APACHE= 22
-.include <bsd.port.pre.mk>
-
OPTIONS_DEFINE= NLS FLAC MP3 MP4 VORBIS LIBARCHIVE FILECACHE MYSQLCACHE
OPTIONS_DEFAULT=NLS MP3 LIBARCHIVE FILECACHE
@@ -39,7 +37,7 @@ SUB_LIST= PORTNAME=${PORTNAME}
PORTDOCS= README
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES== gettext
CFLAGS+= -lintl
PLIST_SUB+= NLS=""
CONFIGURE_ARGS+=--enable-nls
@@ -117,4 +115,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG} ""
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>