aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-21 14:22:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-21 14:22:55 +0000
commita75306e24ac2d7929eb702694a9de1ac06cfef83 (patch)
tree44acc567d8cd686ad0ea94e7499a02f62f9ae160 /www
parent047add43998551e44f74e9d03ae244084a909e24 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-sortedm2m/Makefile21
-rw-r--r--www/py-django-sortedm2m/distinfo2
-rw-r--r--www/py-django-sortedm2m/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 38502b5a01dd..0bcf82cdd750 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1570,6 +1570,7 @@
SUBDIR += py-django-sekizai
SUBDIR += py-django-signals-ahoy
SUBDIR += py-django-simple-captcha
+ SUBDIR += py-django-sortedm2m
SUBDIR += py-django-statici18n
SUBDIR += py-django-storages
SUBDIR += py-django-subdomains
diff --git a/www/py-django-sortedm2m/Makefile b/www/py-django-sortedm2m/Makefile
new file mode 100644
index 000000000000..c4467655c67b
--- /dev/null
+++ b/www/py-django-sortedm2m/Makefile
@@ -0,0 +1,21 @@
+# Created by: Kevin Golding <ports@caomhin.org>
+# $FreeBSD$
+
+PORTNAME= django-sortedm2m
+PORTVERSION= 1.1.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= Replacement for Django's many to many field
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-django
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/www/py-django-sortedm2m/distinfo b/www/py-django-sortedm2m/distinfo
new file mode 100644
index 000000000000..4061c5718a03
--- /dev/null
+++ b/www/py-django-sortedm2m/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-sortedm2m-1.1.0.tar.gz) = a591e97d2f9f20b73bbc294c2245633a2f7ee8e074291a6fd4c6e3eb064806a1
+SIZE (django-sortedm2m-1.1.0.tar.gz) = 34398
diff --git a/www/py-django-sortedm2m/pkg-descr b/www/py-django-sortedm2m/pkg-descr
new file mode 100644
index 000000000000..f28eb871d8cc
--- /dev/null
+++ b/www/py-django-sortedm2m/pkg-descr
@@ -0,0 +1,5 @@
+sortedm2m is a drop-in replacement for Django's own ManyToManyField. The
+provided SortedManyToManyField behaves like the original one but remembers
+the order of added relations.
+
+WWW: https://github.com/gregmuellegger/django-sortedm2m