aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-12-27 10:46:15 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-12-27 10:46:15 +0000
commitbe15a91570adc30fc6ef76e96337fcb1b1108bc7 (patch)
tree2b4ecd11e8ead68ead2cf788441eab743567cc53 /www
parent9e26ce78f0bfb86988755dd5aa236987a2a604bf (diff)
downloadports-be15a91570adc30fc6ef76e96337fcb1b1108bc7.tar.gz
ports-be15a91570adc30fc6ef76e96337fcb1b1108bc7.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Test-HTTP-Server-Simple/Makefile33
-rw-r--r--www/p5-Test-HTTP-Server-Simple/distinfo3
-rw-r--r--www/p5-Test-HTTP-Server-Simple/pkg-descr4
-rw-r--r--www/p5-Test-HTTP-Server-Simple/pkg-plist9
5 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c528847bc9c6..a44e567f33e9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -658,6 +658,7 @@
SUBDIR += p5-Template-Plugin-Monta
SUBDIR += p5-Template-Timer
SUBDIR += p5-Template-Toolkit
+ SUBDIR += p5-Test-HTTP-Server-Simple
SUBDIR += p5-URI-Fetch
SUBDIR += p5-URI-Sequin
SUBDIR += p5-W3C-LinkChecker
diff --git a/www/p5-Test-HTTP-Server-Simple/Makefile b/www/p5-Test-HTTP-Server-Simple/Makefile
new file mode 100644
index 000000000000..2c583485367f
--- /dev/null
+++ b/www/p5-Test-HTTP-Server-Simple/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: www/p5-Test-HTTP-Server-Simple
+# Date created: 27 December 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-HTTP-Server-Simple
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Test::More functions for HTTP::Server::Simple
+
+BUILD_DEPENDS= ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ ${SITE_PERL}/NEXT.pm:${PORTSDIR}/devel/p5-NEXT \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::HTTP::Server::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Test-HTTP-Server-Simple/distinfo b/www/p5-Test-HTTP-Server-Simple/distinfo
new file mode 100644
index 000000000000..6bf4d88b68af
--- /dev/null
+++ b/www/p5-Test-HTTP-Server-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-HTTP-Server-Simple-0.02.tar.gz) = 995c62aed2d3caa640a653109d7e8689
+SHA256 (Test-HTTP-Server-Simple-0.02.tar.gz) = 99a7b986bbe2b498092808058be5b388b150c5c481276c4d36c9442e902cd9be
+SIZE (Test-HTTP-Server-Simple-0.02.tar.gz) = 4826
diff --git a/www/p5-Test-HTTP-Server-Simple/pkg-descr b/www/p5-Test-HTTP-Server-Simple/pkg-descr
new file mode 100644
index 000000000000..804fa44c2a55
--- /dev/null
+++ b/www/p5-Test-HTTP-Server-Simple/pkg-descr
@@ -0,0 +1,4 @@
+This mixin class provides methods to test an HTTP::Server::Simple-based web
+server. Currently, it provides only one such method: started_ok.
+
+WWW: http://search.cpan.org/dist/Test-HTTP-Server-Simple/
diff --git a/www/p5-Test-HTTP-Server-Simple/pkg-plist b/www/p5-Test-HTTP-Server-Simple/pkg-plist
new file mode 100644
index 000000000000..e6b786db84f6
--- /dev/null
+++ b/www/p5-Test-HTTP-Server-Simple/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Test/HTTP/Server/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/HTTP/Server/Simple/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/HTTP/Server/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/HTTP/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/HTTP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test/HTTP/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test/HTTP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true