aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-04-16 11:50:14 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-04-16 11:50:14 +0000
commitf6cb2453c0ac198edd5773d3a0c677fb4ec6f539 (patch)
treee0264e26f713e0f0dc759713616de9f9e98efa8c /www
parent199f814e16a85e7a3c819308899b68b920850f20 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mod_php3/scripts/configure.php10
-rw-r--r--www/mod_php4/scripts/configure.php10
-rw-r--r--www/mod_php5/scripts/configure.php10
3 files changed, 18 insertions, 12 deletions
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index b09c72ded1d5..5e7cad763a09 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -5,6 +5,8 @@ if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
exit
fi
+tempfile=`/usr/bin/mktemp -t checklist`
+
if [ "${BATCH}" ]; then
set \"zlib\" \"MySQL\"
else
@@ -32,14 +34,14 @@ gettext "gettext library support" OFF \
YP "YP/NIS support" OFF \
sysvsem "System V semaphore support" OFF \
sysvshm "System V shared memory support" OFF \
-2> /tmp/checklist.tmp.$$
+2> $tempfile
retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ if [ -s $tempfile ]; then
+ set `cat $tempfile`
fi
- rm -f /tmp/checklist.tmp.$$
+ rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index a5d1ef18bf77..fa48d59f9730 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -5,6 +5,8 @@ if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
exit
fi
+tempfile=`/usr/bin/mktemp -t checklist`
+
if [ "${BATCH}" ]; then
set \"zlib\" \"MySQL\"
else
@@ -39,14 +41,14 @@ sockets "sockets support" OFF \
sysvsem "System V semaphore support" OFF \
sysvshm "System V shared memory support" OFF \
transsid "Transparent session id" OFF \
-2> /tmp/checklist.tmp.$$
+2> $tempfile
retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ if [ -s $tempfile ]; then
+ set `cat $tempfile`
fi
- rm -f /tmp/checklist.tmp.$$
+ rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index a5d1ef18bf77..fa48d59f9730 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -5,6 +5,8 @@ if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
exit
fi
+tempfile=`/usr/bin/mktemp -t checklist`
+
if [ "${BATCH}" ]; then
set \"zlib\" \"MySQL\"
else
@@ -39,14 +41,14 @@ sockets "sockets support" OFF \
sysvsem "System V semaphore support" OFF \
sysvshm "System V shared memory support" OFF \
transsid "Transparent session id" OFF \
-2> /tmp/checklist.tmp.$$
+2> $tempfile
retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ if [ -s $tempfile ]; then
+ set `cat $tempfile`
fi
- rm -f /tmp/checklist.tmp.$$
+ rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then