aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-09-19 21:58:39 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-09-19 21:58:39 +0000
commit0b373b2ae1420b8fefe6dce2712999822854cd24 (patch)
tree6d5bc62f20f7ec3781fb8153e9d818ba8923210e /www
parent68d4f39ab5f0fc3f38fedfe20f3a791f3ccb2501 (diff)
downloadports-0b373b2ae1420b8fefe6dce2712999822854cd24.tar.gz
ports-0b373b2ae1420b8fefe6dce2712999822854cd24.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bug129969431
-rw-r--r--www/firefox/files/patch-bug130338026
3 files changed, 58 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 597829ac51bc..e562c90065cd 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 49.0
DISTVERSIONSUFFIX=.source
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-bug1299694 b/www/firefox/files/patch-bug1299694
new file mode 100644
index 000000000000..2742c32b4f4a
--- /dev/null
+++ b/www/firefox/files/patch-bug1299694
@@ -0,0 +1,31 @@
+commit 6ab2496
+Author: Chris Pearce <cpearce@mozilla.com>
+Date: Mon Sep 5 13:54:37 2016 +1200
+
+ Bug 1299694 - Ensure we don't enable Widevine unintentionally. r=glandium
+
+ On FreeBSD the target.kernel etc checks in enable_eme are failing,
+ but we're still falling through to |return value|, and so Widevine
+ is being enabled. If we remove the |return value| from enable_eme
+ we at least make Widevine disabled where it's not supposed to be
+ enabled.
+
+ MozReview-Commit-ID: D1h0IUidxhv
+---
+ toolkit/moz.configure | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git toolkit/moz.configure toolkit/moz.configure
+index 0c98c7a..a00b6eb 100644
+--- toolkit/moz.configure
++++ toolkit/moz.configure
+@@ -366,7 +366,8 @@ def enable_eme(value, target):
+ return value
+ elif value and value.origin != 'default':
+ die('%s is not supported on %s' % (value.format('--enable-eme'), target.alias))
+- return value
++ # Return the same type of OptionValue (Positive or Negative), with an empty tuple.
++ return value.__class__(())
+
+ @depends(enable_eme, fmp4)
+ def eme(value, fmp4):
diff --git a/www/firefox/files/patch-bug1303380 b/www/firefox/files/patch-bug1303380
new file mode 100644
index 000000000000..5753fc87030f
--- /dev/null
+++ b/www/firefox/files/patch-bug1303380
@@ -0,0 +1,26 @@
+commit c0fd0d3
+Author: Jared Wein <jwein@mozilla.com>
+Date: Mon Sep 19 15:40:28 2016 -0400
+
+ Bug 1303380 - Wrap the telemetry code in _firstWindowLoaded with a try/catch to allow startup and migration code to run to completion if there is an exception writing to Telemetry. r=gijs
+
+ MozReview-Commit-ID: DPfq6lZ4fM3
+---
+ browser/components/nsBrowserGlue.js | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git browser/components/nsBrowserGlue.js browser/components/nsBrowserGlue.js
+index eebbef2..20706fd 100644
+--- browser/components/nsBrowserGlue.js
++++ browser/components/nsBrowserGlue.js
+@@ -931,7 +931,9 @@ BrowserGlue.prototype = {
+ }
+ if (SCALING_PROBE_NAME) {
+ let scaling = aWindow.devicePixelRatio * 100;
+- Services.telemetry.getHistogramById(SCALING_PROBE_NAME).add(scaling);
++ try {
++ Services.telemetry.getHistogramById(SCALING_PROBE_NAME).add(scaling);
++ } catch (ex) {}
+ }
+ },
+