aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /www
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/choqok/Makefile4
-rw-r--r--www/kdewebdev4/Makefile4
-rw-r--r--www/kpartsplugin/Makefile4
-rw-r--r--www/kwebkitpart/Makefile4
-rw-r--r--www/opera/Makefile3
-rw-r--r--www/qupzilla-qt4/Makefile3
-rw-r--r--www/rekonq/Makefile6
7 files changed, 15 insertions, 13 deletions
diff --git a/www/choqok/Makefile b/www/choqok/Makefile
index 9c49a6ebbf4a..8f1286d808c3 100644
--- a/www/choqok/Makefile
+++ b/www/choqok/Makefile
@@ -17,10 +17,10 @@ LIB_DEPENDS= libqjson.so:devel/qjson \
libqoauth.so:net/qoauth \
libtelepathy-qt4.so:net-im/telepathy-qt4
-USE_KDE4= attica automoc4 kdelibs
+USES= cmake gettext kde:4 tar:xz
+USE_KDE= attica automoc4 kdelibs
USE_QT4= gui imageformats_run network \
moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:xz
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/www/kdewebdev4/Makefile b/www/kdewebdev4/Makefile
index a6bdab64a6b7..717ed7677c27 100644
--- a/www/kdewebdev4/Makefile
+++ b/www/kdewebdev4/Makefile
@@ -14,9 +14,9 @@ COMMENT= Comprehensive html/website development environment
LIB_DEPENDS= libtidy.so:www/tidy-lib \
libboost_thread.so:devel/boost-libs
+USES= cmake:outsource kde:4 tar:xz
USE_GNOME= libxml2 libxslt
-USE_KDE4= kdelibs pimlibs automoc4
-USES= cmake:outsource tar:xz
+USE_KDE= kdelibs pimlibs automoc4
USE_QT4= dbus porting_build \
qmake_build moc_build rcc_build uic_build uic3_build
USE_LDCONFIG= yes
diff --git a/www/kpartsplugin/Makefile b/www/kpartsplugin/Makefile
index 15cf96de68a8..20296237e724 100644
--- a/www/kpartsplugin/Makefile
+++ b/www/kpartsplugin/Makefile
@@ -10,9 +10,9 @@ DISTNAME= ${PORTNAME}-${PORTDATE}
MAINTAINER= avilla@FreeBSD.org
COMMENT= Browser file viewer using KDE technology
-USE_KDE4= kdelibs automoc4
+USES= cmake kde:4 webplugin:native tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
-USES= cmake webplugin:native tar:bzip2
CMAKE_ARGS= -DNSPLUGIN_INSTALL_DIR:PATH="${WEBPLUGIN_DIR}"
PORTDATE= 20120723
diff --git a/www/kwebkitpart/Makefile b/www/kwebkitpart/Makefile
index e8675d4238b3..d80a1bc89e62 100644
--- a/www/kwebkitpart/Makefile
+++ b/www/kwebkitpart/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= LOCAL/makc
MAINTAINER= kde@FreeBSD.org
COMMENT= Web browser component for KDE SC based on QtWebKit
-USE_KDE4= kdelibs automoc4
+USES= cmake kde:4 cpe tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= designer gui webkit \
moc_build qmake_build rcc_build uic_build
-USES= cmake cpe tar:xz
CPE_VENDOR= urs_wolfer
diff --git a/www/opera/Makefile b/www/opera/Makefile
index eca0f1cad32d..3959591eedd3 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -46,7 +46,8 @@ CUPS_LIB_DEPENDS= libcups.so:print/cups
VIDEO_USE= gstreamer=vorbis,ogg,theora,vp8,good
GTK2_USE= gnome=gtk20,libxml2
-KDE4_USE= kde4=kdelibs
+KDE4_USES= kde:4
+KDE4_USE= KDE=kdelibs
.include <bsd.port.options.mk>
diff --git a/www/qupzilla-qt4/Makefile b/www/qupzilla-qt4/Makefile
index 06c8f80df388..6780ba0518dd 100644
--- a/www/qupzilla-qt4/Makefile
+++ b/www/qupzilla-qt4/Makefile
@@ -37,7 +37,8 @@ DBUS_CONFIGURE_ENV_OFF= DISABLE_DBUS="true"
GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring
GNOMEKEYRING_CONFIGURE_ENV= GNOME_INTEGRATION="true"
-KWALLET_USE= KDE4=kdelibs
+KWALLET_USES= kde:4
+KWALLET_USE= KDE=kdelibs
KWALLET_CONFIGURE_ENV= KDE_INTEGRATION="true"
post-patch:
diff --git a/www/rekonq/Makefile b/www/rekonq/Makefile
index 2cdd6f539a0e..27062d679b2a 100644
--- a/www/rekonq/Makefile
+++ b/www/rekonq/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTVERSION:C,\..*,.0,}/
MAINTAINER= makc@FreeBSD.org
COMMENT= Lightweight KDE browser based on WebKit
-USES= cmake:outsource gettext tar:xz
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource gettext kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= script webkit \
moc_build qmake_build rcc_build uic_build
@@ -24,7 +24,7 @@ OPERA_CMAKE_OFF= -DWITH_QCA2=off \
-DWITH_QtOAuth=off
NEPOMUK_DESC= Bookmarks tagging via Nepomuk
-NEPOMUK_USE= KDE4=nepomuk-core
+NEPOMUK_USE= KDE=nepomuk-core
NEPOMUK_CMAKE_OFF= -DWITH_NepomukCore=off
post-patch: