aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-07-27 16:16:18 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-07-27 16:16:18 +0000
commit1288cb80656d8c0882f0dca01713188d327303c8 (patch)
treeb0a0410dab110367630367f1c5ec86d9144c9877 /www
parent29aaf6774b0030cd1101d912f5bba59c8aa7f2f1 (diff)
downloadports-1288cb80656d8c0882f0dca01713188d327303c8.tar.gz
ports-1288cb80656d8c0882f0dca01713188d327303c8.zip
MFH: r542676
www/firefox: update to 79.0 Changes: https://www.mozilla.org/firefox/79.0/releasenotes/ Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2020Q3/; revision=543531
Diffstat (limited to 'www')
-rw-r--r--www/firefox/Makefile8
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug8475682
3 files changed, 8 insertions, 8 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 4ecb60cda0ad..2ac5bf9e5886 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -2,21 +2,21 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 78.0.2
+DISTVERSION= 79.0
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build2/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.25:devel/nspr \
- nss>=3.53.1:security/nss \
+ nss>=3.54:security/nss \
icu>=67.1,1:devel/icu \
libevent>=2.1.8:devel/libevent \
- harfbuzz>=2.6.6:print/harfbuzz \
+ harfbuzz>=2.6.8:print/harfbuzz \
graphite2>=1.3.14:graphics/graphite2 \
png>=1.6.35:graphics/png \
libvpx>=1.8.2:multimedia/libvpx \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 29949bc7473f..40e6c90255db 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594245322
-SHA256 (firefox-78.0.2.source.tar.xz) = 1aa00ec6d40a771d525b867b175be28eda096becc745875bcceb133a985750fc
-SIZE (firefox-78.0.2.source.tar.xz) = 334406116
+TIMESTAMP = 1595285412
+SHA256 (firefox-79.0.source.tar.xz) = 12a922855914ec6b4d4f06a4ac58bc549aca6bdafd3722d68a3d709a935e5713
+SIZE (firefox-79.0.source.tar.xz) = 333220776
diff --git a/www/firefox/files/patch-bug847568 b/www/firefox/files/patch-bug847568
index 88511da00630..b24638761af6 100644
--- a/www/firefox/files/patch-bug847568
+++ b/www/firefox/files/patch-bug847568
@@ -278,7 +278,7 @@ index 9297e4d6f501..d8e273887e4b 100644
+option('--with-system-harfbuzz',
+ help="Use system harfbuzz (located with pkgconfig)")
+
-+system_harfbuzz = pkg_check_modules('MOZ_HARFBUZZ', 'harfbuzz >= 2.6.6',
++system_harfbuzz = pkg_check_modules('MOZ_HARFBUZZ', 'harfbuzz >= 2.6.8',
+ when='--with-system-harfbuzz')
+
+set_config('MOZ_SYSTEM_HARFBUZZ', depends_if(system_harfbuzz)(lambda _: True))