aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-28 13:55:34 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-28 13:55:34 +0000
commit30f69b026598ba65ecae618c77a361606c33c041 (patch)
tree8836e21e49c251a56f777b6a6ff1ab5bcaa3e3f4 /www
parent8e21397a0162806803419838e9ac2a9a4d2d8a21 (diff)
www/bookmarkbridge: Fix build with Clang 6
xbelwrite.cpp:90:7: error: declaration of variable 'QString' with deduced type 'auto' requires an initializer auto QString tempstr; ^ http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/bookmarkbridge-0.76_6.log - Deprecate it. It is doubtful this works correctly with modern browsers anymore.
Notes
Notes: svn path=/head/; revision=478317
Diffstat (limited to 'www')
-rw-r--r--www/bookmarkbridge/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/bookmarkbridge/Makefile b/www/bookmarkbridge/Makefile
index f504b748b1ec..d8ce9af2abc1 100644
--- a/www/bookmarkbridge/Makefile
+++ b/www/bookmarkbridge/Makefile
@@ -13,7 +13,11 @@ COMMENT= Synchronize bookmarks between multiple browsers
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Unmaintained. Unlikely to work correctly with modern browsers
+EXPIRATION_DATE= 2018-09-15
+
USES= autoreconf gmake perl5 pkgconfig qt:4 shebangfix
+USE_CXXSTD= gnu++98
SHEBANG_FILES= bookmarkbridge/docs/autodocs.pl
USE_XORG= x11 ice xext
USE_QT= corelib gui qt3support moc_build rcc_build uic_build