aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-13 18:40:21 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-13 18:40:21 +0000
commit66866ba7070dda631e06c79df6ea0ef5b15bca4c (patch)
treee4a03290e3526c511b4d8215c34ab8a5e717ba37 /www
parentf2b540f0093d00de6bce944014753315b35a54c2 (diff)
downloadports-66866ba7070dda631e06c79df6ea0ef5b15bca4c.tar.gz
ports-66866ba7070dda631e06c79df6ea0ef5b15bca4c.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/tomcat-native/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/www/tomcat-native/Makefile b/www/tomcat-native/Makefile
index 2db4f52d9276..1c697aeb08e9 100644
--- a/www/tomcat-native/Makefile
+++ b/www/tomcat-native/Makefile
@@ -16,9 +16,7 @@ LIB_DEPENDS= libapr-1.so:devel/apr1
WRKSRC= ${WRKDIR}/${DISTNAME}/native
-USES= libtool
-USE_OPENSSL= yes
-WITH_OPENSSL_PORT= yes
+USES= libtool ssl
USE_JAVA= yes
USE_LDCONFIG= yes
JAVA_VERSION= 1.6+
@@ -35,4 +33,15 @@ PLIST_FILES= lib/libtcnative-1.a \
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtcnative-1.so.0.2.7
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} == base
+IGNORE_FreeBSD_9= Requires OpenSSL 1.0.2 (set SSL_DEFAULT=openssl)
+IGNORE_FreeBSD_10= Requires OpenSSL 1.0.2 (set_SSL_DEFAULT=openssl)
+.endif
+
+.if ${SSL_DEFAULT:Mlibressl*}
+IGNORE= Detected LibreSSL (missing numerous symbols during linking)
+.endif
+
+.include <bsd.port.post.mk>