aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2014-09-07 09:59:00 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2014-09-07 09:59:00 +0000
commit7cf90b271810d1a65e482e711538c262cf99cbb6 (patch)
treebe5d08e56f2145980a81270e5c97c6f38d1ae8a0 /www
parentd604a8981ce849ffad10c592694059d7c46af35c (diff)
downloadports-7cf90b271810d1a65e482e711538c262cf99cbb6.tar.gz
ports-7cf90b271810d1a65e482e711538c262cf99cbb6.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django16/Makefile68
-rw-r--r--www/py-django16/distinfo2
-rw-r--r--www/py-django16/pkg-descr10
4 files changed, 81 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5d63a5341f90..df42745f9e7f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1510,6 +1510,7 @@
SUBDIR += py-django-tinymce
SUBDIR += py-django14
SUBDIR += py-django15
+ SUBDIR += py-django16
SUBDIR += py-django_compressor
SUBDIR += py-djangotoolbox
SUBDIR += py-djblets
diff --git a/www/py-django16/Makefile b/www/py-django16/Makefile
new file mode 100644
index 000000000000..d99faaeee01d
--- /dev/null
+++ b/www/py-django16/Makefile
@@ -0,0 +1,68 @@
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+# $FreeBSD$
+
+PORTNAME= django
+PORTVERSION= 1.6.6
+CATEGORIES= www python
+MASTER_SITES= https://www.djangoproject.com/m/releases/${PORTVERSION}/ \
+ CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Django-${PORTVERSION}
+DIST_SUBDIR= python
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= High-level Python Web framework
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cpe python:2
+USE_PYTHON= autoplist distutils
+
+CPE_VENDOR= djangoproject
+
+CONFLICTS= py[23][0-9]-django-devel-[0-9]* py[23][0-9]-django-1.[0-57-9].*
+
+DOCSDIR= ${PREFIX}/share/doc/py-django
+
+OPTIONS_DEFINE= FASTCGI HTMLDOCS
+OPTIONS_DEFAULT=SQLITE
+OPTIONS_GROUP= DATABASE
+OPTIONS_GROUP_DATABASE= PGSQL MYSQL SQLITE
+HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
+
+PLIST_FILES= man/man1/daily_cleanup.1.gz \
+ man/man1/django-admin.1.gz \
+ man/man1/gather_profile_stats.1.gz
+
+PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+FASTCGI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MHTMLDOCS}
+. if empty(PORT_OPTIONS:MDOCS)
+IGNORE= you cannot build documentation with DOCS option disabled
+. endif
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
+PORTDOCS= *
+.endif
+
+post-build:
+.if ${PORT_OPTIONS:MHTMLDOCS}
+ cd ${WRKSRC}/docs && ${MAKE} html
+.endif
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${MAN1PREFIX}/man/man1
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
+ @${ECHO_MSG} ""
+.if ${PORT_OPTIONS:MHTMLDOCS}
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/_build/html ${STAGEDIR}/${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/py-django16/distinfo b/www/py-django16/distinfo
new file mode 100644
index 000000000000..13a51e67455a
--- /dev/null
+++ b/www/py-django16/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/Django-1.6.6.tar.gz) = 536cbd54e533ba3563d205f0c91988b24e7d74b8b253d7825e42214b50ba7e90
+SIZE (python/Django-1.6.6.tar.gz) = 6645456
diff --git a/www/py-django16/pkg-descr b/www/py-django16/pkg-descr
new file mode 100644
index 000000000000..638401f81c0e
--- /dev/null
+++ b/www/py-django16/pkg-descr
@@ -0,0 +1,10 @@
+Django is a high-level Python Web framework that encourages rapid development
+and clean, pragmatic design.
+
+Developed and used over the past two years by a fast-moving online-news
+operation, Django was designed from scratch to handle two challenges: the
+intensive deadlines of a newsroom and the stringent requirements of experienced
+Web developers. It has convenient niceties for developing content-management
+systems, but it's an excellent tool for building any Web site.
+
+WWW: http://www.djangoproject.com