aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-04 11:07:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-04 11:07:48 +0000
commit7d8ff46565d50533dfa3882d773fa0668760826d (patch)
tree62baade3722e3ed5427f5a94c698ff66cc8a0b9c /www
parentbc54a1640cf75ed3f05639cabbc939b0e06219e3 (diff)
downloadports-7d8ff46565d50533dfa3882d773fa0668760826d.tar.gz
ports-7d8ff46565d50533dfa3882d773fa0668760826d.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/elinks/Makefile3
-rw-r--r--www/elinks/distinfo4
-rw-r--r--www/elinks/files/patch-compression44
-rw-r--r--www/elinks/files/patch-src::document::html::parser.c13
4 files changed, 3 insertions, 61 deletions
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index 988be553f813..d42436233cf5 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= elinks
-PORTVERSION= 0.4.2
-PORTREVISION= 2
+PORTVERSION= 0.4.3
CATEGORIES= www
MASTER_SITES= http://elinks.or.cz/download/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
diff --git a/www/elinks/distinfo b/www/elinks/distinfo
index 41bc32d8c4d0..b75f2770951e 100644
--- a/www/elinks/distinfo
+++ b/www/elinks/distinfo
@@ -1,2 +1,2 @@
-MD5 (elinks-0.4.2.tar.bz2) = bb77dcd59968634477f5a6d5f07ccd5e
-MD5 (elinks-0.4.2.tar.bz2.asc) = ae0fb86afdb253bc32cac94bfed0b8c0
+MD5 (elinks-0.4.3.tar.bz2) = 34a2ac8ac873d2739282ad6844dfa779
+MD5 (elinks-0.4.3.tar.bz2.asc) = 574ba2ded94b5936f2d59febefe0577a
diff --git a/www/elinks/files/patch-compression b/www/elinks/files/patch-compression
deleted file mode 100644
index 9b67317e74e6..000000000000
--- a/www/elinks/files/patch-compression
+++ /dev/null
@@ -1,44 +0,0 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-NotDashEscaped: You need GnuPG to verify this message
-
-
-# copied from:
-# http://archive.linuxfromscratch.org/mail-archives/links-list/2003/02/att-0021/01-elinks-openbsd_bug.patch
-# http://archive.linuxfromscratch.org/mail-archives/links-list/2003/02/0021.html
-
---- src/protocol/http/http.c.orig Sun Feb 9 02:14:19 2003
-+++ src/protocol/http/http.c Sun Feb 9 02:21:10 2003
-@@ -710,6 +710,8 @@
- }
-
- do {
-+ int init;
-+
- if (to_read == PIPE_BUF / 2) {
- /* ... we aren't finishing yet. */
- int written = write(conn->stream_pipes[1], data,
-@@ -743,12 +745,13 @@
- conn->stream = open_encoded(conn->stream_pipes[0],
- conn->content_encoding);
- if (!conn->stream) return NULL;
-- }
-+ else init = 1;
-+ } else init = 0;
-
- output = (unsigned char *) mem_realloc(output, *new_len + to_read);
- if (!output) break;
-
-- did_read = read_encoded(conn->stream, output + *new_len, to_read);
-+ did_read = read_encoded(conn->stream, output + *new_len, init ? PIPE_BUF / 4 : to_read);
- if (did_read > 0) *new_len += did_read;
- } while (!(!len && did_read != to_read));
-
-
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.1 (FreeBSD)
-
-iD8DBQE+Wnf/SypIl9OdoOMRAiKLAJ9UoMBFqKp6Z5WQPCpWyyLnZ5js3ACfbalV
-mEIH0ioE4rpuE/Tmcu9nj08=
-=5S2+
------END PGP SIGNATURE-----
diff --git a/www/elinks/files/patch-src::document::html::parser.c b/www/elinks/files/patch-src::document::html::parser.c
deleted file mode 100644
index c90bd55328ba..000000000000
--- a/www/elinks/files/patch-src::document::html::parser.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/document/html/parser.c.orig Sat Sep 6 02:09:37 2003
-+++ src/document/html/parser.c Sat Sep 6 02:10:14 2003
-@@ -2330,8 +2330,8 @@
- parse_frame_widths(d, y, HTML_FRAME_CHAR_HEIGHT, &fp.yw, &fp.y);
- fp.parent = html_top.frameset;
- if (fp.x && fp.y) html_top.frameset = special_f(ff, SP_FRAMESET, &fp);
-- mem_free(fp.xw);
-- mem_free(fp.yw);
-+ if (fp.x) mem_free(fp.xw);
-+ if (fp.y) mem_free(fp.yw);
-
- free_cd:
- mem_free(c);