aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-16 15:56:59 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-16 15:56:59 +0000
commitb3a94988dba281d0d6ba28eed15954e8c7274ab0 (patch)
tree9d7279de47178f8e22f7cd6b6e02006d6372602b /www
parent8b76648e17c0c761e15b249dccbb0e5f3e5f5feb (diff)
Add mod_accessCookie 0.4.
This module restricts access in the same way as an 'allow from' does (it is derived form this module :), by checking for the exinstence of a cookie. If a cookie is present it compares it to cookies found in a mySQL database. If it can find a equivalent cookie there, access is granted, else access is denied.
Notes
Notes: svn path=/head/; revision=107243
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_accesscookie/Makefile35
-rw-r--r--www/mod_accesscookie/distinfo2
-rw-r--r--www/mod_accesscookie/pkg-descr5
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 566b589a7427..942a9df9a086 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -199,6 +199,7 @@
SUBDIR += mnogosearch
SUBDIR += mod_access_identd
SUBDIR += mod_access_referer
+ SUBDIR += mod_accesscookie
SUBDIR += mod_accounting
SUBDIR += mod_auth_any
SUBDIR += mod_auth_cookie_mysql
diff --git a/www/mod_accesscookie/Makefile b/www/mod_accesscookie/Makefile
new file mode 100644
index 000000000000..c012d64e60b9
--- /dev/null
+++ b/www/mod_accesscookie/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mod_accessCookie
+# Date created: Apr 16 2004
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_accessCookie
+PORTVERSION= 0.4
+CATEGORIES= www
+MASTER_SITES= http://etweb.wkv.at/himself/Programming/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= Supply access control based cookies stored in a MySQL database
+
+USE_MYSQL= YES
+WANT_APACHE= 13
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+AP_INC+= ${LOCALBASE}/include/mysql
+AP_LIB+= ${LOCALBASE}/lib/mysql -lmysqlclient
+
+PORTDOCS= README
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/mod_accesscookie/distinfo b/www/mod_accesscookie/distinfo
new file mode 100644
index 000000000000..3461a91b871d
--- /dev/null
+++ b/www/mod_accesscookie/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_accessCookie-0.4.tgz) = 638d06ed61a7bda08a69c5c86343302e
+SIZE (mod_accessCookie-0.4.tgz) = 7638
diff --git a/www/mod_accesscookie/pkg-descr b/www/mod_accesscookie/pkg-descr
new file mode 100644
index 000000000000..3d27ef58312c
--- /dev/null
+++ b/www/mod_accesscookie/pkg-descr
@@ -0,0 +1,5 @@
+This module restricts access in the same way as an 'allow from'
+does (it is derived form this module :), by checking for the exinstence of
+a cookie. If a cookie is present it compares it to cookies found in a
+mySQL database. If it can find a equivalent cookie there, access is
+granted, else access is denied.