aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-02-20 07:16:31 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-02-20 07:16:31 +0000
commitb452328822da64c983fc2096180ef83c4a344efd (patch)
tree41fe136ad899ef08b797bce634cf242546442b79 /www
parentc6abd552ea4d65b8919bc231428e8c580a355531 (diff)
Fix up the latest gecko update by:
- reapplying the workaround for svn:eol-style and svn:keywords - fixing version matching in vuln.xml, 17.0.3 is NOT vulnerable
Notes
Notes: svn path=/head/; revision=312612
Diffstat (limited to 'www')
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/files/patch-bug80749218
2 files changed, 5 insertions, 14 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 7d7f0bee343d..e66c5672a827 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -37,6 +37,7 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GL= gl
+USE_DOS2UNIX= media/webrtc/trunk/src/system_wrappers/source/spreadsortlib/spreadsort.hpp
NO_MOZPKGINSTALL=yes
FIREFOX_ICON= ${MOZILLA}.png
diff --git a/www/firefox/files/patch-bug807492 b/www/firefox/files/patch-bug807492
index 4d51306d44ba..84472160d8b9 100644
--- a/www/firefox/files/patch-bug807492
+++ b/www/firefox/files/patch-bug807492
@@ -446,25 +446,15 @@ diff --git media/mtransport/third_party/nrappkit/src/port/generic/include/sys/qu
index bcb1ec0..bb73591 100644
--- media/mtransport/third_party/nrappkit/src/port/generic/include/sys/queue.h
+++ media/mtransport/third_party/nrappkit/src/port/generic/include/sys/queue.h
-@@ -28,17 +28,17 @@
- *
- * @(#)queue.h 8.5 (Berkeley) 8/20/94
- * $FreeBSD$
- */
-
- #ifndef _SYS_QUEUE_H_
- #define _SYS_QUEUE_H_
-
+@@ -33,5 +33,5 @@
+ #define _SYS_QUEUE_H_
+
-#ifndef DARWIN
+#if !defined(BSD) && !defined(DARWIN)
#include <stddef.h>
#define __offsetof offsetof
#endif
-
- #define STAILQ_FOREACH_SAFE(var, head, field, tvar) \
- for ((var) = STAILQ_FIRST((head)); \
- (var) && ((tvar) = STAILQ_NEXT((var), field), 1); \
- (var) = (tvar))
+
diff --git media/mtransport/third_party/nrappkit/src/util/util.c media/mtransport/third_party/nrappkit/src/util/util.c
index 3aced8b..be020bb 100644
--- media/mtransport/third_party/nrappkit/src/util/util.c