aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2013-09-25 10:03:33 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2013-09-25 10:03:33 +0000
commitb4db3cdf7606887c1063310ba0958b0b97134a8e (patch)
tree4f3960719b521320b05be72dad9df4d12cbd4e7c /www
parentaa3e2dd4be1ee49f7825a4e2136555f6bf5ac03f (diff)
downloadports-b4db3cdf7606887c1063310ba0958b0b97134a8e.tar.gz
ports-b4db3cdf7606887c1063310ba0958b0b97134a8e.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/links/Makefile41
-rw-r--r--www/links/distinfo4
2 files changed, 33 insertions, 12 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index c52aa6bd6f61..81226336074d 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= links
-DISTVERSION= 2.7
-PORTREVISION= 1
+DISTVERSION= 2.8
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= http://links.twibright.com/download/ LOCAL/bf
@@ -24,15 +23,16 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENSSL= yes
USE_BZIP2= yes
-OPTIONS_DEFINE= DIRECTFB SVGALIB TRANS UTF8 X11
+OPTIONS_DEFINE= CIPHERSTRING DIRECTFB IPV6 SVGALIB THREADS TRANS UTF8 X11
+CIPHERSTRING_DESC= Select the OpenSSL ciphers used via CIPHERSTRING
DIRECTFB_DESC= DirectFB graphics support
SVGALIB_DESC= SVGALib graphics support
TRANS_DESC= Hack for background transparency
UTF8_DESC= UTF-8 support
X11_DESC= X11 graphics support
-OPTIONS_DEFAULT= UTF8 X11
+OPTIONS_DEFAULT= IPV6 UTF8 X11
MAN1= links.1
PLIST_FILES= bin/links
@@ -40,33 +40,47 @@ PLIST_FILES= bin/links
NO_STAGE= yes
.include <bsd.port.options.mk>
+#CIPHERSTRING must be a valid OpenSSL cipher string(see ciphers(1)):
+CIPHERSTRING?= HIGH:!SSLv2:!aNULL:!eNULL:@STRENGTH
+
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
-LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
+LIB_DEPENDS+= liblzma.so:${PORTSDIR}/archivers/xz
.endif
.if ${PORT_OPTIONS:MDIRECTFB} || ${PORT_OPTIONS:MSVGALIB} || ${PORT_OPTIONS:MX11}
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --enable-graphics
.else
CONFIGURE_ARGS+= --disable-graphics --without-libjpeg --without-libtiff
.endif
.if ${PORT_OPTIONS:MDIRECTFB}
-LIB_DEPENDS+= directfb-1.4.5:${PORTSDIR}/devel/directfb
+LIB_DEPENDS+= libdirectfb.so:${PORTSDIR}/devel/directfb
CONFIGURE_ARGS+= --with-directfb
.else
CONFIGURE_ARGS+= --without-directfb
.endif
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+= --with-ipv6
+.else
+CONFIGURE_ARGS+= --without-ipv6
+.endif
+
.if ${PORT_OPTIONS:MSVGALIB}
-LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
+LIB_DEPENDS+= libvga.so:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+= --with-svgalib
.else
CONFIGURE_ARGS+= --without-svgalib
.endif
+.if ${PORT_OPTIONS:MTHREADS}
+CFLAGS+= -DHAVE_PTHREADS
+LDFLAGS+= -pthread
+.endif
+
.if ${PORT_OPTIONS:MTRANS}
EXTRA_PATCHES+= ${FILESDIR}/extra-terminal.c.diff
.endif
@@ -93,6 +107,13 @@ CONFIGURE_ARGS+= --without-x
post-patch:
@${REINPLACE_CMD} -e "s!/etc/!${PREFIX}/etc/!" ${WRKSRC}/os_dep.h
+ @${REINPLACE_CMD} -e "/LIBS=/{s/-lpthread/-pthread/;s/-ldl//;}" \
+ ${WRKSRC}/configure
+.if ${PORT_OPTIONS:MCIPHERSTRING}
+ @${REINPLACE_CMD} -e '/SSL_CTX_set_options/ \
+ s/;/; SSL_CTX_set_cipher_list(context, "${CIPHERSTRING}");/' \
+ ${WRKSRC}/https.c
+.endif
.if ${PORT_OPTIONS:MX11}
post-install:
diff --git a/www/links/distinfo b/www/links/distinfo
index 1cacac7b30b1..f2dc9416c788 100644
--- a/www/links/distinfo
+++ b/www/links/distinfo
@@ -1,2 +1,2 @@
-SHA256 (links-2.7.tar.bz2) = 0c182b1cbcdfd5cdcd2f75a6032d1a4b660d07c1225c1e07757cec81d3302130
-SIZE (links-2.7.tar.bz2) = 3884511
+SHA256 (links-2.8.tar.bz2) = 7950da386fa2014d75edc23abfaeed1b1f171ebc73bf0f557352948f12390096
+SIZE (links-2.8.tar.bz2) = 4102643