aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-06-24 16:29:25 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-06-24 16:29:25 +0000
commitbd48f3018817b3e74bc4dc371e6a072649b0abbf (patch)
treee6273a1c16a31c1f575721d9eb86248e44b517d3 /www
parent3a660746f7cc25b8eec1756e4c88d9b71da0da3c (diff)
downloadports-bd48f3018817b3e74bc4dc371e6a072649b0abbf.tar.gz
ports-bd48f3018817b3e74bc4dc371e6a072649b0abbf.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-Cookie-Splitter/Makefile9
-rw-r--r--www/p5-Catalyst-Controller-BindLex/Makefile13
-rw-r--r--www/p5-Catalyst-Controller-RateLimit/Makefile11
-rw-r--r--www/p5-Catalyst-Controller-RequestToken/Makefile9
-rw-r--r--www/p5-Catalyst-Model-Adaptor/Makefile11
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile9
-rw-r--r--www/p5-Catalyst-Plugin-Unicode/Makefile11
-rw-r--r--www/p5-Catalyst-View-Templated/Makefile11
-rw-r--r--www/p5-HTML-FromANSI/Makefile9
-rw-r--r--www/p5-Template-Plugin-JSON/Makefile9
10 files changed, 76 insertions, 26 deletions
diff --git a/www/p5-CGI-Cookie-Splitter/Makefile b/www/p5-CGI-Cookie-Splitter/Makefile
index 73221ce2b3d4..1830a1828994 100644
--- a/www/p5-CGI-Cookie-Splitter/Makefile
+++ b/www/p5-CGI-Cookie-Splitter/Makefile
@@ -16,9 +16,14 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-CGI-Simple>=0:${PORTSDIR}/www/p5-CGI-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Controller-BindLex/Makefile b/www/p5-Catalyst-Controller-BindLex/Makefile
index 99291c736194..0c94bc3f2039 100644
--- a/www/p5-Catalyst-Controller-BindLex/Makefile
+++ b/www/p5-Catalyst-Controller-BindLex/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Catalyst-Controller-BindLex
PORTVERSION= 0.03
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:NUFFIN
@@ -19,11 +19,16 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Array-RefElem>=0:${PORTSDIR}/misc/p5-Array-RefElem \
p5-Devel-Caller>=0:${PORTSDIR}/devel/p5-Devel-Caller \
p5-Devel-LexAlias>=0:${PORTSDIR}/devel/p5-Devel-LexAlias \
- p5-PadWalker>=0:${PORTSDIR}/devel/p5-PadWalker \
- p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
+ p5-PadWalker>=0:${PORTSDIR}/devel/p5-PadWalker
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Controller-RateLimit/Makefile b/www/p5-Catalyst-Controller-RateLimit/Makefile
index a02009b4aa43..2d1a29c87c7a 100644
--- a/www/p5-Catalyst-Controller-RateLimit/Makefile
+++ b/www/p5-Catalyst-Controller-RateLimit/Makefile
@@ -18,10 +18,15 @@ BUILD_DEPENDS= p5-Algorithm-FloodControl>=1.91:${PORTSDIR}/devel/p5-Algorithm-Fl
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst \
- p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
- p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Controller-RequestToken/Makefile b/www/p5-Catalyst-Controller-RequestToken/Makefile
index 5e88230b7701..54478467bab9 100644
--- a/www/p5-Catalyst-Controller-RequestToken/Makefile
+++ b/www/p5-Catalyst-Controller-RequestToken/Makefile
@@ -17,9 +17,14 @@ BUILD_DEPENDS= p5-Catalyst-Action-RenderView>=0:${PORTSDIR}/www/p5-Catalyst-Acti
p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Model-Adaptor/Makefile b/www/p5-Catalyst-Model-Adaptor/Makefile
index 2b7e0fde2be5..fd3cd4b66cbd 100644
--- a/www/p5-Catalyst-Model-Adaptor/Makefile
+++ b/www/p5-Catalyst-Model-Adaptor/Makefile
@@ -14,10 +14,15 @@ COMMENT= Use a plain class as a Catalyst model
RUN_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat
BUILD_DEPENDS:= ${RUN_DEPENDS}
-TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
- p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst
+TEST_DEPENDS= p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile b/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile
index 78a46849f9cc..ea29d225087e 100644
--- a/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile
+++ b/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile
@@ -17,9 +17,14 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Catalyst-Plugin-Session>=0.27:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
p5-MRO-Compat>0:${PORTSDIR}/devel/p5-MRO-Compat
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Unicode/Makefile b/www/p5-Catalyst-Plugin-Unicode/Makefile
index 64fc5033f01e..eb8bb42d41ab 100644
--- a/www/p5-Catalyst-Plugin-Unicode/Makefile
+++ b/www/p5-Catalyst-Plugin-Unicode/Makefile
@@ -15,8 +15,7 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-MRO-Compat>=0.10:${PORTSDIR}/devel/p5-MRO-Compat
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
- p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst \
- p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
+ p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst
USES= perl5
USE_PERL5= configure
@@ -24,4 +23,10 @@ USE_PERL5= configure
post-extract:
@${REINPLACE_CMD} -e '/build_requires/d' ${WRKSRC}/Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-View-Templated/Makefile b/www/p5-Catalyst-View-Templated/Makefile
index 038dcbb6c923..9fe0c57b5747 100644
--- a/www/p5-Catalyst-View-Templated/Makefile
+++ b/www/p5-Catalyst-View-Templated/Makefile
@@ -17,10 +17,15 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Class-C3>=0:${PORTSDIR}/devel/p5-Class-C3
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
- p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst \
- p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
+ p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-FromANSI/Makefile b/www/p5-HTML-FromANSI/Makefile
index fe8559ecbd08..3e75677763ed 100644
--- a/www/p5-HTML-FromANSI/Makefile
+++ b/www/p5-HTML-FromANSI/Makefile
@@ -14,9 +14,14 @@ COMMENT= Mark up ANSI sequences as HTML
BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-Term-VT102-Boundless>=0:${PORTSDIR}/devel/p5-Term-VT102-Boundless
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Template-Plugin-JSON/Makefile b/www/p5-Template-Plugin-JSON/Makefile
index ba12a49bbcef..b080bd6622b5 100644
--- a/www/p5-Template-Plugin-JSON/Makefile
+++ b/www/p5-Template-Plugin-JSON/Makefile
@@ -14,9 +14,14 @@ BUILD_DEPENDS= p5-JSON>=2.12:${PORTSDIR}/converters/p5-JSON \
p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
p5-Template-Toolkit>=2.20:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>