aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-08-20 09:32:55 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-08-20 09:32:55 +0000
commitc6c3f09be39b658ef235edb33e23496c1f2ec00b (patch)
tree3bc10ba0207212cb54273b0744a9ddf0d7bcb26e /www
parent02550833165ff532f24d4d134b6728f5555763a5 (diff)
downloadports-c6c3f09be39b658ef235edb33e23496c1f2ec00b.tar.gz
ports-c6c3f09be39b658ef235edb33e23496c1f2ec00b.zip
MFH: r545512
www/pecl-solr: Fix build for php 7.4 PR: 247364 Submitted by: hagabard@gmail.com Approved by: Hung-Yi Chen <gaod@hychen.org> (maintainer) Approved by: portmgr (blanket: build fix)
Notes
Notes: svn path=/branches/2020Q3/; revision=545513
Diffstat (limited to 'www')
-rw-r--r--www/pecl-solr/Makefile5
-rw-r--r--www/pecl-solr/files/patch-src_php7_solr__types.h11
2 files changed, 15 insertions, 1 deletions
diff --git a/www/pecl-solr/Makefile b/www/pecl-solr/Makefile
index 806e967c6ef9..71a5f8963c3a 100644
--- a/www/pecl-solr/Makefile
+++ b/www/pecl-solr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= solr
PORTVERSION= 2.5.0
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= gaod@hychen.org
@@ -16,6 +17,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= php:pecl
USE_PHP= json:build
-IGNORE_WITH_PHP= 74
+
+CONFIGURE_ARGS= LIBXML_CFLAGS=-I${LOCALBASE}/include/libxml2 \
+ LIBXML_LIBS=-L${LOCALBASE}/include/libxml2
.include <bsd.port.mk>
diff --git a/www/pecl-solr/files/patch-src_php7_solr__types.h b/www/pecl-solr/files/patch-src_php7_solr__types.h
new file mode 100644
index 000000000000..52ad8ad29762
--- /dev/null
+++ b/www/pecl-solr/files/patch-src_php7_solr__types.h
@@ -0,0 +1,11 @@
+--- src/php7/solr_types.h.orig 2016-03-30 13:42:31 UTC
++++ src/php7/solr_types.h
+@@ -53,6 +53,7 @@
+ #include <libxml/tree.h>
+
+ typedef unsigned char solr_bool;
++typedef unsigned long ulong; /* Short for unsigned long */
+
+ #include "solr_string.h"
+
+