aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-10-11 07:14:16 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-10-11 07:14:16 +0000
commitd7f970d7636930b037e1c32ed4b777195313a629 (patch)
tree2969641380a2cd4c948b9f04a7d2e435132f4dbf /www
parente66e7ba5f725d2ceda55e6e33be524204da69e59 (diff)
downloadports-d7f970d7636930b037e1c32ed4b777195313a629.tar.gz
ports-d7f970d7636930b037e1c32ed4b777195313a629.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/squid/Makefile1
-rw-r--r--www/squid/files/patch-src_comm_TcpAcceptor.cc38
2 files changed, 39 insertions, 0 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index a5cef77e51e9..94291c4b1958 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -2,6 +2,7 @@
PORTNAME= squid
PORTVERSION= 4.3
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v4/ \
http://www2.us.squid-cache.org/Versions/v4/ \
diff --git a/www/squid/files/patch-src_comm_TcpAcceptor.cc b/www/squid/files/patch-src_comm_TcpAcceptor.cc
new file mode 100644
index 000000000000..18b8b7e17c88
--- /dev/null
+++ b/www/squid/files/patch-src_comm_TcpAcceptor.cc
@@ -0,0 +1,38 @@
+Bug 4889: No connections are accepted after ECONNABORTED
+
+Ignore ECONNABORTED errors when accepting connections. These "client
+decided not to wait for accept(2)" errors do not indicate a problem with
+the listening socket and should not lead to listening socket closure.
+
+Also polished errno checking code for non-ignored errors.
+
+Also documented a bug that prevents TcpAcceptor::acceptOne() from
+stopping to listen on non-ignored accept errors.
+
+Also documented ENFILE and EMFILE mishandling.
+
+--- src/comm/TcpAcceptor.cc.orig 2018-09-30 20:57:54.000000000 +0200
++++ src/comm/TcpAcceptor.cc 2018-10-10 18:10:05.897616000 +0200
+@@ -297,6 +297,7 @@
+ if (intendedForUserConnections())
+ logAcceptError(newConnDetails);
+ notify(flag, newConnDetails);
++ // XXX: Will not stop because doAccept() is not called asynchronously.
+ mustStop("Listener socket closed");
+ return;
+ }
+@@ -366,11 +367,12 @@
+
+ PROF_stop(comm_accept);
+
+- if (ignoreErrno(errcode)) {
++ if (ignoreErrno(errcode) || errcode == ECONNABORTED) {
+ debugs(50, 5, status() << ": " << xstrerr(errcode));
+ return Comm::NOMESSAGE;
+- } else if (ENFILE == errno || EMFILE == errno) {
++ } else if (errcode == ENFILE || errcode == EMFILE) {
+ debugs(50, 3, status() << ": " << xstrerr(errcode));
++ // XXX: These errors do not imply that we should stop listening.
+ return Comm::COMM_ERROR;
+ } else {
+ debugs(50, DBG_IMPORTANT, MYNAME << status() << ": " << xstrerr(errcode));