aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-28 14:00:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-28 14:00:45 +0000
commitdca255c3cec21c0c66003eb626763c7fdc2cb59a (patch)
treee6eac391e081f99a997be8b0d8e036d22d5fe2a9 /www
parent4973e5b396de5fdc84495adcdcb1f40854c8ebcd (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/ach/Makefile2
-rw-r--r--www/caldavzap/Makefile3
-rw-r--r--www/crp/Makefile3
-rw-r--r--www/dddbl/Makefile4
-rw-r--r--www/encode-explorer/Makefile4
-rw-r--r--www/flat-frog/Makefile3
-rw-r--r--www/fluxbb/Makefile3
-rw-r--r--www/geeklog/Makefile3
-rw-r--r--www/iwebcal/Makefile3
-rw-r--r--www/mod_myvhost/Makefile3
-rw-r--r--www/mod_vhs/Makefile5
-rw-r--r--www/pecl-APC/Makefile4
-rw-r--r--www/pecl-amfext/Makefile4
-rw-r--r--www/pecl-http/Makefile4
-rw-r--r--www/pecl-http1/Makefile5
-rw-r--r--www/pecl-http2/Makefile4
-rw-r--r--www/pecl-solr/Makefile6
-rw-r--r--www/pecl-sphinx/Makefile4
-rw-r--r--www/pecl-swish/Makefile4
-rw-r--r--www/pecl-twig/Makefile5
-rw-r--r--www/pecl-varnish/Makefile6
-rw-r--r--www/pecl-yaf/Makefile6
-rw-r--r--www/pecl-yar/Makefile8
-rw-r--r--www/phalcon/Makefile6
-rw-r--r--www/php-screw/Makefile3
-rw-r--r--www/php-templates/Makefile4
-rw-r--r--www/php55-opcache/Makefile2
-rw-r--r--www/php56-opcache/Makefile2
-rw-r--r--www/php70-opcache/Makefile2
-rw-r--r--www/phpbb3/Makefile3
-rw-r--r--www/phpgroupware/Makefile4
-rw-r--r--www/phpmustache/Makefile3
-rw-r--r--www/phpwebapp/Makefile4
-rw-r--r--www/pnews/Makefile3
-rw-r--r--www/pserv/Makefile15
-rw-r--r--www/punbb/Makefile3
-rw-r--r--www/skytemplate/Makefile3
-rw-r--r--www/suphp/Makefile4
-rw-r--r--www/template_/Makefile3
-rw-r--r--www/webgrind/Makefile2
-rw-r--r--www/xcache/Makefile4
-rw-r--r--www/zen-cart/Makefile4
42 files changed, 50 insertions, 120 deletions
diff --git a/www/ach/Makefile b/www/ach/Makefile
index 5823f1744647..e56941deacc4 100644
--- a/www/ach/Makefile
+++ b/www/ach/Makefile
@@ -13,7 +13,7 @@ COMMENT= Free, open source tool for complex research problems
LICENSE= GPLv3
USE_MYSQL= yes
-USE_PHP= yes
+USES= php
USE_GITHUB= yes
GH_ACCOUNT= Burton
GH_PROJECT= Analysis-of-Competing-Hypotheses
diff --git a/www/caldavzap/Makefile b/www/caldavzap/Makefile
index 84ca4d5121a6..87bdf5f8f184 100644
--- a/www/caldavzap/Makefile
+++ b/www/caldavzap/Makefile
@@ -14,8 +14,7 @@ COMMENT= CalDAV web client implementation
LICENSE= AGPLv3
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_PHP= yes
-USES= zip
+USES= php zip
NO_BUILD= yes
do-install:
diff --git a/www/crp/Makefile b/www/crp/Makefile
index 09b67b3daee0..dc33dc5ef5f9 100644
--- a/www/crp/Makefile
+++ b/www/crp/Makefile
@@ -12,8 +12,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= lars.eggert@gmx.net
COMMENT= Automates the process of being the program chair of a conference
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USES= php:web
NO_BUILD= yes
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
diff --git a/www/dddbl/Makefile b/www/dddbl/Makefile
index 1d19ab9a4988..6b67c640159d 100644
--- a/www/dddbl/Makefile
+++ b/www/dddbl/Makefile
@@ -9,13 +9,11 @@ MASTER_SITES= http://www.dddbl.de/dddbl-versions/
MAINTAINER= tz@FreeBSD.org
COMMENT= Definition Driven Database Layer for PHP
-USES= tar:bzip2
+USES= php tar:bzip2
NO_BUILD= yes
NO_ARCH= yes
-USE_PHP= yes
-
WRKSRC= ${WRKDIR}/dddbl2
do-install:
diff --git a/www/encode-explorer/Makefile b/www/encode-explorer/Makefile
index 8a0969ef1e00..9bf24a5690c1 100644
--- a/www/encode-explorer/Makefile
+++ b/www/encode-explorer/Makefile
@@ -11,9 +11,7 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}_${PORTVERSION}
MAINTAINER= fw@moov.de
COMMENT= PHP script to browse, create folders, upload files etc
-USE_PHP= yes
-WANT_PHP_WEB= yes
-USES= zip
+USES= php:web zip
NO_BUILD= yes
OPTIONS_DEFINE= DOCS
diff --git a/www/flat-frog/Makefile b/www/flat-frog/Makefile
index 408b07c927c8..d658dc812fa2 100644
--- a/www/flat-frog/Makefile
+++ b/www/flat-frog/Makefile
@@ -13,8 +13,7 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
NO_BUILD= yes
-USE_PHP= yes
-USES= zip
+USES= php zip
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/www/fluxbb/Makefile b/www/fluxbb/Makefile
index 80bb6fd8b6ce..c638712d5be2 100644
--- a/www/fluxbb/Makefile
+++ b/www/fluxbb/Makefile
@@ -14,10 +14,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc64= Does not build
-USES= cpe
+USES= cpe php
SUB_FILES= pkg-message
NO_BUILD= yes
-USE_PHP= yes
OPTIONS_DEFINE= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT= MYSQL
diff --git a/www/geeklog/Makefile b/www/geeklog/Makefile
index b832c45fea8c..296c62379614 100644
--- a/www/geeklog/Makefile
+++ b/www/geeklog/Makefile
@@ -12,7 +12,7 @@ COMMENT= Web content management system
LICENSE= GPLv2+
-USES= cpe
+USES= cpe php
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message
@@ -20,7 +20,6 @@ SUB_FILES= pkg-message
USE_MYSQL= yes
NO_BUILD= yes
-USE_PHP= yes
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
diff --git a/www/iwebcal/Makefile b/www/iwebcal/Makefile
index aa0523c540bd..17cdce389f71 100644
--- a/www/iwebcal/Makefile
+++ b/www/iwebcal/Makefile
@@ -10,10 +10,9 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Webbased iCal calendar viewer
-USES= tar:tgz
+USES= php tar:tgz
NO_BUILD= yes
NO_ARCH= yes
-USE_PHP= yes
WRKSRC= ${WRKDIR}/iWebCal
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
diff --git a/www/mod_myvhost/Makefile b/www/mod_myvhost/Makefile
index f2418cd9cf00..ebfc94501520 100644
--- a/www/mod_myvhost/Makefile
+++ b/www/mod_myvhost/Makefile
@@ -35,8 +35,7 @@ STRIP= # keep debug information
.if ${PORT_OPTIONS:MPHP_MODULE}
MAKE_ENV+= WITH_PHP=true
-USE_PHP= yes
-WANT_PHP_MOD= yes
+USES+= php:mod
.endif
pre-patch:
diff --git a/www/mod_vhs/Makefile b/www/mod_vhs/Makefile
index eba6b5d99d0a..0194315ffe0d 100644
--- a/www/mod_vhs/Makefile
+++ b/www/mod_vhs/Makefile
@@ -14,12 +14,9 @@ LICENSE= APACHE11
MANUAL_PACKAGE_BUILD= needs apr with LDAP and DBD options enabled
-USES= cpe
+USES= php:mod,build cpe
CPE_VENDOR= xavier_beaudouin
USE_APACHE= 22+
-USE_PHP= yes
-USE_PHP_BUILD= yes
-WANT_PHP_MOD= yes
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SRC_FILE= *.c
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index 609acc9d89c8..b9160a41fa73 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -31,9 +31,7 @@ IGNORE_WITH_PHP=55 56 70
PHP_MODNAME= ${PORTNAME:tl}
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
-USE_PHP= yes
-USE_PHPEXT= yes
-USES= tar:tgz
+USES= php:ext tar:tgz
PORTDOCS= CHANGELOG INSTALL NOTICE apc.php
diff --git a/www/pecl-amfext/Makefile b/www/pecl-amfext/Makefile
index d314255fba5e..2a3ea163b9d4 100644
--- a/www/pecl-amfext/Makefile
+++ b/www/pecl-amfext/Makefile
@@ -14,9 +14,7 @@ COMMENT= Implements encoding and decoding of AMF and AMF3 messages
LICENSE= PHP30
-USES= dos2unix libtool tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= dos2unix libtool php:ext tar:tgz
PHP_MODNAME= amf
IGNORE_WITH_PHP= 70
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index ce5a29c0f1c6..b0d1573f1fa2 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -26,9 +26,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
PHP_DEFAULT= 7.0
IGNORE_WITH_PHP= 55 56
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
CONFLICTS= pecl-http[12]*
.include <bsd.port.mk>
diff --git a/www/pecl-http1/Makefile b/www/pecl-http1/Makefile
index 02c243da4719..8219055e9402 100644
--- a/www/pecl-http1/Makefile
+++ b/www/pecl-http1/Makefile
@@ -17,10 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
-PHP_MODNAME= http
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 56 70
CONFLICTS= pecl-http-*
diff --git a/www/pecl-http2/Makefile b/www/pecl-http2/Makefile
index ea0a4362a15d..f19c0dbb8a2f 100644
--- a/www/pecl-http2/Makefile
+++ b/www/pecl-http2/Makefile
@@ -24,9 +24,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libevent.so:devel/libevent2
IGNORE_WITH_PHP=70
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
CONFLICTS= pecl-http1* pecl-http-*
.include <bsd.port.mk>
diff --git a/www/pecl-solr/Makefile b/www/pecl-solr/Makefile
index 1bbc2010fe89..3b7a03a0c4df 100644
--- a/www/pecl-solr/Makefile
+++ b/www/pecl-solr/Makefile
@@ -16,10 +16,8 @@ BROKEN_powerpc64= Does not build
LIB_DEPENDS= libcurl.so:ftp/curl \
libxml2.so:textproc/libxml2
-USE_PHP= json
-USE_PHPEXT= yes
-USE_PHPIZE= yes
-USE_PHP_BUILD= yes
+USES= php:ext
+USE_PHP= json:build
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/www/pecl-sphinx/Makefile b/www/pecl-sphinx/Makefile
index 29244f9278e1..03a3b22b9840 100644
--- a/www/pecl-sphinx/Makefile
+++ b/www/pecl-sphinx/Makefile
@@ -15,9 +15,7 @@ LICENSE= PHP301
LIB_DEPENDS= libsphinxclient.so:textproc/libsphinxclient
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
SUB_FILES= pkg-message
diff --git a/www/pecl-swish/Makefile b/www/pecl-swish/Makefile
index 5741cb89b612..708218bc25dc 100644
--- a/www/pecl-swish/Makefile
+++ b/www/pecl-swish/Makefile
@@ -16,9 +16,7 @@ LICENSE= PHP301
BUILD_DEPENDS= swish-config:www/swish-e
RUN_DEPENDS:= swish-config:www/swish-e
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-swish --with-swish=${LOCALBASE}/bin
diff --git a/www/pecl-twig/Makefile b/www/pecl-twig/Makefile
index 97d4f6c26b48..5372eab2680e 100644
--- a/www/pecl-twig/Makefile
+++ b/www/pecl-twig/Makefile
@@ -13,10 +13,7 @@ COMMENT= Twig C extension to improve performance of the Twig template language
LICENSE= BSD3CLAUSE
-USE_PHP= yes
-USE_PHPIZE= yes
-USE_PHPEXT= yes
-USES= tar:tgz
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/www/pecl-varnish/Makefile b/www/pecl-varnish/Makefile
index 3fb37736eced..3225ac2de295 100644
--- a/www/pecl-varnish/Makefile
+++ b/www/pecl-varnish/Makefile
@@ -20,10 +20,8 @@ EXPIRATION_DATE= 2016-07-04
BUILD_DEPENDS= varnish4>=0:www/varnish4
-USES= tar:tgz
-USE_PHP= hash
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
+USE_PHP= hash:build
IGNORE_WITH_PHP= 52
diff --git a/www/pecl-yaf/Makefile b/www/pecl-yaf/Makefile
index 657b9fc14c32..446e6a070b44 100644
--- a/www/pecl-yaf/Makefile
+++ b/www/pecl-yaf/Makefile
@@ -18,11 +18,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --with-php-config=${PREFIX}/bin/php-config
-USES= tar:tgz
-PHP_MODNAME= ${PORTNAME:tl}
-USE_PHP= yes
-USE_PHPEXT= yes
-USE_PHPIZE= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/www/pecl-yar/Makefile b/www/pecl-yar/Makefile
index b72b5411c5b2..111054ac1af7 100644
--- a/www/pecl-yar/Makefile
+++ b/www/pecl-yar/Makefile
@@ -15,12 +15,8 @@ LICENSE= PHP301
BROKEN_powerpc64= Does not build
-USES= tar:tgz
-PHP_MODNAME= yar
-USE_PHP= json curl
-USE_PHPEXT= yes
-USE_PHPIZE= yes
-USE_PHP_BUILD= yes
+USES= php:ext tar:tgz
+USE_PHP= json:build curl:build
IGNORE_WITH_PHP= 70
CFLAGS+= -I${LOCALBASE}/include
diff --git a/www/phalcon/Makefile b/www/phalcon/Makefile
index 5d77ac097d8f..709432e7c255 100644
--- a/www/phalcon/Makefile
+++ b/www/phalcon/Makefile
@@ -11,10 +11,8 @@ COMMENT= Phalcon PHP Framework written in C-language
LICENSE= BSD3CLAUSE
-USE_PHP= hash pdo
-USE_PHPEXT= yes
-USE_PHPIZE= yes
-USE_PHP_BUILD= yes
+USES= php:ext
+USE_PHP= hash:build pdo:build
IGNORE_WITH_PHP= 70
ONLY_FOR_ARCHS= amd64 i386
diff --git a/www/php-screw/Makefile b/www/php-screw/Makefile
index 2b83190886a5..1fa740c15dfa 100644
--- a/www/php-screw/Makefile
+++ b/www/php-screw/Makefile
@@ -13,9 +13,8 @@ COMMENT= PHP script encryption tool
CRYPTKEY?= 11152, 368, 192, 1281, 62
-USES= libtool
+USES= php:phpize libtool
USE_PHP= zlib
-USE_PHPIZE= yes
PLIST_SUB= PHP_EXTDIR="${PHP_EXT_DIR}"
SUB_FILES= pkg-message
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
index 7fb1794571c9..15b43ae345a2 100644
--- a/www/php-templates/Makefile
+++ b/www/php-templates/Makefile
@@ -15,10 +15,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Template framework for PHP
WRKSRC= ${WRKDIR}/templates
-USES= dos2unix
+USES= dos2unix php:phpize
-USE_PHP= yes
-USE_PHPIZE= yes
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-templates=shared
diff --git a/www/php55-opcache/Makefile b/www/php55-opcache/Makefile
index 409d5cc275a7..1dc5c1f620be 100644
--- a/www/php55-opcache/Makefile
+++ b/www/php55-opcache/Makefile
@@ -7,6 +7,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php55
PKGNAMESUFFIX= -opcache
-USE_ZENDEXT= yes
+USES= php:zend
.include "${MASTERDIR}/Makefile"
diff --git a/www/php56-opcache/Makefile b/www/php56-opcache/Makefile
index 563247fbd78c..2c4265adab60 100644
--- a/www/php56-opcache/Makefile
+++ b/www/php56-opcache/Makefile
@@ -7,6 +7,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php56
PKGNAMESUFFIX= -opcache
-USE_ZENDEXT= yes
+USES= php:zend
.include "${MASTERDIR}/Makefile"
diff --git a/www/php70-opcache/Makefile b/www/php70-opcache/Makefile
index 4a743d8e2206..db9930ba6e63 100644
--- a/www/php70-opcache/Makefile
+++ b/www/php70-opcache/Makefile
@@ -7,6 +7,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php70
PKGNAMESUFFIX= -opcache
-USE_ZENDEXT= yes
+USES= php:zend
.include "${MASTERDIR}/Makefile"
diff --git a/www/phpbb3/Makefile b/www/phpbb3/Makefile
index a02d145a4a0e..1aa69cb60716 100644
--- a/www/phpbb3/Makefile
+++ b/www/phpbb3/Makefile
@@ -16,8 +16,7 @@ LICENSE= GPLv2
CONFLICTS= phpbb-tw-[0-9]* phpbb-devel-[0-9]* \
phpbb-[0-2]*
-USES= tar:bzip2
-USE_PHP= yes
+USES= php tar:bzip2
OPTIONS_DEFINE= DOCS
diff --git a/www/phpgroupware/Makefile b/www/phpgroupware/Makefile
index a33f0e9bc5aa..f311ff6d61ca 100644
--- a/www/phpgroupware/Makefile
+++ b/www/phpgroupware/Makefile
@@ -8,9 +8,7 @@ MASTER_SITES= SF/phpgroupware/phpgroupware/${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Web based GroupWare system
-USES= tar:bzip2
-USE_PHP= yes
-WANT_PHP_MOD= yes
+USES= php:mod tar:bzip2
IGNORE_WITH_PHP= 70
NO_BUILD= yes
diff --git a/www/phpmustache/Makefile b/www/phpmustache/Makefile
index c928f040f65f..dac185cf9ab3 100644
--- a/www/phpmustache/Makefile
+++ b/www/phpmustache/Makefile
@@ -16,8 +16,7 @@ USE_GITHUB= yes
GH_ACCOUNT= bobthecow
GH_PROJECT= mustache.php
-USE_PHP= yes
-USE_PHP_BUILD= yes
+USES= php:build
NO_ARCH= yes
SUB_FILES= pkg-message
diff --git a/www/phpwebapp/Makefile b/www/phpwebapp/Makefile
index 887f4b8b9c8d..3f1d8eb0b956 100644
--- a/www/phpwebapp/Makefile
+++ b/www/phpwebapp/Makefile
@@ -11,9 +11,7 @@ COMMENT= Web application framework
NO_ARCH= yes
NO_BUILD= yes
-USE_PHP= yes
-USES= shebangfix
-WANT_PHP_WEB= yes
+USES= php:web shebangfix
SHEBANG_FILES= web_app/boxes/menu/edit/xsl/test/*.sh \
web_app/boxes/webnotes/db/dump.sh \
diff --git a/www/pnews/Makefile b/www/pnews/Makefile
index ad0950ffc403..95c99031bfa8 100644
--- a/www/pnews/Makefile
+++ b/www/pnews/Makefile
@@ -13,8 +13,7 @@ COMMENT= PHP Web-based News Reader
LICENSE= GPLv2+
-USES= tar:tgz
-USE_PHP= yes
+USES= php tar:tgz
NO_BUILD= yes
PNEWSDIR?= www/pnews
diff --git a/www/pserv/Makefile b/www/pserv/Makefile
index 1631c710ad80..9deae74f176b 100644
--- a/www/pserv/Makefile
+++ b/www/pserv/Makefile
@@ -21,24 +21,19 @@ OPTIONS_DEFINE= LOG PHP
OPTIONS_DEFAULT= LOG PHP
LOG_DESC= Enable loggin
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPHP}
-USE_PHP= yes
-WANT_PHP_CGI= yes
-.endif
+PHP_USES= php:cgi
post-patch:
@${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|g;s|%%LOCALBASE%%|${LOCALBASE}|g" \
${WRKSRC}/defaults/pserv.conf ${WRKSRC}/sources/main.h
-.if ! ${PORT_OPTIONS:MLOG}
+
+post-patch-LOG-off:
@${REINPLACE_CMD} "s|define LOG|undef LOG|" \
${WRKSRC}/sources/main.h
-.endif
-.if ! ${PORT_OPTIONS:MPHP}
+
+post-patch-PHP-off:
@${REINPLACE_CMD} "s|define PHP|undef PHP|" \
${WRKSRC}/sources/main.h
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sources/pserv ${STAGEDIR}${PREFIX}/sbin/
diff --git a/www/punbb/Makefile b/www/punbb/Makefile
index 1bd6dcb31b7a..7fa4cec638fe 100644
--- a/www/punbb/Makefile
+++ b/www/punbb/Makefile
@@ -23,8 +23,7 @@ BUILD_DEPENDS+= ${UNZIP_CMD}:archivers/unzip
SUB_FILES= pkg-message
NO_BUILD= yes
-USE_PHP= yes
-USES= tar:bzip2
+USES= php tar:bzip2
OPTIONS_DEFINE= LANGUAGE_PACK EXTRAS
OPTIONS_DEFAULT= LANGUAGE_PACK EXTRAS
diff --git a/www/skytemplate/Makefile b/www/skytemplate/Makefile
index d97a410d539e..41b69e4294aa 100644
--- a/www/skytemplate/Makefile
+++ b/www/skytemplate/Makefile
@@ -11,8 +11,7 @@ DISTNAME= SkyTemplate.v${PORTVERSION:S/.//g}
MAINTAINER= munggo@gmail.com
COMMENT= Yet another PHP compiling template engine
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USES= php:web
NO_BUILD= yes
SUB_FILES= pkg-message
diff --git a/www/suphp/Makefile b/www/suphp/Makefile
index a8bb1eec930b..32b493768ff2 100644
--- a/www/suphp/Makefile
+++ b/www/suphp/Makefile
@@ -13,14 +13,12 @@ MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Securely execute PHP scripts under Apache
GNU_CONFIGURE= yes
-USES= autoreconf libtool
+USES= autoreconf libtool php:cgi
SUB_FILES= pkg-message
USE_APACHE= 22+
CFLAGS+= -I${LOCALBASE}/include
USE_CSTD= gnu89
-USE_PHP= yes
-WANT_PHP_CGI= yes
MYPORTDOCS= apache/CONFIG \
apache/INSTALL \
diff --git a/www/template_/Makefile b/www/template_/Makefile
index 34d27c93d17a..6ec7366d5674 100644
--- a/www/template_/Makefile
+++ b/www/template_/Makefile
@@ -15,8 +15,7 @@ LICENSE= LGPL20+
WRKSRC= ${WRKDIR}
FETCH_ARGS+= -o ${DISTNAME}.tar.gz
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USES= php:web
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/www/webgrind/Makefile b/www/webgrind/Makefile
index 3df5d74e767d..46c4bf0caf92 100644
--- a/www/webgrind/Makefile
+++ b/www/webgrind/Makefile
@@ -18,7 +18,7 @@ GH_TAGNAME= dc35393
SNAPSHOT= 20140207
-USE_PHP= yes
+USES= php
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/xcache/Makefile b/www/xcache/Makefile
index 89a9cfca6966..93bf7ca09391 100644
--- a/www/xcache/Makefile
+++ b/www/xcache/Makefile
@@ -11,9 +11,7 @@ COMMENT= Fast and stable php opcode cacher
LICENSE= BSD3CLAUSE
-USES= tar:bzip2
-USE_PHP= yes
-USE_PHPIZE= yes
+USES= php:phpize tar:bzip2
CONFIGURE_ARGS= --enable-xcache=shared
diff --git a/www/zen-cart/Makefile b/www/zen-cart/Makefile
index 6a5f8b961d0e..2264221bd1a5 100644
--- a/www/zen-cart/Makefile
+++ b/www/zen-cart/Makefile
@@ -15,12 +15,10 @@ COMMENT= PHP-based user-friendly, open source shopping cart
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/license.txt
-USES= dos2unix shebangfix zip
+USES= dos2unix php:web shebangfix zip
SHEBANG_FILES= editors/htmlarea/examples/2-areas.cgi \
editors/htmlarea/examples/test.cgi \
editors/htmlarea/plugins/SpellChecker/spell-check-logic.cgi
-USE_PHP= yes
-WANT_PHP_WEB= yes
DOS2UNIX_REGEX= .*\.php
NO_BUILD= yes