aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAllan Jude <allanjude@FreeBSD.org>2016-05-16 00:29:36 +0000
committerAllan Jude <allanjude@FreeBSD.org>2016-05-16 00:29:36 +0000
commit1170fea2ec2756e0f5681c8d92759d5226fb14a1 (patch)
treeb200ebe5e19bc01e6c211f97c867bc2bcfd540ec /www
parent6b1bafaf8b040f28bd839702cec164595f3219f2 (diff)
downloadports-1170fea2ec2756e0f5681c8d92759d5226fb14a1.tar.gz
ports-1170fea2ec2756e0f5681c8d92759d5226fb14a1.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/varnish-libvmod-maxminddb/Makefile33
-rw-r--r--www/varnish-libvmod-maxminddb/distinfo3
-rw-r--r--www/varnish-libvmod-maxminddb/files/patch-Makefile.am16
-rw-r--r--www/varnish-libvmod-maxminddb/pkg-descr3
-rw-r--r--www/varnish-libvmod-maxminddb/pkg-plist4
6 files changed, 60 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 161d93d79e4a..f2999ea9958f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2254,6 +2254,7 @@
SUBDIR += uzbl
SUBDIR += validator
SUBDIR += varnish-libvmod-header
+ SUBDIR += varnish-libvmod-maxminddb
SUBDIR += varnish-libvmod-saintmode
SUBDIR += varnish-nagios
SUBDIR += varnish4
diff --git a/www/varnish-libvmod-maxminddb/Makefile b/www/varnish-libvmod-maxminddb/Makefile
new file mode 100644
index 000000000000..da32b903f95e
--- /dev/null
+++ b/www/varnish-libvmod-maxminddb/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= libvmod-maxminddb
+DISTVERSION= 1.0.0
+CATEGORIES= www
+PKGNAMEPREFIX= varnish-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Varnish Module (vmod) for accessing maxminddb geoip data
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= varnish4>=4.1.0:www/varnish4 \
+ rst2man:textproc/py-docutils
+
+LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
+
+RUN_DEPENDS= varnish4>=4.1.0:www/varnish4
+
+USES= autoreconf gmake libtool pkgconfig python:2,build
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/varnish
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/varnish
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+USE_GITHUB= yes
+GH_ACCOUNT= simonvik
+GH_PROJECT= libvmod_maxminddb
+GH_TAGNAME= 4ae6a7f
+
+.include <bsd.port.mk>
diff --git a/www/varnish-libvmod-maxminddb/distinfo b/www/varnish-libvmod-maxminddb/distinfo
new file mode 100644
index 000000000000..b7ce94d27e30
--- /dev/null
+++ b/www/varnish-libvmod-maxminddb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463350841
+SHA256 (simonvik-libvmod_maxminddb-1.0.0-4ae6a7f_GH0.tar.gz) = d6aab1a15ebcc6136a975250d223223413603b53dbf1c02652dfa5edd83f3d8a
+SIZE (simonvik-libvmod_maxminddb-1.0.0-4ae6a7f_GH0.tar.gz) = 3927
diff --git a/www/varnish-libvmod-maxminddb/files/patch-Makefile.am b/www/varnish-libvmod-maxminddb/files/patch-Makefile.am
new file mode 100644
index 000000000000..95add989ec49
--- /dev/null
+++ b/www/varnish-libvmod-maxminddb/files/patch-Makefile.am
@@ -0,0 +1,16 @@
+--- Makefile.am.orig 2016-05-15 22:29:56 UTC
++++ Makefile.am
+@@ -2,11 +2,11 @@ ACLOCAL_AMFLAGS = -I m4
+
+ SUBDIRS = src
+
+-dist_man_MANS = vmod_geoip.3
++dist_man_MANS = vmod_maxminddb.3
+ MAINTAINERCLEANFILES = $(dist_man_MANS)
+ doc_DATA = README.rst LICENSE
+
+-vmod_geoip.3: README.rst
++vmod_maxminddb.3: README.rst
+ if HAVE_RST2MAN
+ ${RST2MAN} README.rst $@
+ else
diff --git a/www/varnish-libvmod-maxminddb/pkg-descr b/www/varnish-libvmod-maxminddb/pkg-descr
new file mode 100644
index 000000000000..e6fd43188882
--- /dev/null
+++ b/www/varnish-libvmod-maxminddb/pkg-descr
@@ -0,0 +1,3 @@
+Varnish Module (vmod) for accessing maxminddb geoip data
+
+WWW: https://github.com/simonvik/libvmod_maxminddb
diff --git a/www/varnish-libvmod-maxminddb/pkg-plist b/www/varnish-libvmod-maxminddb/pkg-plist
new file mode 100644
index 000000000000..fc172093e720
--- /dev/null
+++ b/www/varnish-libvmod-maxminddb/pkg-plist
@@ -0,0 +1,4 @@
+lib/varnish/vmods/libvmod_maxminddb.so
+man/man3/vmod_maxminddb.3.gz
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.rst