aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-09 08:47:34 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-09 08:47:34 +0000
commit4395a0e495139f5e842a09cd7565205aefee6f3b (patch)
tree3b4ccfca739a6a00ac972400f471e56b8342bfdf /www
parent399c1e55657ddde1e53d0797caed1c3be292589d (diff)
downloadports-4395a0e495139f5e842a09cd7565205aefee6f3b.tar.gz
ports-4395a0e495139f5e842a09cd7565205aefee6f3b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mozplugger/Makefile2
-rw-r--r--www/mozplugger/distinfo5
-rw-r--r--www/mozplugger/files/patch-Makefile44
3 files changed, 26 insertions, 25 deletions
diff --git a/www/mozplugger/Makefile b/www/mozplugger/Makefile
index b9b499e1e368..35ccb155f090 100644
--- a/www/mozplugger/Makefile
+++ b/www/mozplugger/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mozplugger
-PORTVERSION= 1.14.2
+PORTVERSION= 1.14.3
CATEGORIES= www
MASTER_SITES= http://mozplugger.mozdev.org/files/
diff --git a/www/mozplugger/distinfo b/www/mozplugger/distinfo
index 48ee3e2bb58f..5a0dd0ab70d4 100644
--- a/www/mozplugger/distinfo
+++ b/www/mozplugger/distinfo
@@ -1,3 +1,2 @@
-MD5 (mozplugger-1.14.2.tar.gz) = 76c4e2cdf14e41b6df1d60bd1a2f249d
-SHA256 (mozplugger-1.14.2.tar.gz) = ee768a2c04898da9525200f601ec1f1adeeb5116a0adecded0db6796ecc07b3d
-SIZE (mozplugger-1.14.2.tar.gz) = 93406
+SHA256 (mozplugger-1.14.3.tar.gz) = 2d56f0b224768276b9872499002cfed402ef86ef5c43af70e3466d8aece232f1
+SIZE (mozplugger-1.14.3.tar.gz) = 135099
diff --git a/www/mozplugger/files/patch-Makefile b/www/mozplugger/files/patch-Makefile
index 91e7225f3172..7a65578592b7 100644
--- a/www/mozplugger/files/patch-Makefile
+++ b/www/mozplugger/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2009-08-23 15:36:38.000000000 -0300
-+++ Makefile 2009-08-23 15:49:33.000000000 -0300
+--- Makefile.orig 2011-03-03 15:40:49.000000000 -0600
++++ Makefile 2011-03-08 10:37:12.000000000 -0600
@@ -1,5 +1,5 @@
# Where is your Xwindows located?
-X11=/usr/X11R6
@@ -7,16 +7,20 @@
#
# For building rpms
-@@ -7,7 +7,7 @@
+@@ -7,9 +7,9 @@
#
# For installing
-prefix=/usr
+-sysconfdir=/etc
+-exec_prefix=
+prefix=${PREFIX}
++sysconfdir=${prefix}/etc
++exec_prefix=${PREFIX}
# On 64 bit arch change libprefix to lib64
libprefix=/lib
-@@ -18,7 +18,7 @@
+@@ -20,7 +20,7 @@
RPMDIR=/usr/src/RPM
# Choose compiler
@@ -25,7 +29,7 @@
LD=gcc
BINFORMAT=bin
-@@ -71,10 +71,10 @@
+@@ -74,10 +74,10 @@
${MAKE} all CC=cc LD=ld XLDFLAGS='-expect_unresolved "*" -shared -msym -O3'
freebsd-aout:
@@ -38,33 +42,31 @@
openbsd:
${MAKE} all CC=gcc XCFLAGS=-fPIC LD=gcc XLDFLAGS=-shared X11=/usr/X11R6/
-@@ -119,7 +119,7 @@
+@@ -122,7 +122,7 @@
mozplugger-controller \
mozplugger-linker
--DEFINES= -DXP_UNIX -DVERSION=\"$(VERSION)\" -D$(BUILD) #-D__amd64__
-+DEFINES= -DXP_UNIX -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(prefix)\" -D$(BUILD) #-D__amd64__
+-DEFINES= -DXP_UNIX -DVERSION=\"$(VERSION)\" -D$(BUILD) -DSYSCONFDIR=\"${sysconfdir}\" #-D__amd64__
++DEFINES= -DXP_UNIX -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(prefix)\" -D$(BUILD) -DSYSCONFDIR=\"${sysconfdir}\" #-D__amd64__
INCLUDES= -Inpapi/include -I$(X11)/include
RPM_OPT_FLAGS ?= -O2
COMMON_CFLAGS=$(RPM_OPT_FLAGS) $(INCLUDES) $(DEFINES)
-@@ -190,15 +190,15 @@
+@@ -202,15 +202,15 @@
install:
- -@mkdir -p $(root)$(prefix)/bin
-- -@mkdir -p $(root)$(prefix)$(libprefix)/mozilla/plugins
-- -@mkdir -p $(root)$(prefix)/share/man/man7
-- -@mkdir -p $(root)/etc
+ -@mkdir -p $(exec_prefix)/bin
+- -@mkdir -p $(prefix)$(libprefix)/mozilla/plugins
+- -@mkdir -p $(exec_prefix)/share/man/man7
+ -@mkdir -p $(root)${WEBPLUGINS_DIR}
+ -@mkdir -p $(root)$(prefix)/man/man7
-+ -@mkdir -p $(root)${prefix}/etc
- cp mozplugger-helper $(root)$(prefix)/bin/
- cp mozplugger-controller $(root)$(prefix)/bin/
- cp mozplugger-linker $(root)$(prefix)/bin/
-- cp mozplugger.so $(root)$(prefix)$(libprefix)/mozilla/plugins/
-- cp mozpluggerrc $(root)/etc/
-- cp mozplugger.7 $(root)$(prefix)/share/man/man7/
+ -@mkdir -p ${sysconfdir}
+ cp mozplugger-helper $(exec_prefix)/bin/
+ cp mozplugger-controller $(exec_prefix)/bin/
+ cp mozplugger-linker $(exec_prefix)/bin/
+- cp mozplugger.so $(prefix)$(libprefix)/mozilla/plugins/
+ cp mozplugger.so $(root)${WEBPLUGINS_DIR}
-+ cp mozpluggerrc $(root)$(prefix)/etc/
+ cp mozpluggerrc ${sysconfdir}/
+- cp mozplugger.7 $(exec_prefix)/share/man/man7/
+ cp mozplugger.7 $(root)$(prefix)/man/man7/
mozplugger.tar.gz: $(BASE_FILES) $(SOURCE_FILES)