aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-05-16 02:07:15 +0000
committerMark Felder <feld@FreeBSD.org>2016-05-16 02:07:15 +0000
commit50472a66fef27e857d336cab3c11ce1ad9a077f0 (patch)
treef9f86a55f11048b7d265162dbc7111d8416556ff /www
parent1d8cb0a2169730861148f77b2f43e6dba251671e (diff)
downloadports-50472a66fef27e857d336cab3c11ce1ad9a077f0.tar.gz
ports-50472a66fef27e857d336cab3c11ce1ad9a077f0.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-pySmartDL/Makefile24
-rw-r--r--www/py-pySmartDL/distinfo2
-rw-r--r--www/py-pySmartDL/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a5c3f237f4fc..9d052aba6e9d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1746,6 +1746,7 @@
SUBDIR += py-pyramid
SUBDIR += py-pyramid_rpc
SUBDIR += py-pysearch
+ SUBDIR += py-pySmartDL
SUBDIR += py-python-digitalocean
SUBDIR += py-pywebdav
SUBDIR += py-pywikibot
diff --git a/www/py-pySmartDL/Makefile b/www/py-pySmartDL/Makefile
new file mode 100644
index 000000000000..e668ccb71114
--- /dev/null
+++ b/www/py-pySmartDL/Makefile
@@ -0,0 +1,24 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pySmartDL
+PORTVERSION= 1.2.4
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Smart download manager for Python
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} == "2.7"
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>0:devel/py-futures
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/py-pySmartDL/distinfo b/www/py-pySmartDL/distinfo
new file mode 100644
index 000000000000..5258b1ecf792
--- /dev/null
+++ b/www/py-pySmartDL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pySmartDL-1.2.4.tar.gz) = 65a9b2dbd2070962916a5759797fa86fc0f05a64ba22e51309786c4484490ea1
+SIZE (pySmartDL-1.2.4.tar.gz) = 19689
diff --git a/www/py-pySmartDL/pkg-descr b/www/py-pySmartDL/pkg-descr
new file mode 100644
index 000000000000..7f3aa32f194b
--- /dev/null
+++ b/www/py-pySmartDL/pkg-descr
@@ -0,0 +1,3 @@
+pySmartDL strives to be a full-pleged smart download manager for Python.
+
+WWW: https://github.com/iTaybb/pySmartDL/