aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-06-16 04:46:18 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-06-16 04:46:18 +0000
commit64b5bd34e8aa254e32d6e3d6c1b044b61cee4344 (patch)
tree6acddbc4c47facd52ef73faf2ee3598f9e14a367 /www
parentb1649c6bdf00ca4dd6f89eb4018c90e67b2cdec9 (diff)
downloadports-64b5bd34e8aa254e32d6e3d6c1b044b61cee4344.tar.gz
ports-64b5bd34e8aa254e32d6e3d6c1b044b61cee4344.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/dummyflash/Makefile38
-rw-r--r--www/dummyflash/distinfo2
-rw-r--r--www/dummyflash/files/patch-aa78
-rw-r--r--www/dummyflash/pkg-descr4
-rw-r--r--www/dummyflash/pkg-plist1
6 files changed, 124 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c00442a5d222..ebc4202024eb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -84,6 +84,7 @@
SUBDIR += drivel
SUBDIR += drupal
SUBDIR += dtse
+ SUBDIR += dummyflash
SUBDIR += eldav.el
SUBDIR += elinks
SUBDIR += emacs-w3m
diff --git a/www/dummyflash/Makefile b/www/dummyflash/Makefile
new file mode 100644
index 000000000000..9d257bf28367
--- /dev/null
+++ b/www/dummyflash/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: dummyflash
+# Date Created: June 16 2004
+# Whom: Daniel O'Connor <darius@dons.net.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dummyflash
+PORTVERSION= 1.0
+PORTREVISION= 0
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.netscape.com/pub/sdk/plugin/unix/
+DISTNAME= unix-sdk-3.0b5
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= darius@dons.net.au
+COMMENT= Silently consume flash MIME types
+
+USE_X_PREFIX= yes
+BUILD_WRKSRC= ${WRKSRC}/PluginSDK30b5/examples/UnixTemplate/Unix
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile.freebsd
+
+.if defined(WITH_MOZILLA_DEVEL)
+DEVEL=-devel
+PLIST_SUB=DEVEL=${DEVEL}
+.else
+DEVEL=
+PLIST_SUB=DEVEL=
+.endif
+
+pre-everything::
+ @${ECHO_MSG} "Set WITH_MOZILLA_DEVEL to install this port for www/mozilla-devel"
+
+do-install:
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/dummyflash.so ${PREFIX}/lib/mozilla${DEVEL}/plugins
+
+.include <bsd.port.mk>
diff --git a/www/dummyflash/distinfo b/www/dummyflash/distinfo
new file mode 100644
index 000000000000..46bb94bcd48e
--- /dev/null
+++ b/www/dummyflash/distinfo
@@ -0,0 +1,2 @@
+MD5 (unix-sdk-3.0b5.tar.Z) = 1e43785d5697c60937e8d6236e7d7d7e
+SIZE (unix-sdk-3.0b5.tar.Z) = 1644129
diff --git a/www/dummyflash/files/patch-aa b/www/dummyflash/files/patch-aa
new file mode 100644
index 000000000000..75e478397eac
--- /dev/null
+++ b/www/dummyflash/files/patch-aa
@@ -0,0 +1,78 @@
+--- PluginSDK30b5/examples/UnixTemplate/Source/UnixShell.c.orig Fri Jul 12 15:10:28 1996
++++ PluginSDK30b5/examples/UnixTemplate/Source/UnixShell.c Thu Nov 21 15:38:24 2002
+@@ -48,7 +48,7 @@
+ char*
+ NPP_GetMIMEDescription(void)
+ {
+- return("mime/type:sample:Template Only");
++ return("application/x-shockwave-flash:null flash:Dummy flash plugin");
+ }
+
+ NPError
+@@ -58,12 +58,11 @@
+
+ switch (variable) {
+ case NPPVpluginNameString:
+- *((char **)value) = "Template plugin";
++ *((char **)value) = "Dummy flash plugin";
+ break;
+ case NPPVpluginDescriptionString:
+ *((char **)value) =
+- "This plugins handles nothing. This is only"
+- " a template.";
++ "This is a dummy flash plugin";
+ break;
+ default:
+ err = NPERR_GENERIC_ERROR;
+--- PluginSDK30b5/examples/UnixTemplate/Unix/makefile.freebsd.orig Thu Jan 1 09:30:00 1970
++++ PluginSDK30b5/examples/UnixTemplate/Unix/makefile.freebsd Thu Nov 21 15:39:02 2002
+@@ -0,0 +1,49 @@
++#!make
++################################################################################
++# Copyright (c) 1996 Netscape Communications. All rights reserved.
++################################################################################
++#
++# Template plugin makefile
++#
++# Platform: SunOS 4.1
++#
++# The output of the make process will be nptemplate.so
++# Install this file either in
++# /usr/lib/netscape/plugins/
++# (or)
++# ~/.netscape/plugins/
++# (or) in any convenient directory and point environment variable
++# NPX_PLUGIN_PATH to point to the directory. It is advisable
++# that the plugins (.so) are the only files in that directory.
++#
++# This makefile contains some of our defines for the compiler:
++#
++# XP_UNIX This needs to get defined for npapi.h on unix platforms.
++# PLUGIN_TRACE Enable this define to get debug prints whenever the plugin
++# api gets control.
++
++# PLUGIN_DEFINES= -DXP_UNIX -DPLUGIN_TRACE
++PLUGIN_DEFINES= -DXP_UNIX -I../../../include -I../Source/_gen -I/usr/X11R6/include
++
++CC= gcc
++OPTIMIZER= -g
++CFLAGS= $(OPTIMIZER) $(PLUGIN_DEFINES) -I. -I$(ROOT)/usr/include
++
++SRC= ../Source/UnixShell.c ../Source/stubs.c
++OBJ= UnixShell.o stubs.o
++
++SHAREDTARGET=dummyflash.so
++
++default all: $(SHAREDTARGET)
++
++$(SHAREDTARGET): $(OBJ)
++ $(LD) -shared -o $(SHAREDTARGET) $(OBJ) $(LDFLAGS)
++
++UnixShell.o: ../Source/UnixShell.c
++ $(CC) -c $(CFLAGS) ../Source/UnixShell.c
++
++stubs.o: ../Source/stubs.c
++ $(CC) -c $(CFLAGS) ../Source/stubs.c
++
++clean:
++ $(RM) $(OBJ) $(SHAREDTARGET)
diff --git a/www/dummyflash/pkg-descr b/www/dummyflash/pkg-descr
new file mode 100644
index 000000000000..46594070677d
--- /dev/null
+++ b/www/dummyflash/pkg-descr
@@ -0,0 +1,4 @@
+This plugin silently consumes flash MIME types to prevent the browser from
+prompting the user to download them
+
+WWW: http://www.gsoft.com.au/~doconnor/nullflash.html
diff --git a/www/dummyflash/pkg-plist b/www/dummyflash/pkg-plist
new file mode 100644
index 000000000000..fba39a125159
--- /dev/null
+++ b/www/dummyflash/pkg-plist
@@ -0,0 +1 @@
+lib/mozilla%%DEVEL%%/plugins/dummyflash.so