aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2016-05-17 20:30:57 +0000
committerCarlo Strub <cs@FreeBSD.org>2016-05-17 20:30:57 +0000
commit7523acb6776130d1879e77bf6afb589e8d6c1a68 (patch)
tree5f1b39d407efa611fd3d9128f158d8dd5b233ab4 /www
parent804e286a964239d5fe1e3866f62579b8a4161731 (diff)
downloadports-7523acb6776130d1879e77bf6afb589e8d6c1a68.tar.gz
ports-7523acb6776130d1879e77bf6afb589e8d6c1a68.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-otp/Makefile18
-rw-r--r--www/py-django-otp/distinfo2
-rw-r--r--www/py-django-otp/pkg-descr13
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9d052aba6e9d..393ce57acebb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1561,6 +1561,7 @@
SUBDIR += py-django-mezzanine-grappelli
SUBDIR += py-django-mptt
SUBDIR += py-django-openid-auth
+ SUBDIR += py-django-otp
SUBDIR += py-django-overextends
SUBDIR += py-django-paging
SUBDIR += py-django-photologue
diff --git a/www/py-django-otp/Makefile b/www/py-django-otp/Makefile
new file mode 100644
index 000000000000..789ce4d973dc
--- /dev/null
+++ b/www/py-django-otp/Makefile
@@ -0,0 +1,18 @@
+# Created by: Carlo Strub <cs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= django-otp
+PORTVERSION= 0.3.5
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Adding two-factor authentication to Django
+
+LICENSE= BSD2CLAUSE
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/www/py-django-otp/distinfo b/www/py-django-otp/distinfo
new file mode 100644
index 000000000000..658a78d8d86e
--- /dev/null
+++ b/www/py-django-otp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-otp-0.3.5.tar.gz) = c03cc0b7ec2ad67ca6e1462109966a4aeb3bc5e929f198b39895f29d2a23eb19
+SIZE (django-otp-0.3.5.tar.gz) = 40116
diff --git a/www/py-django-otp/pkg-descr b/www/py-django-otp/pkg-descr
new file mode 100644
index 000000000000..9713d55d0934
--- /dev/null
+++ b/www/py-django-otp/pkg-descr
@@ -0,0 +1,13 @@
+This project makes it easy to add support for one-time passwords (OTPs) to
+Django. It can be integrated at various levels, depending on how much
+customization is required. It integrates with django.contrib.auth, although it
+is not a Django authentication backend. The primary target is developers
+wishing to incorporate OTPs into their Django projects as a form of two-factor
+authentication.
+
+This project includes several simple OTP plugins and more are available
+separately. This package also includes an implementation of OATH HOTP and TOTP
+for convenience, as these are standard OTP algorithms used by multiple
+plugins.
+
+WWW: https://bitbucket.org/psagers/django-otp