aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2018-04-17 15:53:59 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2018-04-17 15:53:59 +0000
commit8142af1bd3f2cfa1dfb17cb7806350d1daaea4a2 (patch)
tree8938b116e65d5649c3eeaac368851fb74023437b /www
parent46aa5e2216e82d5c3463300b1fb254bffac9f211 (diff)
downloadports-8142af1bd3f2cfa1dfb17cb7806350d1daaea4a2.tar.gz
ports-8142af1bd3f2cfa1dfb17cb7806350d1daaea4a2.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/gohugo/Makefile30
-rw-r--r--www/gohugo/distinfo58
2 files changed, 44 insertions, 44 deletions
diff --git a/www/gohugo/Makefile b/www/gohugo/Makefile
index 35762fc88092..742165069c1a 100644
--- a/www/gohugo/Makefile
+++ b/www/gohugo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hugo
DISTVERSIONPREFIX= v
-DISTVERSION= 0.38.2
+DISTVERSION= 0.39
CATEGORIES= www
PKGNAMEPREFIX= go
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
@@ -11,7 +11,7 @@ MAINTAINER= ben.lavery@hashbang0.com
COMMENT= Fast and flexible static site generator
LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE.md
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go
USE_GITHUB= yes
@@ -20,23 +20,23 @@ GH_SUBDIR= src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}
GH_TUPLE= BurntSushi:toml:a368813:toml/src/github.com/BurntSushi/toml \
PuerkitoBio:purell:0bcb03f:purell/src/github.com/PuerkitoBio/purell \
PuerkitoBio:urlesc:de5bf2a:urlesc/src/github.com/PuerkitoBio/urlesc \
- alecthomas:chroma:85c342e:chroma/src/github.com/alecthomas/chroma \
+ alecthomas:chroma:6b1131c:chroma/src/github.com/alecthomas/chroma \
bep:debounce:844797f:debounce/src/github.com/bep/debounce \
bep:gitmap:012701e:gitmap/src/github.com/bep/gitmap \
chaseadamsio:goorgeous:dcf1ef8:goorgeous/src/github.com/chaseadamsio/goorgeous \
- cpuguy83:go-md2man:a65d4d2:go_md2man/src/github.com/cpuguy83/go-md2man \
+ cpuguy83:go-md2man:20f5889:go_md2man/src/github.com/cpuguy83/go-md2man \
danwakefield:fnmatch:cbb64ac:fnmatch/src/github.com/danwakefield/fnmatch \
davecgh:go-spew:346938d:go_spew/src/github.com/davecgh/go-spew \
disintegration:imaging:dd50a3e:imaging/src/github.com/disintegration/imaging \
dlclark:regexp2:487489b:regexp2/src/github.com/dlclark/regexp2 \
eknkc:amber:cdade1c:amber/src/github.com/eknkc/amber \
- fortytw2:leaktest:7dad533:leaktest/src/github.com/fortytw2/leaktest \
+ fortytw2:leaktest:a5ef704:leaktest/src/github.com/fortytw2/leaktest \
fsnotify:fsnotify:c282820:fsnotify/src/github.com/fsnotify/fsnotify \
gobwas:glob:5ccd90e:glob/src/github.com/gobwas/glob \
gorilla:websocket:ea4d1f6:websocket/src/github.com/gorilla/websocket \
hashicorp:go-immutable-radix:7f3cd43:go_immutable_radix/src/github.com/hashicorp/go-immutable-radix \
hashicorp:golang-lru:0fb14ef:golang_lru/src/github.com/hashicorp/golang-lru \
- hashicorp:hcl:23c074d:hcl/src/github.com/hashicorp/hcl \
+ hashicorp:hcl:ef8a98b:hcl/src/github.com/hashicorp/hcl \
inconshreveable:mousetrap:76626ae:mousetrap/src/github.com/inconshreveable/mousetrap \
jdkato:prose:20d3663:prose/src/github.com/jdkato/prose \
kyokomi:emoji:7e06b23:emoji/src/github.com/kyokomi/emoji \
@@ -45,8 +45,8 @@ GH_TUPLE= BurntSushi:toml:a368813:toml/src/github.com/BurntSushi/toml \
markbates:inflect:a12c3ae:inflect/src/github.com/markbates/inflect \
mattn:go-runewidth:9e777a8:go_runewidth/src/github.com/mattn/go-runewidth \
miekg:mmark:fd2f6c1:mmark/src/github.com/miekg/mmark \
- mitchellh:mapstructure:a4e142e:mapstructure/src/github.com/mitchellh/mapstructure \
- muesli:smartcrop:1db4849:smartcrop/src/github.com/muesli/smartcrop \
+ mitchellh:mapstructure:00c29f5:mapstructure/src/github.com/mitchellh/mapstructure \
+ muesli:smartcrop:f6ebaa7:smartcrop/src/github.com/muesli/smartcrop \
nicksnyder:go-i18n:0dc1626:go_i18n/src/github.com/nicksnyder/go-i18n \
olekukonko:tablewriter:b8a9be0:tablewriter/src/github.com/olekukonko/tablewriter \
pelletier:go-toml:acdc450:go_toml/src/github.com/pelletier/go-toml \
@@ -56,7 +56,7 @@ GH_TUPLE= BurntSushi:toml:a368813:toml/src/github.com/BurntSushi/toml \
shurcooL:sanitized_anchor_name:86672fc:sanitized_anchor_name/src/github.com/shurcooL/sanitized_anchor_name \
spf13:afero:6364489:afero/src/github.com/spf13/afero \
spf13:cast:8965335:cast/src/github.com/spf13/cast \
- spf13:cobra:be77323:cobra/src/github.com/spf13/cobra \
+ spf13:cobra:a1f051b:cobra/src/github.com/spf13/cobra \
spf13:fsync:12a01e6:fsync/src/github.com/spf13/fsync \
spf13:jWalterWeatherman:7c0cea3:jWalterWeatherman/src/github.com/spf13/jwalterweatherman \
spf13:nitro:24d7ef3:nitro/src/github.com/spf13/nitro \
@@ -64,12 +64,12 @@ GH_TUPLE= BurntSushi:toml:a368813:toml/src/github.com/BurntSushi/toml \
spf13:viper:b5e8006:viper/src/github.com/spf13/viper \
stretchr:testify:12b6f73:testify/src/github.com/stretchr/testify \
yosssi:ace:ea038f4:ace/src/github.com/yosssi/ace \
- golang:image:12117c1:image/src/golang.org/x/image \
- golang:net:136a25c:net/src/golang.org/x/net \
- golang:sync:fd80eb9:sync/src/golang.org/x/sync \
- golang:sys:37707fd:sys/src/golang.org/x/sys \
- golang:text:4e4a321:text/src/golang.org/x/text \
- go-yaml:yaml:d670f94:yaml/src/gopkg.in/yaml.v2
+ golang:image:f315e44:image/src/golang.org/x/image \
+ golang:net:61147c4:net/src/golang.org/x/net \
+ golang:sync:1d60e46:sync/src/golang.org/x/sync \
+ golang:sys:3b87a42:sys/src/golang.org/x/sys \
+ golang:text:2cb4393:text/src/golang.org/x/text \
+ go-yaml:yaml:5420a8b:yaml/src/gopkg.in/yaml.v2
OPTIONS_DEFINE= MANPAGES
OPTIONS_DEFAULT= MANPAGES
diff --git a/www/gohugo/distinfo b/www/gohugo/distinfo
index de6c53107807..f46430bebbca 100644
--- a/www/gohugo/distinfo
+++ b/www/gohugo/distinfo
@@ -1,22 +1,22 @@
-TIMESTAMP = 1523564042
-SHA256 (gohugo/gohugoio-hugo-v0.38.2_GH0.tar.gz) = a8197de4e2480dade53cfe6c0213c3576efe468d1e21d7518cecb019edbbb846
-SIZE (gohugo/gohugoio-hugo-v0.38.2_GH0.tar.gz) = 28097801
+TIMESTAMP = 1523912409
+SHA256 (gohugo/gohugoio-hugo-v0.39_GH0.tar.gz) = db8e8e8f51879d8892bc089bc2078bfa83a7d9a4231e39c60220911b2ee9ad30
+SIZE (gohugo/gohugoio-hugo-v0.39_GH0.tar.gz) = 28310542
SHA256 (gohugo/BurntSushi-toml-a368813_GH0.tar.gz) = 68dc067c4105cd20a642ddf1f4acaada7474c1b58e5b249d4bd9b0d7e8edebc2
SIZE (gohugo/BurntSushi-toml-a368813_GH0.tar.gz) = 42252
SHA256 (gohugo/PuerkitoBio-purell-0bcb03f_GH0.tar.gz) = ade9e6e2a5d1d79daaf2d729f450c482ff0aa316ea0a1d9e5e3f7a753d05c49c
SIZE (gohugo/PuerkitoBio-purell-0bcb03f_GH0.tar.gz) = 11654
SHA256 (gohugo/PuerkitoBio-urlesc-de5bf2a_GH0.tar.gz) = 0d4b469d8d1dfe12e740661d242df9f49779e6f07a31361231d5314979391df5
SIZE (gohugo/PuerkitoBio-urlesc-de5bf2a_GH0.tar.gz) = 6796
-SHA256 (gohugo/alecthomas-chroma-85c342e_GH0.tar.gz) = e0b372e0539afb99ddb755ea17ad7892902aef4a2d8f007973e20aad47cce959
-SIZE (gohugo/alecthomas-chroma-85c342e_GH0.tar.gz) = 298049
+SHA256 (gohugo/alecthomas-chroma-6b1131c_GH0.tar.gz) = 8051ba22e0e1bbf25765e57432ff9880124663ff184912bbc6fbd4e0adf875ef
+SIZE (gohugo/alecthomas-chroma-6b1131c_GH0.tar.gz) = 299642
SHA256 (gohugo/bep-debounce-844797f_GH0.tar.gz) = e957962f6cf46be644cc31c6de4c2d5dda00736a6f507bc24042235d0295c9c8
SIZE (gohugo/bep-debounce-844797f_GH0.tar.gz) = 3489
SHA256 (gohugo/bep-gitmap-012701e_GH0.tar.gz) = 6af8c509315fcaa0abc8d922009357e360d86ac419a611639ca3b67636d053c1
SIZE (gohugo/bep-gitmap-012701e_GH0.tar.gz) = 4596
SHA256 (gohugo/chaseadamsio-goorgeous-dcf1ef8_GH0.tar.gz) = 6dbf5f61257fc8c71ec6ae533f477f351c1b0fa11774cf6e8abf27edc7d90d61
SIZE (gohugo/chaseadamsio-goorgeous-dcf1ef8_GH0.tar.gz) = 34318
-SHA256 (gohugo/cpuguy83-go-md2man-a65d4d2_GH0.tar.gz) = aa57abcc9cc5b034a91479922764bffdcd602d29c8b8ce5512f4dc6bbaab54b9
-SIZE (gohugo/cpuguy83-go-md2man-a65d4d2_GH0.tar.gz) = 40242
+SHA256 (gohugo/cpuguy83-go-md2man-20f5889_GH0.tar.gz) = bab48ebb3ef8c482ba3564020168d0fd47dd70fe87a313b4f7a6f67b692be077
+SIZE (gohugo/cpuguy83-go-md2man-20f5889_GH0.tar.gz) = 79309
SHA256 (gohugo/danwakefield-fnmatch-cbb64ac_GH0.tar.gz) = e187c66e99cdae6474edc59c1a63245e8e9428c4035c36e76c2cfe0b46ca7a38
SIZE (gohugo/danwakefield-fnmatch-cbb64ac_GH0.tar.gz) = 4950
SHA256 (gohugo/davecgh-go-spew-346938d_GH0.tar.gz) = 92e706ece5da01f2c61cf632e168d8c24d44866523b25f0e8eb9d1596c5d5f79
@@ -27,8 +27,8 @@ SHA256 (gohugo/dlclark-regexp2-487489b_GH0.tar.gz) = ee911649e6f517303a90a2f9f9e
SIZE (gohugo/dlclark-regexp2-487489b_GH0.tar.gz) = 203400
SHA256 (gohugo/eknkc-amber-cdade1c_GH0.tar.gz) = 3e2f7d217f104aa055cd9544cc3181d75406e5f1c11a191361e602fe25ae8e15
SIZE (gohugo/eknkc-amber-cdade1c_GH0.tar.gz) = 22601
-SHA256 (gohugo/fortytw2-leaktest-7dad533_GH0.tar.gz) = b732d88c9f7c475d4282d96812cb49726cbc736603bc5e1aeda5062be75838f3
-SIZE (gohugo/fortytw2-leaktest-7dad533_GH0.tar.gz) = 3677
+SHA256 (gohugo/fortytw2-leaktest-a5ef704_GH0.tar.gz) = a21feb618bbd196f9db9590c42233852a4072ce9ce17f5b10696016acf0bf9cb
+SIZE (gohugo/fortytw2-leaktest-a5ef704_GH0.tar.gz) = 4639
SHA256 (gohugo/fsnotify-fsnotify-c282820_GH0.tar.gz) = 85d31bf25f43a66fbaf0799ce8993a038694e65312bef96441a83556abaff73a
SIZE (gohugo/fsnotify-fsnotify-c282820_GH0.tar.gz) = 31139
SHA256 (gohugo/gobwas-glob-5ccd90e_GH0.tar.gz) = 8cc10587c2b7a0bce5753f82f24bbc83008d5828849a5f206aeab97a67bd1050
@@ -39,8 +39,8 @@ SHA256 (gohugo/hashicorp-go-immutable-radix-7f3cd43_GH0.tar.gz) = f04accbdac242e
SIZE (gohugo/hashicorp-go-immutable-radix-7f3cd43_GH0.tar.gz) = 18972
SHA256 (gohugo/hashicorp-golang-lru-0fb14ef_GH0.tar.gz) = 0a9056fea3b9e92bf2dba50520ae22cdde4cffed12e344fd775fde8ba53309e5
SIZE (gohugo/hashicorp-golang-lru-0fb14ef_GH0.tar.gz) = 12899
-SHA256 (gohugo/hashicorp-hcl-23c074d_GH0.tar.gz) = e1261b44b456f6b496a7aa652cc7359f766c998eef03e1ee36a437ee27f94a5f
-SIZE (gohugo/hashicorp-hcl-23c074d_GH0.tar.gz) = 69802
+SHA256 (gohugo/hashicorp-hcl-ef8a98b_GH0.tar.gz) = 57a3754b8f027f56aed31b98b607e4e5a3e9f4ae64625fd98e1c3a66ea59a190
+SIZE (gohugo/hashicorp-hcl-ef8a98b_GH0.tar.gz) = 70438
SHA256 (gohugo/inconshreveable-mousetrap-76626ae_GH0.tar.gz) = d56204c0067e12a8939e1db62e907095f4fba37d98cb1e0ec574f1dce89effc4
SIZE (gohugo/inconshreveable-mousetrap-76626ae_GH0.tar.gz) = 2288
SHA256 (gohugo/jdkato-prose-20d3663_GH0.tar.gz) = 53f23648aaac68bd8d532dbecb2a33a5ac83b9e2264c60e8d7caebcfacc65460
@@ -57,10 +57,10 @@ SHA256 (gohugo/mattn-go-runewidth-9e777a8_GH0.tar.gz) = 4249ccc1fa807f20a7034e8e
SIZE (gohugo/mattn-go-runewidth-9e777a8_GH0.tar.gz) = 22363
SHA256 (gohugo/miekg-mmark-fd2f6c1_GH0.tar.gz) = 5651c08280f6d8468b30c53368f23722b868206427c905c3d6ac6022e7185945
SIZE (gohugo/miekg-mmark-fd2f6c1_GH0.tar.gz) = 198722
-SHA256 (gohugo/mitchellh-mapstructure-a4e142e_GH0.tar.gz) = 765d11e0da1df40811f25cd2d69e58a9c958acc9891087f6a90ebca08273b9d9
-SIZE (gohugo/mitchellh-mapstructure-a4e142e_GH0.tar.gz) = 17996
-SHA256 (gohugo/muesli-smartcrop-1db4849_GH0.tar.gz) = ae61d58038c1eb74f74626af3e8aa29ed9a01d71822d513961efaf116eb6815b
-SIZE (gohugo/muesli-smartcrop-1db4849_GH0.tar.gz) = 447906
+SHA256 (gohugo/mitchellh-mapstructure-00c29f5_GH0.tar.gz) = 612c2d0d6aade35b2556e74be050689517bc9f68a2f0c8c8b3cb1d09d8d123b4
+SIZE (gohugo/mitchellh-mapstructure-00c29f5_GH0.tar.gz) = 18395
+SHA256 (gohugo/muesli-smartcrop-f6ebaa7_GH0.tar.gz) = 337fa158b74dd3b2fd4904737329789f7765fe88c815cb099590d9717cc80085
+SIZE (gohugo/muesli-smartcrop-f6ebaa7_GH0.tar.gz) = 448029
SHA256 (gohugo/nicksnyder-go-i18n-0dc1626_GH0.tar.gz) = 85469070e822c4102fb3d60f30c099d3aa0675cb7e0109448958324b904d38f0
SIZE (gohugo/nicksnyder-go-i18n-0dc1626_GH0.tar.gz) = 39643
SHA256 (gohugo/olekukonko-tablewriter-b8a9be0_GH0.tar.gz) = c298df35543b6ca4ef61a84de03884140ec051976b772072f287b2a08435c52a
@@ -79,8 +79,8 @@ SHA256 (gohugo/spf13-afero-6364489_GH0.tar.gz) = e4dd6703ba9bb47e1b8ae62fa904eec
SIZE (gohugo/spf13-afero-6364489_GH0.tar.gz) = 45186
SHA256 (gohugo/spf13-cast-8965335_GH0.tar.gz) = b19c0f765ad78d7aefd363c57b9c4f78e6b75b079542b47922ed52c3fff07cdf
SIZE (gohugo/spf13-cast-8965335_GH0.tar.gz) = 9855
-SHA256 (gohugo/spf13-cobra-be77323_GH0.tar.gz) = 9bb901caa5158d5ecedfe18872d6cf16082448c545dbe381c2108fe0e0057bd1
-SIZE (gohugo/spf13-cobra-be77323_GH0.tar.gz) = 100308
+SHA256 (gohugo/spf13-cobra-a1f051b_GH0.tar.gz) = 692baf59c0952d4b113a897e6556e95c65bd36998a0b19abf3453bbf87e07db9
+SIZE (gohugo/spf13-cobra-a1f051b_GH0.tar.gz) = 100782
SHA256 (gohugo/spf13-fsync-12a01e6_GH0.tar.gz) = f3d5520a8dba6d57618db9a869abeb23f349ec20c177f5fa8957588bb987e0aa
SIZE (gohugo/spf13-fsync-12a01e6_GH0.tar.gz) = 4840
SHA256 (gohugo/spf13-jWalterWeatherman-7c0cea3_GH0.tar.gz) = ee1fa0fb1f9a9df8b93a15f67a42322eccfe1e314f489cf1909a7c3ac37dcc7d
@@ -95,15 +95,15 @@ SHA256 (gohugo/stretchr-testify-12b6f73_GH0.tar.gz) = d916c3ed1ccbba35f0e01dce8f
SIZE (gohugo/stretchr-testify-12b6f73_GH0.tar.gz) = 95230
SHA256 (gohugo/yosssi-ace-ea038f4_GH0.tar.gz) = 0d8da272af4618613b62f6f28fff6142d285c70de0658b8c328f588a690e4b85
SIZE (gohugo/yosssi-ace-ea038f4_GH0.tar.gz) = 23269
-SHA256 (gohugo/golang-image-12117c1_GH0.tar.gz) = f5e9ceef0e58238388a7c75083c436ec93781829923de5ee9b8848364887bfaf
-SIZE (gohugo/golang-image-12117c1_GH0.tar.gz) = 4816520
-SHA256 (gohugo/golang-net-136a25c_GH0.tar.gz) = 2d17d156885d1ee09d9f7280fd4f6e74bedcc5f1bbb7e15b31550863ceea7b8e
-SIZE (gohugo/golang-net-136a25c_GH0.tar.gz) = 936295
-SHA256 (gohugo/golang-sync-fd80eb9_GH0.tar.gz) = bae73bd7b81336d67b38c72e55b185bcb5a3e194f1210dc475fc811d32afaff4
-SIZE (gohugo/golang-sync-fd80eb9_GH0.tar.gz) = 16385
-SHA256 (gohugo/golang-sys-37707fd_GH0.tar.gz) = 9a86c90f564594b3f201540d19fb4fb828e1df8af61bb2fa9190a760cba039a7
-SIZE (gohugo/golang-sys-37707fd_GH0.tar.gz) = 795284
-SHA256 (gohugo/golang-text-4e4a321_GH0.tar.gz) = dff5f00dcf8df086d82b3c1166b73c34cd06de428849b67bad80abd59575ef3d
-SIZE (gohugo/golang-text-4e4a321_GH0.tar.gz) = 6113403
-SHA256 (gohugo/go-yaml-yaml-d670f94_GH0.tar.gz) = 4463e4d645c426bafeb6ad3b479bd16b7245637609cb5da27b89fca40ebf87a5
-SIZE (gohugo/go-yaml-yaml-d670f94_GH0.tar.gz) = 64752
+SHA256 (gohugo/golang-image-f315e44_GH0.tar.gz) = ad2d55d7f42049f0d5b30d7850b1bea18631dc2c7bec70bb30454a37556707d6
+SIZE (gohugo/golang-image-f315e44_GH0.tar.gz) = 4816515
+SHA256 (gohugo/golang-net-61147c4_GH0.tar.gz) = e34008062dee507e06a82ba2035906757a343ff862b5f2195f3a0f50c59b117d
+SIZE (gohugo/golang-net-61147c4_GH0.tar.gz) = 941792
+SHA256 (gohugo/golang-sync-1d60e46_GH0.tar.gz) = 526fab48f250f45ec22dbfd2700df629871ea8aeb8289a49c58f4fc606a7a5e5
+SIZE (gohugo/golang-sync-1d60e46_GH0.tar.gz) = 16327
+SHA256 (gohugo/golang-sys-3b87a42_GH0.tar.gz) = 1c39939ad35db460f7c9dd1e5c18f645c131b75f422ef3351e9581646c1269b3
+SIZE (gohugo/golang-sys-3b87a42_GH0.tar.gz) = 801930
+SHA256 (gohugo/golang-text-2cb4393_GH0.tar.gz) = ea60e68948669d1c9245c728a842ee009a0749c1635c362b99c9bd16bf6a8ef8
+SIZE (gohugo/golang-text-2cb4393_GH0.tar.gz) = 6566252
+SHA256 (gohugo/go-yaml-yaml-5420a8b_GH0.tar.gz) = d9be7faf5cb89a81c5ec6c94f1f1b0da076b239e205d3f36b9071b1aa7d27bcc
+SIZE (gohugo/go-yaml-yaml-5420a8b_GH0.tar.gz) = 70228