aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-02-11 17:52:27 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-02-11 17:52:27 +0000
commit8de31b9ac75b77d1747e33211d139e0601b6c65f (patch)
tree27781066c1fbe1090363e84518cea6c74c9a2b8c /www
parentc923f72f2b962f97e83af6f184ae6a7501ff2cfe (diff)
downloadports-8de31b9ac75b77d1747e33211d139e0601b6c65f.tar.gz
ports-8de31b9ac75b77d1747e33211d139e0601b6c65f.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-View-TT-ControllerLocal/Makefile32
-rw-r--r--www/p5-Catalyst-View-TT-ControllerLocal/distinfo3
-rw-r--r--www/p5-Catalyst-View-TT-ControllerLocal/pkg-descr22
-rw-r--r--www/p5-Catalyst-View-TT-ControllerLocal/pkg-plist12
5 files changed, 70 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 55850204f731..7024662bff48 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -542,6 +542,7 @@
SUBDIR += p5-Catalyst-View-HTML-Template
SUBDIR += p5-Catalyst-View-Mason
SUBDIR += p5-Catalyst-View-TT
+ SUBDIR += p5-Catalyst-View-TT-ControllerLocal
SUBDIR += p5-Class-DBI-FromForm
SUBDIR += p5-Compress-LeadingBlankSpaces
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
diff --git a/www/p5-Catalyst-View-TT-ControllerLocal/Makefile b/www/p5-Catalyst-View-TT-ControllerLocal/Makefile
new file mode 100644
index 000000000000..f33c8015e3d8
--- /dev/null
+++ b/www/p5-Catalyst-View-TT-ControllerLocal/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-Catalyst-View-TT-ControllerLocal
+# Date created: 11 Feb 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-View-TT-ControllerLocal
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Catalyst TT View with template names relative to the Controller
+
+BUILD_DEPENDS= p5-Catalyst>=0:${PORTSDIR}/www/p5-Catalyst \
+ p5-Catalyst-View-TT>=0:${PORTSDIR}/www/p5-Catalyst-View-TT \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Helper::View::TTControllerLocal.3 \
+ Catalyst::View::TT::ControllerLocal.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500801
+IGNORE= requires Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-View-TT-ControllerLocal/distinfo b/www/p5-Catalyst-View-TT-ControllerLocal/distinfo
new file mode 100644
index 000000000000..8d3e8860bcf1
--- /dev/null
+++ b/www/p5-Catalyst-View-TT-ControllerLocal/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-View-TT-ControllerLocal-0.02.tar.gz) = 892b31bba9f31dce149b0c44e0ee9413
+SHA256 (Catalyst-View-TT-ControllerLocal-0.02.tar.gz) = 723260f304122c8cd570b197a30f44d8413bbe94b7cb0e540092ec725c5bc603
+SIZE (Catalyst-View-TT-ControllerLocal-0.02.tar.gz) = 3511
diff --git a/www/p5-Catalyst-View-TT-ControllerLocal/pkg-descr b/www/p5-Catalyst-View-TT-ControllerLocal/pkg-descr
new file mode 100644
index 000000000000..dc68746f072f
--- /dev/null
+++ b/www/p5-Catalyst-View-TT-ControllerLocal/pkg-descr
@@ -0,0 +1,22 @@
+Catalyst::View::TT::ControllerLocal is like a normal Catalyst TT View,
+but with template file names relative to the current Controller. So
+with a set of templates like:
+
+ ./root/edit.html
+ ./root/add.html
+ ./root/Frobniz/add.html
+
+and an action "add" in the Controller "MyApp::Controller::Frobniz", you
+set "$c->stash->{template}" to "add.html" in order for it to pick up
+the "./root/frobbiz/add.html" template.
+
+Setting the "$c->stash->{template}" from Controller "MyApp::Con-
+troller::Bogon" would instead pick the default template in
+"./root/add.html" (since there is no Bogon subdirectory under root).
+
+In addition, since there is no file "edit.html" except in the Frobniz
+directory, C::V::TT::ControllerLocal will default to looking for
+"edit.html" in ./root/ and ./root/base (or whatever you set MyApp->con-
+fig->{INCLUDE_PATH} to).
+
+WWW: http://search.cpan.org/dist/Catalyst-View-TT-ControllerLocal/
diff --git a/www/p5-Catalyst-View-TT-ControllerLocal/pkg-plist b/www/p5-Catalyst-View-TT-ControllerLocal/pkg-plist
new file mode 100644
index 000000000000..940512df310d
--- /dev/null
+++ b/www/p5-Catalyst-View-TT-ControllerLocal/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/Catalyst/View/TT/ControllerLocal.pm
+%%SITE_PERL%%/Catalyst/Helper/View/TTControllerLocal.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/TT/ControllerLocal/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/TT/ControllerLocal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/TT
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper/View
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper
+@dirrmtry %%SITE_PERL%%/Catalyst/View/TT
+@dirrmtry %%SITE_PERL%%/Catalyst/View
+@dirrmtry %%SITE_PERL%%/Catalyst