aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-30 20:16:33 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-30 20:16:33 +0000
commitbad945faf78f215122dee1d6ed24425213e5d16a (patch)
tree101fa5309deef3bebd86fc9b23488392505638c2 /www
parent16d3aba14d1bd6ab6f9ef0af4536eb5f703d5b0e (diff)
downloadports-bad945faf78f215122dee1d6ed24425213e5d16a.tar.gz
ports-bad945faf78f215122dee1d6ed24425213e5d16a.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-fedex/Makefile24
-rw-r--r--www/py-fedex/distinfo2
-rw-r--r--www/py-fedex/pkg-descr3
-rw-r--r--www/py-fedex/pkg-plist54
5 files changed, 84 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 57191f32bad1..81a8348b13f2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1476,6 +1476,7 @@
SUBDIR += py-dotcloud.cli
SUBDIR += py-dtflickr
SUBDIR += py-fcgi
+ SUBDIR += py-fedex
SUBDIR += py-feedfinder
SUBDIR += py-feedgenerator
SUBDIR += py-flask
diff --git a/www/py-fedex/Makefile b/www/py-fedex/Makefile
new file mode 100644
index 000000000000..8f82e077f0ad
--- /dev/null
+++ b/www/py-fedex/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-fedex
+# Date created: 31 May 2012
+# Whom: Kevin Golding <ports@caomhin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fedex
+PORTVERSION= 1.0.13
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= A light wrapper around Fedex's Web Services SOAP API using suds
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}suds>=0:${PORTSDIR}/net/py-suds
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-fedex/distinfo b/www/py-fedex/distinfo
new file mode 100644
index 000000000000..e7f5856445a5
--- /dev/null
+++ b/www/py-fedex/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fedex-1.0.13.tar.gz) = d60d852ec5fb0cc8b2ef91c0f180fec901b78fb1d324922c5e93aa5f7c1f8707
+SIZE (fedex-1.0.13.tar.gz) = 446371
diff --git a/www/py-fedex/pkg-descr b/www/py-fedex/pkg-descr
new file mode 100644
index 000000000000..07e102cc7ebd
--- /dev/null
+++ b/www/py-fedex/pkg-descr
@@ -0,0 +1,3 @@
+A light wrapper around Fedex's Web Services SOAP API using suds.
+
+WWW: http://code.google.com/p/python-fedex/
diff --git a/www/py-fedex/pkg-plist b/www/py-fedex/pkg-plist
new file mode 100644
index 000000000000..16b3ab7fd1df
--- /dev/null
+++ b/www/py-fedex/pkg-plist
@@ -0,0 +1,54 @@
+%%PYTHON_SITELIBDIR%%/fedex/__init__.py
+%%PYTHON_SITELIBDIR%%/fedex/__init__.pyc
+%%PYTHON_SITELIBDIR%%/fedex/__init__.pyo
+%%PYTHON_SITELIBDIR%%/fedex/base_service.py
+%%PYTHON_SITELIBDIR%%/fedex/base_service.pyc
+%%PYTHON_SITELIBDIR%%/fedex/base_service.pyo
+%%PYTHON_SITELIBDIR%%/fedex/config.py
+%%PYTHON_SITELIBDIR%%/fedex/config.pyc
+%%PYTHON_SITELIBDIR%%/fedex/config.pyo
+%%PYTHON_SITELIBDIR%%/fedex/printers/__init__.py
+%%PYTHON_SITELIBDIR%%/fedex/printers/__init__.pyc
+%%PYTHON_SITELIBDIR%%/fedex/printers/__init__.pyo
+%%PYTHON_SITELIBDIR%%/fedex/printers/unix.py
+%%PYTHON_SITELIBDIR%%/fedex/printers/unix.pyc
+%%PYTHON_SITELIBDIR%%/fedex/printers/unix.pyo
+%%PYTHON_SITELIBDIR%%/fedex/services/__init__.py
+%%PYTHON_SITELIBDIR%%/fedex/services/__init__.pyc
+%%PYTHON_SITELIBDIR%%/fedex/services/__init__.pyo
+%%PYTHON_SITELIBDIR%%/fedex/services/address_validation_service.py
+%%PYTHON_SITELIBDIR%%/fedex/services/address_validation_service.pyc
+%%PYTHON_SITELIBDIR%%/fedex/services/address_validation_service.pyo
+%%PYTHON_SITELIBDIR%%/fedex/services/package_movement.py
+%%PYTHON_SITELIBDIR%%/fedex/services/package_movement.pyc
+%%PYTHON_SITELIBDIR%%/fedex/services/package_movement.pyo
+%%PYTHON_SITELIBDIR%%/fedex/services/rate_service.py
+%%PYTHON_SITELIBDIR%%/fedex/services/rate_service.pyc
+%%PYTHON_SITELIBDIR%%/fedex/services/rate_service.pyo
+%%PYTHON_SITELIBDIR%%/fedex/services/ship_service.py
+%%PYTHON_SITELIBDIR%%/fedex/services/ship_service.pyc
+%%PYTHON_SITELIBDIR%%/fedex/services/ship_service.pyo
+%%PYTHON_SITELIBDIR%%/fedex/services/track_service.py
+%%PYTHON_SITELIBDIR%%/fedex/services/track_service.pyc
+%%PYTHON_SITELIBDIR%%/fedex/services/track_service.pyo
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/AddressValidationService_v2.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/CloseService_v2.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/CourierDispatchService_v3.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/PackageMovementInformationService_v4.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/RateService_v8.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/ReturnTagService_v1.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/ShipService_v7.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/TrackService_v4.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl/AddressValidationService_v2.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl/CloseService_v2.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl/CourierDispatchService_v3.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl/PackageMovementInformationService_v4.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl/RateService_v8.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl/ReturnTagService_v1.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl/ShipService_v7.wsdl
+%%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl/TrackService_v4.wsdl
+@dirrm %%PYTHON_SITELIBDIR%%/fedex/wsdl/test_server_wsdl
+@dirrm %%PYTHON_SITELIBDIR%%/fedex/wsdl
+@dirrm %%PYTHON_SITELIBDIR%%/fedex/services
+@dirrm %%PYTHON_SITELIBDIR%%/fedex/printers
+@dirrm %%PYTHON_SITELIBDIR%%/fedex