aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-24 18:10:30 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-24 18:10:30 +0000
commite1598249298974c6e8c61c34d927acabee345542 (patch)
tree5883afe298a5f232e854b104fc944ca19c4f7e7f /www
parent422e3bda8bd3eb5d0b4737e335fd434883fbc44f (diff)
downloadports-e1598249298974c6e8c61c34d927acabee345542.tar.gz
ports-e1598249298974c6e8c61c34d927acabee345542.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/aria/Makefile2
-rw-r--r--www/awffull/Makefile2
-rw-r--r--www/cadaver/Makefile2
-rw-r--r--www/cakephp12/Makefile2
-rw-r--r--www/cakephp13/Makefile2
-rw-r--r--www/cakephp21/Makefile2
-rw-r--r--www/cakephp22/Makefile2
-rw-r--r--www/diamanda/Makefile2
-rw-r--r--www/dillo-i18n/Makefile2
-rw-r--r--www/elgg/Makefile2
-rw-r--r--www/epiphany-extensions/Makefile2
-rw-r--r--www/evolution-webcal/Makefile2
-rw-r--r--www/gallery/Makefile2
-rw-r--r--www/gallery2/Makefile2
-rw-r--r--www/gallery3/Makefile2
-rw-r--r--www/gnome-user-share/Makefile2
-rw-r--r--www/gnome-web-photo/Makefile2
-rw-r--r--www/google-appengine/Makefile2
-rw-r--r--www/gtkhtml3/Makefile2
-rw-r--r--www/horde3-ansel/Makefile2
-rw-r--r--www/horde3-base/Makefile2
-rw-r--r--www/horde3-passwd/Makefile2
-rw-r--r--www/horde3-trean/Makefile2
-rw-r--r--www/horde3-wicked/Makefile2
-rw-r--r--www/ikiwiki/Makefile2
-rw-r--r--www/libepc/Makefile2
-rw-r--r--www/linkchecker/Makefile2
-rw-r--r--www/llgal/Makefile2
-rw-r--r--www/lynx-current/Makefile2
-rw-r--r--www/lynx/Makefile2
-rw-r--r--www/neon29/Makefile2
-rw-r--r--www/newsbeuter/Makefile2
-rw-r--r--www/nscache/Makefile2
-rw-r--r--www/pivotx/Makefile2
-rw-r--r--www/py-django-devel/Makefile2
-rw-r--r--www/py-django-mezzanine-filebrowser/Makefile2
-rw-r--r--www/py-django-mezzanine-grappelli/Makefile2
-rw-r--r--www/py-django-mptt/Makefile2
-rw-r--r--www/py-django-registration/Makefile2
-rw-r--r--www/py-django/Makefile2
-rw-r--r--www/py-django13/Makefile2
-rw-r--r--www/py-django14/Makefile2
-rw-r--r--www/py-formencode/Makefile2
-rw-r--r--www/py-nevow/Makefile2
-rw-r--r--www/py-prewikka/Makefile2
-rw-r--r--www/py-satchmo/Makefile2
-rw-r--r--www/py-turbogears/Makefile2
-rw-r--r--www/retawq/Makefile2
-rw-r--r--www/roundup/Makefile2
-rw-r--r--www/sitecopy/Makefile2
-rw-r--r--www/snownews/Makefile2
-rw-r--r--www/w3m/Makefile2
-rw-r--r--www/wml/Makefile2
-rw-r--r--www/zend-framework/Makefile2
54 files changed, 54 insertions, 54 deletions
diff --git a/www/aria/Makefile b/www/aria/Makefile
index e97325e9e468..70dfd06eb881 100644
--- a/www/aria/Makefile
+++ b/www/aria/Makefile
@@ -19,7 +19,7 @@ BROKEN= fails to build
USE_BZIP2= yes
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/www/awffull/Makefile b/www/awffull/Makefile
index 6611446c41f0..f779590d3c91 100644
--- a/www/awffull/Makefile
+++ b/www/awffull/Makefile
@@ -24,7 +24,7 @@ FONTLABEL?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf
OPTIONS_DEFINE= GEOIP
USE_ICONV= yes
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-font-default=${FONTDEFAULT} \
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 8ab983662bb5..2060fd6c038a 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -52,7 +52,7 @@ post-install:
.if !defined(WITHOUT_NLS)
USE_ICONV= yes
-USE_GETTEXT= yes
+USES= gettext
CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE}
LANGS=en@quot es it
diff --git a/www/cakephp12/Makefile b/www/cakephp12/Makefile
index fb2de643f780..dd35ccb63986 100644
--- a/www/cakephp12/Makefile
+++ b/www/cakephp12/Makefile
@@ -24,7 +24,7 @@ SLAVE_PORT_MODULES= REWRITE
CONFLICTS= cakephp-1.[13].*
NO_BUILD= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PHP= session
WANT_PHP_WEB= yes
DEFAULT_PHP_VER=5
diff --git a/www/cakephp13/Makefile b/www/cakephp13/Makefile
index 57e90a182d6b..faf7da4ed124 100644
--- a/www/cakephp13/Makefile
+++ b/www/cakephp13/Makefile
@@ -26,7 +26,7 @@ SLAVE_PORT_MODULES= REWRITE
CONFLICTS= cakephp-1.[12].* cakephp-2.*
NO_BUILD= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PHP= session
WANT_PHP_WEB= yes
DEFAULT_PHP_VER=5
diff --git a/www/cakephp21/Makefile b/www/cakephp21/Makefile
index 7d5337b41c62..72209a3645c7 100644
--- a/www/cakephp21/Makefile
+++ b/www/cakephp21/Makefile
@@ -25,7 +25,7 @@ SLAVE_PORT_MODULES= REWRITE
CONFLICTS= cakephp-1.* cakephp-2.2.*
NO_BUILD= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PHP= ctype session
WANT_PHP_WEB= yes
DEFAULT_PHP_VER=5
diff --git a/www/cakephp22/Makefile b/www/cakephp22/Makefile
index e7c0f986512d..1a26a5a80cfa 100644
--- a/www/cakephp22/Makefile
+++ b/www/cakephp22/Makefile
@@ -21,7 +21,7 @@ SLAVE_PORT_MODULES= REWRITE
CONFLICTS= cakephp-1.* cakephp-2.1.*
NO_BUILD= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PHP= ctype session
WANT_PHP_WEB= yes
DEFAULT_PHP_VER=5
diff --git a/www/diamanda/Makefile b/www/diamanda/Makefile
index 7a348b971cc5..af1bdd957429 100644
--- a/www/diamanda/Makefile
+++ b/www/diamanda/Makefile
@@ -27,7 +27,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
NO_BUILD= yes
USE_PYTHON= yes
-USE_GETTEXT= yes
+USES= gettext
SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
diff --git a/www/dillo-i18n/Makefile b/www/dillo-i18n/Makefile
index 86a3f4a99343..317f7e3560bd 100644
--- a/www/dillo-i18n/Makefile
+++ b/www/dillo-i18n/Makefile
@@ -43,7 +43,7 @@ CONFIGURE_ARGS= --enable-cookies --enable-threaded-dns \
CONFLICTS= dillo-[0-9].[0-9].[0-9]*
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB= NLS=""
CONFIGURE_ARGS+= --enable-nls
.else
diff --git a/www/elgg/Makefile b/www/elgg/Makefile
index 27e634acabba..0e20ad784766 100644
--- a/www/elgg/Makefile
+++ b/www/elgg/Makefile
@@ -16,7 +16,7 @@ COMMENT= Blogging and social networking platform
LICENSE= GPLv2
USE_PHP= mysql gd json soap dom xml
-USE_GETTEXT= yes
+USES= gettext
USE_ZIP= yes
NO_BUILD= yes
diff --git a/www/epiphany-extensions/Makefile b/www/epiphany-extensions/Makefile
index ad797c34aaf6..15981a7e8286 100644
--- a/www/epiphany-extensions/Makefile
+++ b/www/epiphany-extensions/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
CONFLICTS= epiphany-extensions-3.[0-9]*
-USE_GETTEXT= yes
+USES= gettext
USE_BZIP2= yes
USE_GNOME= gnomeprefix gnomehack intlhack
INSTALLS_OMF= yes
diff --git a/www/evolution-webcal/Makefile b/www/evolution-webcal/Makefile
index 1d3dcdffad32..d869476eef83 100644
--- a/www/evolution-webcal/Makefile
+++ b/www/evolution-webcal/Makefile
@@ -18,7 +18,7 @@ COMMENT= Webcal(endar) handler for gnome
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PERL5= yes
USE_GNOME= gnomeprefix gnomehack intlhack evolutiondataserver libgnomeui
GNU_CONFIGURE= yes
diff --git a/www/gallery/Makefile b/www/gallery/Makefile
index ce7e07f830df..45d158821e37 100644
--- a/www/gallery/Makefile
+++ b/www/gallery/Makefile
@@ -21,7 +21,7 @@ WANT_PHP_WEB= yes
.if !defined(WITHOUT_NLS)
USE_PHP+= gettext
-USE_GETTEXT= yes # Pet portlint
+USES+= gettext
LANGPACKS= af_ZA-1.5.2${EXTRACT_SUFX} \
ar_EG-1.5.1-cvs${EXTRACT_SUFX} \
diff --git a/www/gallery2/Makefile b/www/gallery2/Makefile
index f1fefe652c04..8fcd4fe4c7fa 100644
--- a/www/gallery2/Makefile
+++ b/www/gallery2/Makefile
@@ -43,7 +43,7 @@ RUN_DEPENDS+= pngtogd:${PORTSDIR}/graphics/gd
.if ${PORT_OPTIONS:MNLS}
USE_PHP+= gettext
-USE_GETTEXT= yes # Pet portlint
+USES+= gettext
.endif
.if ${PORT_OPTIONS:MNETPBM}
diff --git a/www/gallery3/Makefile b/www/gallery3/Makefile
index e78201608827..618ba76d0368 100644
--- a/www/gallery3/Makefile
+++ b/www/gallery3/Makefile
@@ -67,7 +67,7 @@ RUN_DEPENDS+= giftopnm:${PORTSDIR}/graphics/netpbm
.if ${PORT_OPTIONS:MNLS}
USE_PHP+= gettext
-USE_GETTEXT= yes # Pet portlint
+USES+= gettext
.endif
.if ${PORT_OPTIONS:MUNZIP}
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index 034e1b88a1ff..3cf2cc7bbf25 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_APACHE= 22
USE_XORG= sm
USE_GNOME= gnomeprefix gnomehack intlhack gtk20 gconf2 gnomedocutils nautilus2
diff --git a/www/gnome-web-photo/Makefile b/www/gnome-web-photo/Makefile
index bc2a64f262d0..fe2c815728ea 100644
--- a/www/gnome-web-photo/Makefile
+++ b/www/gnome-web-photo/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
USE_XZ= yes
USE_GNOME= gconf2 gnomehack gnomeprefix
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules \
diff --git a/www/google-appengine/Makefile b/www/google-appengine/Makefile
index f875f98c4ad5..358823780930 100644
--- a/www/google-appengine/Makefile
+++ b/www/google-appengine/Makefile
@@ -22,7 +22,7 @@ PROJECTHOST= googleappengine
USE_PYTHON= 2.7
USE_ZIP= yes
-USE_GETTEXT= yes
+USES= gettext
OPTIONS_DEFINE= EXAMPLES MYSQL
OPTIONS_DEFAULT= MYSQL
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index 3ac74e2fb805..b565f1505f5f 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup \
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
-USE_GETTEXT= yes
+USES= gettext
USE_BZIP2= yes
USE_XORG= xinerama xi xrandr xcursor xcomposite xdamage
USE_GMAKE= yes
diff --git a/www/horde3-ansel/Makefile b/www/horde3-ansel/Makefile
index bfe73227d9ae..f9209923da05 100644
--- a/www/horde3-ansel/Makefile
+++ b/www/horde3-ansel/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= horde@FreeBSD.org
COMMENT= Image gallery
USE_HORDE= base pkg-message
-USE_GETTEXT= yes
+USES= gettext
PORTDOCS= CHANGES CREDITS TODO README
.include "${.CURDIR}/../../www/horde3-base/bsd.horde.mk"
diff --git a/www/horde3-base/Makefile b/www/horde3-base/Makefile
index 183fd064696e..fd0166d92401 100644
--- a/www/horde3-base/Makefile
+++ b/www/horde3-base/Makefile
@@ -79,7 +79,7 @@ RUN_DEPENDS+= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date \
${PEARDIR}/Net/SMTP.php:${PORTSDIR}/net/pear-Net_SMTP \
${PEARDIR}/MDB2/Schema/Validate.php:${PORTSDIR}/databases/pear-MDB2_Schema
-USE_GETTEXT= yes
+USES= gettext
USE_PHP= ctype gettext session
.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
diff --git a/www/horde3-passwd/Makefile b/www/horde3-passwd/Makefile
index afd85398253a..7a09f01bf72e 100644
--- a/www/horde3-passwd/Makefile
+++ b/www/horde3-passwd/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= horde@FreeBSD.org
COMMENT= Password changing module
USE_HORDE= base
-USE_GETTEXT= yes
+USES= gettext
PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES TODO
.include "${.CURDIR}/../../www/horde3-base/bsd.horde.mk"
diff --git a/www/horde3-trean/Makefile b/www/horde3-trean/Makefile
index 233902a52cf0..41164173546f 100644
--- a/www/horde3-trean/Makefile
+++ b/www/horde3-trean/Makefile
@@ -17,7 +17,7 @@ COMMENT= Bookmark manager
USE_HORDE= base pkg-message
USE_BZIP2= yes
-USE_GETTEXT= yes
+USES= gettext
PORTDOCS= CHANGES CREDITS INSTALL TODO README
.include "${.CURDIR}/../../www/horde3-base/bsd.horde.mk"
diff --git a/www/horde3-wicked/Makefile b/www/horde3-wicked/Makefile
index a393679a194f..e1f1954c4bcc 100644
--- a/www/horde3-wicked/Makefile
+++ b/www/horde3-wicked/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Wiki module for Horde
USE_HORDE= base pkg-message
-USE_GETTEXT= yes
+USES= gettext
PORTDOCS= README CHANGES CREDITS INSTALL TODO
BUILD_DEPENDS+= ${PEARDIR}/Text/Wiki.php:${PORTSDIR}/www/pear-Text_Wiki
diff --git a/www/ikiwiki/Makefile b/www/ikiwiki/Makefile
index 40b6abd26902..598532415035 100644
--- a/www/ikiwiki/Makefile
+++ b/www/ikiwiki/Makefile
@@ -38,7 +38,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
LICENSE= GPLv2
PERL_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
OPTIONS= PO4A "Install translated underlays" On \
SEARCH "Install search backend" On \
diff --git a/www/libepc/Makefile b/www/libepc/Makefile
index b1648f6590b9..8977fcb8985c 100644
--- a/www/libepc/Makefile
+++ b/www/libepc/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GNOME= gnomeprefix gnomehack gtk20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/www/linkchecker/Makefile b/www/linkchecker/Makefile
index f41d078779ea..817cbd86e3a9 100644
--- a/www/linkchecker/Makefile
+++ b/www/linkchecker/Makefile
@@ -90,7 +90,7 @@ USE_APACHE_RUN= 22
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/www/llgal/Makefile b/www/llgal/Makefile
index 924ac08cb46e..2491281dfc76 100644
--- a/www/llgal/Makefile
+++ b/www/llgal/Makefile
@@ -28,7 +28,7 @@ RUN_DEPENDS= p5-Image-Size>=0:${PORTSDIR}/graphics/p5-Image-Size \
USE_BZIP2= yes
USE_PERL5= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
MAN1= llgal.1
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 7eb3c10c3ffa..399d21573c46 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -52,7 +52,7 @@ L_DOC= ${PREFIX}/share/doc/lynx
L_HELP= ${PREFIX}/share/lynx_help
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
CONFIGURE_ARGS+= --enable-nls
.else
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index d9720e8d2382..675fe98ce257 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -34,7 +34,7 @@ DEFAULT_COLORS_DESC= Colors support
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS='@comment '
.else
-USE_GETTEXT= yes
+USES+= gettext
USE_ICONV= yes
CONFIGURE_ARGS+=--enable-nls --with-libiconv-prefix="${LOCALBASE}"
PLIST_SUB+= NLS=''
diff --git a/www/neon29/Makefile b/www/neon29/Makefile
index 4a577fa7754b..a6e153e55b1f 100644
--- a/www/neon29/Makefile
+++ b/www/neon29/Makefile
@@ -58,7 +58,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
diff --git a/www/newsbeuter/Makefile b/www/newsbeuter/Makefile
index 269398c2ec91..e090c461435c 100644
--- a/www/newsbeuter/Makefile
+++ b/www/newsbeuter/Makefile
@@ -18,7 +18,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PERL5_BUILD=yes
USE_SQLITE= yes
USE_GNOME= libxml2
diff --git a/www/nscache/Makefile b/www/nscache/Makefile
index d36db55014c2..39b7a20ae010 100644
--- a/www/nscache/Makefile
+++ b/www/nscache/Makefile
@@ -20,7 +20,7 @@ COMMENT= Netscape cache browser
USE_GNOME= gnomehier gtk12
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG} --disable-gnome
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/www/pivotx/Makefile b/www/pivotx/Makefile
index b8d5df28e327..4fc7c084bbe2 100644
--- a/www/pivotx/Makefile
+++ b/www/pivotx/Makefile
@@ -30,7 +30,7 @@ PHPDOM_DESC= Use PHP:DOM instead of SimpleXML
WANT_PHP_WEB= yes
USE_PHP= session gettext xml tokenizer gd pcre
-USE_GETTEXT= yes
+USES+= gettext
.if ${PORT_OPTIONS:MPHPDOM}
USE_PHP+= dom
diff --git a/www/py-django-devel/Makefile b/www/py-django-devel/Makefile
index a17eee487a42..e74533a16556 100644
--- a/www/py-django-devel/Makefile
+++ b/www/py-django-devel/Makefile
@@ -20,7 +20,7 @@ LICENSE= BSD
SNAPSHOTDATE= 20130106
USE_XZ= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/www/py-django-mezzanine-filebrowser/Makefile b/www/py-django-mezzanine-filebrowser/Makefile
index 7e039c5f76d7..0c4f0efced22 100644
--- a/www/py-django-mezzanine-filebrowser/Makefile
+++ b/www/py-django-mezzanine-filebrowser/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= Fork of django-filebrowser for Mezzanine CMS
USE_PYTHON= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= filebrowser_safe
diff --git a/www/py-django-mezzanine-grappelli/Makefile b/www/py-django-mezzanine-grappelli/Makefile
index 5393f2879d9a..0f302264ef1b 100644
--- a/www/py-django-mezzanine-grappelli/Makefile
+++ b/www/py-django-mezzanine-grappelli/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= Fork of django-grappelli for Mezzanine CMS
USE_PYTHON= yes
-USE_GETTEXT= yes
+USES= gettext
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= grappelli_safe
diff --git a/www/py-django-mptt/Makefile b/www/py-django-mptt/Makefile
index 10eb560e9e0b..f7818b502eec 100644
--- a/www/py-django-mptt/Makefile
+++ b/www/py-django-mptt/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-
GITVERSION= 4310e7e
FETCH_ARGS= -Fpr
-USE_GETTEXT= yes
+USES= gettext
USE_PYDISTUTILS= yes
USE_PYTHON= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${GITVERSION}
diff --git a/www/py-django-registration/Makefile b/www/py-django-registration/Makefile
index 13c2256753c5..0431e52e68fa 100644
--- a/www/py-django-registration/Makefile
+++ b/www/py-django-registration/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.3:${PORTSDIR}/www/py-django
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-USE_GETTEXT= yes
+USES= gettext
CONFLICTS_INSTALL= pootle-*
diff --git a/www/py-django/Makefile b/www/py-django/Makefile
index b66e120329b1..0e158e6da770 100644
--- a/www/py-django/Makefile
+++ b/www/py-django/Makefile
@@ -15,7 +15,7 @@ COMMENT= High-level Python Web framework
LICENSE= BSD
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Django
diff --git a/www/py-django13/Makefile b/www/py-django13/Makefile
index 3570a49c4601..545526eb02e4 100644
--- a/www/py-django13/Makefile
+++ b/www/py-django13/Makefile
@@ -20,7 +20,7 @@ LICENSE= BSD
LATEST_LINK= ${PYTHON_PKGNAMEPREFIX}django13
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Django
diff --git a/www/py-django14/Makefile b/www/py-django14/Makefile
index 8f6302f3536d..f0a703becb9b 100644
--- a/www/py-django14/Makefile
+++ b/www/py-django14/Makefile
@@ -17,7 +17,7 @@ LICENSE= BSD
LATEST_LINK= ${PYTHON_PKGNAMEPREFIX}django14
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Django
diff --git a/www/py-formencode/Makefile b/www/py-formencode/Makefile
index 7d6052002633..22863631ebd3 100644
--- a/www/py-formencode/Makefile
+++ b/www/py-formencode/Makefile
@@ -17,7 +17,7 @@ COMMENT= HTML form validation, generation, and conversion package
USE_PYTHON= -2.7
USE_PYDISTUTILS= easy_install
-USE_GETTEXT= yes
+USES= gettext
PYDISTUTILS_PKGNAME= FormEncode
diff --git a/www/py-nevow/Makefile b/www/py-nevow/Makefile
index f80ef88962b0..1dac25a7b7bd 100644
--- a/www/py-nevow/Makefile
+++ b/www/py-nevow/Makefile
@@ -20,7 +20,7 @@ COMMENT= A web application templating system, based on the Twisted Woven
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
USE_TWISTED= web
-USE_GETTEXT= yes
+USES= gettext
PYDISTUTILS_PKGNAME= Nevow
SUB_FILES= pkg-message
diff --git a/www/py-prewikka/Makefile b/www/py-prewikka/Makefile
index 9cd87dc6e137..dd5951fae96d 100644
--- a/www/py-prewikka/Makefile
+++ b/www/py-prewikka/Makefile
@@ -20,7 +20,7 @@ USE_PYDISTUTILS= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/www/py-satchmo/Makefile b/www/py-satchmo/Makefile
index 16daf5725a59..9c5ed34ff584 100644
--- a/www/py-satchmo/Makefile
+++ b/www/py-satchmo/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.2.3:${PORTSDIR}/www/py-django \
${PYTHON_PKGNAMEPREFIX}django-signals-ahoy>=0:${PORTSDIR}/www/py-django-signals-ahoy \
${PYTHON_PKGNAMEPREFIX}django-threaded-multihost>=0:${PORTSDIR}/www/py-django-threaded-multihost
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYEASYINSTALL_EGG= Satchmo-${PORTVERSION}-${PYTHON_VERSION:S/thon//}.egg
diff --git a/www/py-turbogears/Makefile b/www/py-turbogears/Makefile
index 47a122755597..a0131d2bc4a4 100644
--- a/www/py-turbogears/Makefile
+++ b/www/py-turbogears/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cherrypy>=3.1.2:${PORTSDIR}/www/py-cherrypy
${PYTHON_PKGNAMEPREFIX}Genshi>=0.4.4:${PORTSDIR}/textproc/py-genshi \
${PYTHON_PKGNAMEPREFIX}TGScheduler>0:${PORTSDIR}/devel/py-TGScheduler
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= -2.7
USE_PYDISTUTILS= easy_install
diff --git a/www/retawq/Makefile b/www/retawq/Makefile
index 7a8c2545f814..bb169fd0956f 100644
--- a/www/retawq/Makefile
+++ b/www/retawq/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-0.2.6c
MAINTAINER= ports@FreeBSD.org
COMMENT= An interactive, multi-threaded web browser for text terminals
-USE_GETTEXT= yes
+USES= gettext
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --path-archprefix=${PREFIX} --path-prefix=${PREFIX} \
--enable-i18n --enable-local-cgi --enable-ipv6
diff --git a/www/roundup/Makefile b/www/roundup/Makefile
index 72ab483f3b06..f2305b1eb81c 100644
--- a/www/roundup/Makefile
+++ b/www/roundup/Makefile
@@ -11,7 +11,7 @@ COMMENT= Issue-Tracking System for Knowledge Workers
LICENSE= PSFL
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= yes
USE_PYDISTUTILS=yes
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
index fd3bdea02029..1cdc2d6578c9 100644
--- a/www/sitecopy/Makefile
+++ b/www/sitecopy/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
LIBS+= -lintl
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
diff --git a/www/snownews/Makefile b/www/snownews/Makefile
index 06919ac70024..4781ecd632fd 100644
--- a/www/snownews/Makefile
+++ b/www/snownews/Makefile
@@ -22,7 +22,7 @@ OPML_DESC= Outline Processor Markup Support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index f453164c10c3..fd84afa9c97f 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -47,7 +47,7 @@ PLIST_SUB+= M17N="@comment "
.endif
.if ${PORT_OPTIONS:MJAPANESE}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+= --enable-m17n --enable-japanese=E --with-migemo=yes gt_cv_func_gnugettext1_libintl=yes
DOCS_JP= ${DOCS} README.SSL README.cookie README.keymap README.mailcap \
README.menu README.migemo
diff --git a/www/wml/Makefile b/www/wml/Makefile
index b5fb829338a7..52b6190c6a45 100644
--- a/www/wml/Makefile
+++ b/www/wml/Makefile
@@ -31,7 +31,7 @@ BUILD_DEPENDS= lynx:${PORTSDIR}/www/lynx \
USE_PERL5= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
CONFIGURE_ARGS= --with-perl=${PERL5} --with-catdir=man \
--prefix=${PREFIX}
diff --git a/www/zend-framework/Makefile b/www/zend-framework/Makefile
index c67cd1edadd7..8696bc6ff2e2 100644
--- a/www/zend-framework/Makefile
+++ b/www/zend-framework/Makefile
@@ -17,7 +17,7 @@ COMMENT= A framework for developing PHP web applications
NO_BUILD= yes
USE_PHP= spl
WANT_PHP_WEB= yes
-USE_GETTEXT= yes
+USES= gettext
LICENSE= BSD