aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-02 18:21:05 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-02 18:21:05 +0000
commit0aad97bb5c24e162fa1f0e0fa87c8654f738ff52 (patch)
tree59a0148ef943ecb5bc12a830cc669c801d3c91f8 /www
parent9046e7300f8c066998aad575e838180bdf83371e (diff)
downloadports-0aad97bb5c24e162fa1f0e0fa87c8654f738ff52.tar.gz
ports-0aad97bb5c24e162fa1f0e0fa87c8654f738ff52.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/htmlobject/Makefile3
-rw-r--r--www/p5-Apache-Session-SQLite3/Makefile3
-rw-r--r--www/p5-Apache-Session-SharedMem/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-AutoRunmode/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-DebugScreen/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-HtmlTidy/Makefile3
-rw-r--r--www/p5-CGI-ArgChecker/Makefile3
-rw-r--r--www/p5-CGI-Builder/Makefile3
-rw-r--r--www/p5-CGI-Expand/Makefile3
-rw-r--r--www/p5-CGI-FastTemplate/Makefile3
-rw-r--r--www/p5-CGI-Response/Makefile3
-rw-r--r--www/p5-CGI-Upload/Makefile3
-rw-r--r--www/p5-CGI-modules/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-FormBuilder/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Params-Nested/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Scheduler/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile3
-rw-r--r--www/p5-Compress-LeadingBlankSpaces/Makefile3
-rw-r--r--www/p5-Data-Validate-URI/Makefile3
-rw-r--r--www/p5-FAQ-OMatic/Makefile3
-rw-r--r--www/p5-Geo-Caching/Makefile3
-rw-r--r--www/p5-HTML-Breadcrumbs/Makefile3
-rw-r--r--www/p5-HTML-Clean/Makefile3
-rw-r--r--www/p5-HTML-Pager/Makefile3
-rw-r--r--www/p5-HTML-Perlinfo/Makefile3
-rw-r--r--www/p5-HTML-QuickCheck/Makefile3
-rw-r--r--www/p5-HTML-SimpleParse/Makefile3
-rw-r--r--www/p5-HTML-StripScripts-Parser/Makefile3
-rw-r--r--www/p5-HTML-StripScripts/Makefile3
-rw-r--r--www/p5-HTML-Webmake/Makefile3
-rw-r--r--www/p5-HTTP-Server-Simple-PSGI/Makefile3
-rw-r--r--www/p5-Net-Akismet/Makefile3
-rw-r--r--www/p5-Nginx-ReadBody/Makefile3
-rw-r--r--www/p5-Template-Plugin-Markdown/Makefile3
-rw-r--r--www/p5-WWW-Link/Makefile3
-rw-r--r--www/p5-WebService-IMDB/Makefile3
-rw-r--r--www/p5-WebService-MoviePosterDB/Makefile3
-rw-r--r--www/p5-WebService-MusicBrainz/Makefile3
-rw-r--r--www/p5-WebService-Technorati/Makefile3
-rw-r--r--www/p5-libservlet/Makefile3
40 files changed, 80 insertions, 40 deletions
diff --git a/www/htmlobject/Makefile b/www/htmlobject/Makefile
index 6372ae2f5740..5e5ea2345f4b 100644
--- a/www/htmlobject/Makefile
+++ b/www/htmlobject/Makefile
@@ -18,7 +18,8 @@ COMMENT= HTML Document Object
BUILD_DEPENDS= p5-Data-FormValidator>=0:${PORTSDIR}/textproc/p5-Data-FormValidator \
p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTMLObject::Base.3 HTMLObject::Form.3 \
HTMLObject::FrameSet.3 HTMLObject::HDMLCard.3 \
diff --git a/www/p5-Apache-Session-SQLite3/Makefile b/www/p5-Apache-Session-SQLite3/Makefile
index 736dc298bfd0..e405d176de91 100644
--- a/www/p5-Apache-Session-SQLite3/Makefile
+++ b/www/p5-Apache-Session-SQLite3/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Apache-Session>=0:${PORTSDIR}/www/p5-Apache-Session \
p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Apache::Session::SQLite3.3
diff --git a/www/p5-Apache-Session-SharedMem/Makefile b/www/p5-Apache-Session-SharedMem/Makefile
index b5a3010bc265..ef137d975103 100644
--- a/www/p5-Apache-Session-SharedMem/Makefile
+++ b/www/p5-Apache-Session-SharedMem/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-IPC-Cache>=0:${PORTSDIR}/devel/p5-IPC-Cache \
p5-Apache-Session>=0:${PORTSDIR}/www/p5-Apache-Session
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Apache::Session::Store::SharedMem.3 \
Apache::Session::SharedMem.3
diff --git a/www/p5-CGI-Application-Plugin-AutoRunmode/Makefile b/www/p5-CGI-Application-Plugin-AutoRunmode/Makefile
index 177896707a69..9ea4441188c2 100644
--- a/www/p5-CGI-Application-Plugin-AutoRunmode/Makefile
+++ b/www/p5-CGI-Application-Plugin-AutoRunmode/Makefile
@@ -13,7 +13,8 @@ COMMENT= CGI::App plugin to automatically register runmodes
BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Application::Plugin::AutoRunmode.3 \
CGI::Application::Plugin::AutoRunmode::FileDelegate.3
diff --git a/www/p5-CGI-Application-Plugin-DebugScreen/Makefile b/www/p5-CGI-Application-Plugin-DebugScreen/Makefile
index 7e01779c5936..7b6c7bc787cd 100644
--- a/www/p5-CGI-Application-Plugin-DebugScreen/Makefile
+++ b/www/p5-CGI-Application-Plugin-DebugScreen/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Application::Plugin::DebugScreen.3
diff --git a/www/p5-CGI-Application-Plugin-HtmlTidy/Makefile b/www/p5-CGI-Application-Plugin-HtmlTidy/Makefile
index e607be216647..0ba3e039dfc8 100644
--- a/www/p5-CGI-Application-Plugin-HtmlTidy/Makefile
+++ b/www/p5-CGI-Application-Plugin-HtmlTidy/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-CGI-Application>4.01:${PORTSDIR}/www/p5-CGI-Application \
p5-HTML-Tidy>=1.08:${PORTSDIR}/textproc/p5-HTML-Tidy
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Application::Plugin::HtmlTidy.3
diff --git a/www/p5-CGI-ArgChecker/Makefile b/www/p5-CGI-ArgChecker/Makefile
index 9a9b9efdddf0..30651405ef89 100644
--- a/www/p5-CGI-ArgChecker/Makefile
+++ b/www/p5-CGI-ArgChecker/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl module implementing a cgi interface to String::Checker
BUILD_DEPENDS= p5-String-Checker>=0:${PORTSDIR}/devel/p5-String-Checker
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::ArgChecker.3
diff --git a/www/p5-CGI-Builder/Makefile b/www/p5-CGI-Builder/Makefile
index 455c69fa0f61..b4dd4a3098fe 100644
--- a/www/p5-CGI-Builder/Makefile
+++ b/www/p5-CGI-Builder/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-IO-Util>=0:${PORTSDIR}/devel/p5-IO-Util \
p5-OOTools>=0:${PORTSDIR}/devel/p5-OOTools
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Bundle::CGI::Builder::Complete.3 \
CGI::Builder.3 \
diff --git a/www/p5-CGI-Expand/Makefile b/www/p5-CGI-Expand/Makefile
index c26f403b2777..852772c41b87 100644
--- a/www/p5-CGI-Expand/Makefile
+++ b/www/p5-CGI-Expand/Makefile
@@ -13,7 +13,8 @@ COMMENT= Convert flat hash to nested data using TT2's dot convention
BUILD_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Expand.3
diff --git a/www/p5-CGI-FastTemplate/Makefile b/www/p5-CGI-FastTemplate/Makefile
index 9455aa193852..86b744ff62cb 100644
--- a/www/p5-CGI-FastTemplate/Makefile
+++ b/www/p5-CGI-FastTemplate/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module for manage templates and parses templates
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::FastTemplate.3
diff --git a/www/p5-CGI-Response/Makefile b/www/p5-CGI-Response/Makefile
index 250398905f31..3b71f7a12904 100644
--- a/www/p5-CGI-Response/Makefile
+++ b/www/p5-CGI-Response/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module allowing response construction for CGI applications
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Response.3
diff --git a/www/p5-CGI-Upload/Makefile b/www/p5-CGI-Upload/Makefile
index e80b8cf67b77..39b8e9400315 100644
--- a/www/p5-CGI-Upload/Makefile
+++ b/www/p5-CGI-Upload/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-HTTP-BrowserDetect>=0:${PORTSDIR}/www/p5-HTTP-BrowserDetect \
p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Upload.3
diff --git a/www/p5-CGI-modules/Makefile b/www/p5-CGI-modules/Makefile
index b7724f7c6123..ba224d035081 100644
--- a/www/p5-CGI-modules/Makefile
+++ b/www/p5-CGI-modules/Makefile
@@ -17,7 +17,8 @@ COMMENT= Modules for perl5, for use in writing CGI scripts
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Base.3 CGI::BasePlus.3 CGI::Carp.3 CGI::Form.3 \
CGI::MiniSvr.3 CGI::Request.3
diff --git a/www/p5-Catalyst-Plugin-FormBuilder/Makefile b/www/p5-Catalyst-Plugin-FormBuilder/Makefile
index d1762c969833..eaefe620acc1 100644
--- a/www/p5-Catalyst-Plugin-FormBuilder/Makefile
+++ b/www/p5-Catalyst-Plugin-FormBuilder/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-CGI-FormBuilder>=3.02:${PORTSDIR}/www/p5-CGI-FormBuilder
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::FormBuilder.3
diff --git a/www/p5-Catalyst-Plugin-Params-Nested/Makefile b/www/p5-Catalyst-Plugin-Params-Nested/Makefile
index b509a81d797c..e5f061db3ec8 100644
--- a/www/p5-Catalyst-Plugin-Params-Nested/Makefile
+++ b/www/p5-Catalyst-Plugin-Params-Nested/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= p5-CGI-Expand>=1.06:${PORTSDIR}/www/p5-CGI-Expand \
p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime
TEST_DEPENDS= p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::Params::Nested.3 \
Catalyst::Plugin::Params::Nested::Expander.3
diff --git a/www/p5-Catalyst-Plugin-Scheduler/Makefile b/www/p5-Catalyst-Plugin-Scheduler/Makefile
index e149077ee725..0a3b62585e63 100644
--- a/www/p5-Catalyst-Plugin-Scheduler/Makefile
+++ b/www/p5-Catalyst-Plugin-Scheduler/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::Scheduler.3
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile b/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile
index 32bb55c11d1c..d98f9d09602b 100644
--- a/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile
+++ b/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Catalyst-Plugin-Session>=0.27:${PORTSDIR}/www/p5-Catalyst-Plug
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::Session::Store::Delegate.3
diff --git a/www/p5-Compress-LeadingBlankSpaces/Makefile b/www/p5-Compress-LeadingBlankSpaces/Makefile
index 906bad13d8a2..d1ba48fed945 100644
--- a/www/p5-Compress-LeadingBlankSpaces/Makefile
+++ b/www/p5-Compress-LeadingBlankSpaces/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl class to compress leading blank spaces in web content
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Compress::LeadingBlankSpaces.3
diff --git a/www/p5-Data-Validate-URI/Makefile b/www/p5-Data-Validate-URI/Makefile
index e3c817616801..1115a526fabe 100644
--- a/www/p5-Data-Validate-URI/Makefile
+++ b/www/p5-Data-Validate-URI/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Data-Validate-Domain>=0:${PORTSDIR}/dns/p5-Data-Validate-Domai
RUN_DEPENDS= p5-Data-Validate-Domain>=0:${PORTSDIR}/dns/p5-Data-Validate-Domain \
p5-Data-Validate-IP>=0:${PORTSDIR}/net-mgmt/p5-Data-Validate-IP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Validate::URI.3
diff --git a/www/p5-FAQ-OMatic/Makefile b/www/p5-FAQ-OMatic/Makefile
index 6f4e2d1662de..7be3ee621529 100644
--- a/www/p5-FAQ-OMatic/Makefile
+++ b/www/p5-FAQ-OMatic/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl API to manipulate FAQ-O-Matics
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= FAQ::OMatic::API.3
diff --git a/www/p5-Geo-Caching/Makefile b/www/p5-Geo-Caching/Makefile
index 0226929453e0..d29d020b4739 100644
--- a/www/p5-Geo-Caching/Makefile
+++ b/www/p5-Geo-Caching/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Geo::Caching.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/www/p5-HTML-Breadcrumbs/Makefile b/www/p5-HTML-Breadcrumbs/Makefile
index e7260fb7bca4..1621649efc07 100644
--- a/www/p5-HTML-Breadcrumbs/Makefile
+++ b/www/p5-HTML-Breadcrumbs/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Module to produce HTML 'breadcrumb trails'
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Breadcrumbs.3
diff --git a/www/p5-HTML-Clean/Makefile b/www/p5-HTML-Clean/Makefile
index 1628ccba0af0..e7bfcc832bcd 100644
--- a/www/p5-HTML-Clean/Makefile
+++ b/www/p5-HTML-Clean/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Cleans up HTML code for web browsers, not humans
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= htmlclean.1
MAN3= HTML::Clean.3
diff --git a/www/p5-HTML-Pager/Makefile b/www/p5-HTML-Pager/Makefile
index 77219d1a81a1..2c20450200de 100644
--- a/www/p5-HTML-Pager/Makefile
+++ b/www/p5-HTML-Pager/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl module for handling CGI HTML paging of arbitrary data
BUILD_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Pager.3
diff --git a/www/p5-HTML-Perlinfo/Makefile b/www/p5-HTML-Perlinfo/Makefile
index 5e69ff0c0685..fd08214c0703 100644
--- a/www/p5-HTML-Perlinfo/Makefile
+++ b/www/p5-HTML-Perlinfo/Makefile
@@ -18,7 +18,8 @@ LICENSE_COMB= dual
LICENSE= ART10 GPLv1
PERL5= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= perlinfo.1
MAN3= HTML::Perlinfo.3 HTML::Perlinfo::HTML.3 \
diff --git a/www/p5-HTML-QuickCheck/Makefile b/www/p5-HTML-QuickCheck/Makefile
index c88209fa73c3..c5c02a32b394 100644
--- a/www/p5-HTML-QuickCheck/Makefile
+++ b/www/p5-HTML-QuickCheck/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple and fast HTML syntax checking package for perl 4 and perl 5
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::QuickCheck.3
diff --git a/www/p5-HTML-SimpleParse/Makefile b/www/p5-HTML-SimpleParse/Makefile
index 3020c5ac79f1..26182694f3ab 100644
--- a/www/p5-HTML-SimpleParse/Makefile
+++ b/www/p5-HTML-SimpleParse/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= HTML::SimpleParse - a bare-bones HTML parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::SimpleParse.3
diff --git a/www/p5-HTML-StripScripts-Parser/Makefile b/www/p5-HTML-StripScripts-Parser/Makefile
index 6495ec9323e9..2f1a20768a2a 100644
--- a/www/p5-HTML-StripScripts-Parser/Makefile
+++ b/www/p5-HTML-StripScripts-Parser/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-HTML-Parser>=3.56:${PORTSDIR}/www/p5-HTML-Parser \
p5-HTML-StripScripts>=1.05:${PORTSDIR}/www/p5-HTML-StripScripts
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::StripScripts::Parser.3
diff --git a/www/p5-HTML-StripScripts/Makefile b/www/p5-HTML-StripScripts/Makefile
index 2d9ff337a4eb..7b1aa7e41ca2 100644
--- a/www/p5-HTML-StripScripts/Makefile
+++ b/www/p5-HTML-StripScripts/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Strip scripting constructs out of HTML
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::StripScripts.3
diff --git a/www/p5-HTML-Webmake/Makefile b/www/p5-HTML-Webmake/Makefile
index 357d0de851bc..df383aa81aa2 100644
--- a/www/p5-HTML-Webmake/Makefile
+++ b/www/p5-HTML-Webmake/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= webmake.1
MAN3= HTML::WebMake.3 HTML::WebMake::MetadataContent.3 HTML::WebMake::PerlCodeLibrary.3 \
diff --git a/www/p5-HTTP-Server-Simple-PSGI/Makefile b/www/p5-HTTP-Server-Simple-PSGI/Makefile
index 392cb6db7d4d..885af6a34b8c 100644
--- a/www/p5-HTTP-Server-Simple-PSGI/Makefile
+++ b/www/p5-HTTP-Server-Simple-PSGI/Makefile
@@ -16,7 +16,8 @@ COMMENT= PSGI handler for HTTP::Server::Simple
RUN_DEPENDS= p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Server::Simple::PSGI.3
diff --git a/www/p5-Net-Akismet/Makefile b/www/p5-Net-Akismet/Makefile
index 76ea6eedb3d7..8b4dc45448e6 100644
--- a/www/p5-Net-Akismet/Makefile
+++ b/www/p5-Net-Akismet/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-libwww>=5.09:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS+= p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
.endif
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Akismet.3
diff --git a/www/p5-Nginx-ReadBody/Makefile b/www/p5-Nginx-ReadBody/Makefile
index ae2bdc03ba1b..e3b52c6e45c3 100644
--- a/www/p5-Nginx-ReadBody/Makefile
+++ b/www/p5-Nginx-ReadBody/Makefile
@@ -26,7 +26,8 @@ RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx-devel
RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
.endif
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
pre-everything::
@${CAT} ${PKGMESSAGE}
diff --git a/www/p5-Template-Plugin-Markdown/Makefile b/www/p5-Template-Plugin-Markdown/Makefile
index 353153860cd5..df23892000cc 100644
--- a/www/p5-Template-Plugin-Markdown/Makefile
+++ b/www/p5-Template-Plugin-Markdown/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
p5-Text-Markdown>=0:${PORTSDIR}/textproc/p5-Text-Markdown
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Plugin::Markdown.3
diff --git a/www/p5-WWW-Link/Makefile b/www/p5-WWW-Link/Makefile
index 0eb242dcecb8..c54879c5d3e4 100644
--- a/www/p5-WWW-Link/Makefile
+++ b/www/p5-WWW-Link/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Link.3 \
WWW::Link::Change.3 \
diff --git a/www/p5-WebService-IMDB/Makefile b/www/p5-WebService-IMDB/Makefile
index 1f49291d4b69..ab78d9145cba 100644
--- a/www/p5-WebService-IMDB/Makefile
+++ b/www/p5-WebService-IMDB/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::IMDB.3 \
WebService::IMDB::Birth.3 \
diff --git a/www/p5-WebService-MoviePosterDB/Makefile b/www/p5-WebService-MoviePosterDB/Makefile
index 844f5b54e865..27949f382d8e 100644
--- a/www/p5-WebService-MoviePosterDB/Makefile
+++ b/www/p5-WebService-MoviePosterDB/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::MoviePosterDB.3 \
WebService::MoviePosterDB::Movie.3 \
diff --git a/www/p5-WebService-MusicBrainz/Makefile b/www/p5-WebService-MusicBrainz/Makefile
index e795d40e632a..11000c98c0ae 100644
--- a/www/p5-WebService-MusicBrainz/Makefile
+++ b/www/p5-WebService-MusicBrainz/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::MusicBrainz.3 \
WebService::MusicBrainz::Artist.3 \
diff --git a/www/p5-WebService-Technorati/Makefile b/www/p5-WebService-Technorati/Makefile
index 17a3c9873d96..0131b1fc5732 100644
--- a/www/p5-WebService-Technorati/Makefile
+++ b/www/p5-WebService-Technorati/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::Technorati.3 \
WebService::Technorati::ApiQuery.3 \
diff --git a/www/p5-libservlet/Makefile b/www/p5-libservlet/Makefile
index 1e269da6e7c7..8df051c7fd8f 100644
--- a/www/p5-libservlet/Makefile
+++ b/www/p5-libservlet/Makefile
@@ -18,7 +18,8 @@ COMMENT= Servlet API for Perl
BUILD_DEPENDS= p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Servlet.3 \
Servlet::Config.3 \