aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-05 06:30:32 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-05 06:30:32 +0000
commit5c05bf1526cc7aa97c9180ebf7f30db036ca380d (patch)
tree43723d9e12f5e66cc4c3ccfb2fe572dcb56bbb8d /www
parent23771c7b3d379b99ba6191447ab8c66f85930f33 (diff)
downloadports-5c05bf1526cc7aa97c9180ebf7f30db036ca380d.tar.gz
ports-5c05bf1526cc7aa97c9180ebf7f30db036ca380d.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mimetex/Makefile47
-rw-r--r--www/mimetex/distinfo3
-rw-r--r--www/mimetex/pkg-descr11
-rw-r--r--www/mimetex/pkg-message6
-rw-r--r--www/mimetex/pkg-plist7
6 files changed, 75 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index de78c706365a..1d6aa5a46e78 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -257,6 +257,7 @@
SUBDIR += mhonarc
SUBDIR += micro_httpd
SUBDIR += middleman
+ SUBDIR += mimetex
SUBDIR += mini_httpd
SUBDIR += mkapachepw
SUBDIR += mknmz-wwwoffle
diff --git a/www/mimetex/Makefile b/www/mimetex/Makefile
new file mode 100644
index 000000000000..41a097974b2c
--- /dev/null
+++ b/www/mimetex/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: mimetex
+# Date created: 2006-02-03
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mimetex
+PORTVERSION= 1.60
+CATEGORIES= www math
+MASTER_SITES= http://www.forkosh.com/ \
+ http://nivi.interfree.it/distfiles/${DIST_SUBDIR}/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= nivit@email.it
+COMMENT= A CGI script that lets you embed LaTeX math in your HTML pages
+
+NO_WRKSUBDIR= yes
+USE_APACHE= yes
+USE_ZIP= yes
+
+FETCH_CMD= /usr/bin/fetch -rR # see PR bin/76134
+LN_OPTS= -sf
+
+CGI_BIN= ${PREFIX}/www/cgi-bin/
+CGI_PRG= ${PORTNAME}.cgi
+WWW_DIR= ${PREFIX}/www/data/mimetex/
+
+do-build:
+ cd ${WRKDIR};\
+ ${CC} ${CFLAGS} -DAA mimetex.c gifsave.c -lm -o ${CGI_PRG}
+
+do-install:
+ ${MKDIR} ${CGI_BIN}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${CGI_PRG} ${CGI_BIN}/${CGI_PRG}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.html ${DOCSDIR}
+ ${MKDIR} ${WWW_DIR}
+ ${LN} ${LN_OPTS} ${DOCSDIR}/${PORTNAME}.html ${WWW_DIR}/index.html
+.endif
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mimetex/distinfo b/www/mimetex/distinfo
new file mode 100644
index 000000000000..40b6fe54737e
--- /dev/null
+++ b/www/mimetex/distinfo
@@ -0,0 +1,3 @@
+MD5 (mimetex/1.60/mimetex.zip) = 9b201b0e36d83b2713caa9048958be82
+SHA256 (mimetex/1.60/mimetex.zip) = 7cd7de6f62471301ebf58490e00a00ccc60728d629c2cdfcfb167dfe063e691b
+SIZE (mimetex/1.60/mimetex.zip) = 643731
diff --git a/www/mimetex/pkg-descr b/www/mimetex/pkg-descr
new file mode 100644
index 000000000000..87a46d2940a1
--- /dev/null
+++ b/www/mimetex/pkg-descr
@@ -0,0 +1,11 @@
+MimeTeX, licensed under the gpl, lets you easily embed LaTeX math in
+your html pages. It parses a LaTeX math expression and immediately
+emits the corresponding gif image, rather than the usual TeX dvi.
+And mimeTeX is an entirely separate little program that doesn't
+use TeX or its fonts in any way. It's just one cgi that you put in
+your site's cgi-bin/ directory, with no other dependencies.
+It's easy to use. Just place an html <img> tag in your document
+wherever you want to see the corresponding LaTeX expression.
+
+Author: John Forkosh <john@forkosh.com>
+WWW: http://www.forkosh.com/mimetex.html
diff --git a/www/mimetex/pkg-message b/www/mimetex/pkg-message
new file mode 100644
index 000000000000..98ccdbf1b073
--- /dev/null
+++ b/www/mimetex/pkg-message
@@ -0,0 +1,6 @@
+
+*********************************************************
+
+ See online documentation at http://localhost/mimetex/
+
+*********************************************************
diff --git a/www/mimetex/pkg-plist b/www/mimetex/pkg-plist
new file mode 100644
index 000000000000..aa825baadb45
--- /dev/null
+++ b/www/mimetex/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/mimetex.html
+%%PORTDOCS%%www/data/mimetex/index.html
+www/cgi-bin/mimetex.cgi
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm www/data/mimetex
+@dirrmtry www/cgi-bin